Re: BGP synchro problem (LONG)

From: Thekkethala (thek@xxxxxxxxxxxx)
Date: Fri Nov 09 2001 - 16:20:22 GMT-3


   
Just a thought..

OSPF does not resdistribute external routes learnt, directly into BGP - this
is a form of loop prevention.

To force OSPF to redistribute all external routes into BGP yu may use a
statement something like

Router bgp 1
redistribute ospf 1 .......match external 1 match external 2

i dont know if this helps - ...

Ajit
----- Original Message -----
From: <SFeldberg@edeltacom.com>
To: "Chua, Parry" <Parry.Chua@compaq.com>
Cc: <ccielab@groupstudy.com>; "'Liekun Ye'" <liekun@chinaweal.com>;
<nobody@groupstudy.com>
Sent: Friday, November 09, 2001 12:06 PM
Subject: RE: BGP synchro problem (LONG)

> This is EVIL.
>
> The same topology, same network redistributed into OSPF and EIGRP. As
> Liekun stated earlier, EIGRP allows the BGP route to become synchronized,
> OSPF does not. End result is that this network will not be considered
> "best" by R2 when using OSPF as the IGP.
>
> To answer the question
> > Is the nexthop 133.3.13.3 reachable from R2?
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> O IA 100.100.1.0 [110/75] via 133.3.12.1, 00:07:27, Serial0
> 133.3.0.0/16 is variably subnetted, 7 subnets, 2 masks
> C 133.3.2.0/24 is directly connected, Loopback0
> D 133.3.3.0/24 [90/2297856] via 133.3.23.3, 00:22:16, Serial1
> D 133.3.1.0/24 [90/2297856] via 133.3.12.1, 00:22:14, Serial0
> C 133.3.12.0/24 is directly connected, Serial0
> O 133.3.12.1/32 [110/64] via 133.3.12.1, 00:45:09, Serial0
> D 133.3.13.0/24 [90/2195456] via 133.3.12.1, 00:22:16, Serial0
> [90/2195456] via 133.3.23.3, 00:22:16, Serial1
> C 133.3.23.0/24 is directly connected, Serial1
>
> RTR-2#ping 133.3.13.3
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 133.3.13.3, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
>
> Here's what it looks like when it works properly with EIGRP
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> D EX 100.100.1.0 [170/2560512256] via 133.3.23.3, 00:02:42, Serial1
> 133.3.0.0/24 is subnetted, 6 subnets
> C 133.3.2.0 is directly connected, Loopback0
> D 133.3.3.0 [90/2297856] via 133.3.23.3, 00:04:38, Serial1
> D 133.3.1.0 [90/2297856] via 133.3.12.1, 00:04:38, Serial0
> C 133.3.12.0 is directly connected, Serial0
> D 133.3.13.0 [90/2195456] via 133.3.12.1, 00:04:38, Serial0
> [90/2195456] via 133.3.23.3, 00:04:38, Serial1
> C 133.3.23.0 is directly connected, Serial1
>
> RTR-2#sh ip bgp
> BGP table version is 2, local router ID is 133.3.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *>i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
> When OSPF is the IGP
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> O E2 100.100.1.0 [110/20] via 133.3.23.3, 00:00:15, Serial1
> 133.3.0.0/24 is subnetted, 6 subnets
> C 133.3.2.0 is directly connected, Loopback0
> D 133.3.3.0 [90/2297856] via 133.3.23.3, 00:21:00, Serial1
> D 133.3.1.0 [90/2297856] via 133.3.12.1, 00:21:00, Serial0
> C 133.3.12.0 is directly connected, Serial0
> D 133.3.13.0 [90/2195456] via 133.3.12.1, 00:21:00, Serial0
> [90/2195456] via 133.3.23.3, 00:21:00, Serial1
> C 133.3.23.0 is directly connected, Serial1
>
> RTR-2#sh ip bgp
> BGP table version is 3, local router ID is 133.3.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> * i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
>
> I also tried to change the LSA type of the 100.100.1.0 network in OSPF
>
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> O IA 100.100.1.0 [110/65] via 133.3.23.3, 00:00:32, Serial1
> 133.3.0.0/24 is subnetted, 6 subnets
> C 133.3.2.0 is directly connected, Loopback0
> D 133.3.3.0 [90/2297856] via 133.3.23.3, 00:40:23, Serial1
> D 133.3.1.0 [90/2297856] via 133.3.12.1, 00:40:23, Serial0
> C 133.3.12.0 is directly connected, Serial0
> D 133.3.13.0 [90/2195456] via 133.3.12.1, 00:40:23, Serial0
> [90/2195456] via 133.3.23.3, 00:40:23, Serial1
> C 133.3.23.0 is directly connected, Serial1
>
>
> Still, no love...
>
>
> RTR-2#sh ip bgp
> BGP table version is 1, local router ID is 133.3.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> * i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
>
> Again, when the route is advertised by EIGRP
>
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> D EX 100.100.1.0 [170/2560512256] via 133.3.23.3, 00:00:08, Serial1
> 133.3.0.0/24 is subnetted, 6 subnets
> C 133.3.2.0 is directly connected, Loopback0
> D 133.3.3.0 [90/2297856] via 133.3.23.3, 01:03:11, Serial1
> D 133.3.1.0 [90/2297856] via 133.3.12.1, 01:03:11, Serial0
> C 133.3.12.0 is directly connected, Serial0
> D 133.3.13.0 [90/2195456] via 133.3.12.1, 01:03:11, Serial0
> [90/2195456] via 133.3.23.3, 01:03:11, Serial1
> C 133.3.23.0 is directly connected, Serial1
>
>
> Routing table entry detail
>
>
> RTR-2#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 2
> Paths: (1 available, best #1)
> Not advertised to any peer
> Local
> 133.3.13.3 (metric 2195456) from 133.3.12.1 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal,
> synchronized, best, ref 2
> Originator: 133.3.3.3, Cluster list: 133.3.1.1
>
>
> Again, when the route is advertised by OSPF
>
>
> RTR-2#sh ip route
>
> 100.0.0.0/24 is subnetted, 1 subnets
> O IA 100.100.1.0 [110/65] via 133.3.23.3, 00:01:39, Serial1
> 133.3.0.0/24 is subnetted, 6 subnets
> C 133.3.2.0 is directly connected, Loopback0
> D 133.3.3.0 [90/2297856] via 133.3.23.3, 01:02:00, Serial1
> D 133.3.1.0 [90/2297856] via 133.3.12.1, 01:02:00, Serial0
> C 133.3.12.0 is directly connected, Serial0
> D 133.3.13.0 [90/2195456] via 133.3.12.1, 01:02:00, Serial0
> [90/2195456] via 133.3.23.3, 01:02:00, Serial1
> C 133.3.23.0 is directly connected, Serial1
>
> Routing table entry detail
>
> RTR-2#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 0
> Paths: (1 available, no best path)
> Not advertised to any peer
> Local
> 133.3.13.3 (metric 2195456) from 133.3.12.1 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal, not
> synchronized, ref 2
> Originator: 133.3.3.3, Cluster list: 133.3.1.1
>
>
> Notice that the network is "not synchronized"
>
>
> All IOS are current:
>
> RTR-1#sh ver
> Cisco Internetwork Operating System Software
> IOS (tm) 2500 Software (C2500-JOS56I-L), Version 12.0(19), RELEASE
SOFTWARE
> (fc1)
>
> RTR-3#sh ver
> Cisco Internetwork Operating System Software
> IOS (tm) 2500 Software (C2500-DS-L), Version 12.0(20), RELEASE SOFTWARE
> (fc1)
>
> RTR-2#sh ver
> Cisco Internetwork Operating System Software
> IOS (tm) 2500 Software (C2500-JOS56I-L), Version 12.0(19), RELEASE
SOFTWARE
> (fc1)
>
>
> More info about routing and BGP table entries:
>
> With OSPF
>
>
> RTR-2#sh ip bgp
> Network Next Hop Metric LocPrf Weight Path
> * i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
> RTR-1#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 2
> Paths: (1 available, best #1)
> Advertised to non peer-group peers:
> 133.3.12.2
> Local, (Received from a RR-client)
> 133.3.13.3 from 133.3.13.3 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal,
> synchronized, best, ref 2
>
> RTR-1#sh ip route 100.100.1.0
> Routing entry for 100.100.1.0/24
> Known via "ospf 100", distance 110, metric 11, type inter area
> Redistributing via ospf 100
> Last update from 133.3.13.3 on Ethernet0, 00:17:19 ago
> Routing Descriptor Blocks:
> * 133.3.13.3, from 133.3.3.3, 00:17:19 ago, via Ethernet0
> Route metric is 11, traffic share count is 1
>
> RTR-2#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 0
> Paths: (1 available, no best path)
> Not advertised to any peer
> Local
> 133.3.13.3 (metric 74) from 133.3.12.1 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal, not
> synchronized, ref 2
> Originator: 133.3.3.3, Cluster list: 133.3.1.1
>
> RTR-2#sh ip route 100.100.1.0
> Routing entry for 100.100.1.0/24
> Known via "ospf 100", distance 110, metric 75, type inter area
> Redistributing via ospf 100
> Last update from 133.3.12.1 on Serial0, 00:20:03 ago
> Routing Descriptor Blocks:
> * 133.3.12.1, from 133.3.3.3, 00:20:03 ago, via Serial0
> Route metric is 75, traffic share count is 1
>
>
> With EIGRP
>
>
> RTR-2#sh ip bgp
> Network Next Hop Metric LocPrf Weight Path
> *>i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
> RTR-1#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 5
> Paths: (1 available, best #1)
> Advertised to non peer-group peers:
> 133.3.12.2
> Local, (Received from a RR-client)
> 133.3.13.3 from 133.3.13.3 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal,
> synchronized, best, ref 2
>
> RTR-1#sh ip route 100.100.1.0
> Routing entry for 100.100.1.0/24
> Known via "eigrp 1", distance 170, metric 2560025856, type external
> Redistributing via eigrp 1
> Last update from 133.3.13.3 on Ethernet0, 00:01:06 ago
> Routing Descriptor Blocks:
> * 133.3.13.3, from 133.3.13.3, 00:01:06 ago, via Ethernet0
> Route metric is 2560025856, traffic share count is 1
> Total delay is 1010 microseconds, minimum bandwidth is 1 Kbit
> Reliability 1/255, minimum MTU 1 bytes
> Loading 1/255, Hops 1
>
>
> RTR-2#sh ip bgp
> Network Next Hop Metric LocPrf Weight Path
> *>i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
> RTR-2#sh ip bgp 100.100.1.0
> BGP routing table entry for 100.100.1.0/24, version 2
> Paths: (1 available, best #1)
> Not advertised to any peer
> Local
> 133.3.13.3 (metric 2195456) from 133.3.12.1 (133.3.3.3)
> Origin incomplete, metric 10, localpref 100, valid, internal,
> synchronized, best, ref 2
> Originator: 133.3.3.3, Cluster list: 133.3.1.1
>
> RTR-2#sh ip route 100.100.1.0
> Routing entry for 100.100.1.0/24
> Known via "eigrp 1", distance 170, metric 2560512256, type external
> Redistributing via eigrp 1
> Last update from 133.3.23.3 on Serial1, 00:00:41 ago
> Routing Descriptor Blocks:
> * 133.3.23.3, from 133.3.23.3, 00:00:41 ago, via Serial1
> Route metric is 2560512256, traffic share count is 1
> Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
> Reliability 1/255, minimum MTU 1 bytes
> Loading 1/255, Hops 1
>
>
> The only difference I can see in the output between the protocols is in
the
> routing descriptor blocks.
>
> OSPF on R2
>
> * 133.3.12.1, from 133.3.3.3, 00:20:03 ago, via Serial0
>
> EIGRP on R2
>
> * 133.3.23.3, from 133.3.23.3, 00:00:41 ago, via Serial1
>
> When the "* x.x.x.x, from x.x.x.x" values match, the route is becomes
> synchronized. This is now "driving me to the brink of drink" as another
> member colorfully stated in an earlier post.... any thoughts???!
>
> Stephen Feldberg
> e ^ deltacom
> phone: 678.835.5437
> sfeldberg@edeltacom.com
>
>
>
> "Chua, Parry"
> <Parry.Chua@c To: "'Liekun Ye'"
<liekun@chinaweal.com>,
> ompaq.com> SFeldberg@edeltacom.com
> Sent by: cc: ccielab@groupstudy.com,
nobody@groupstudy.com
> nobody@groups Subject: RE: BGP synchro
problem
> tudy.com
>
>
> 11/08/2001
> 10:28 PM
> Please
> respond to
> "Chua, Parry"
>
>
>
>
>
>
> Hi,
>
> Since R1 is the RR for R2 and R3, in R1 bgp table, it has receive the
> update
> from R3. R1 has
> send the update to R2 bgp as expected , only R2 does not consider it is
> valid. It the next
> hop 133.3.13.3 reachable from R2 ?
>
>
> > Parry Chua
> >
>
>
> -----Original Message-----
> From: Liekun Ye [mailto:liekun@chinaweal.com]
> Sent: Friday, November 09, 2001 10:06 AM
> To: SFeldberg@edeltacom.com
> Cc: ccielab@groupstudy.com; nobody@groupstudy.com
> Subject: RE: BGP synchro problem
>
>
> Ok, Here is my real configure, Pls help me to figure it out. TKS.
>
> Here is my config on R1/R2/R3
>
> Configure on R1
> =========================================
> hostname RTR-1
> !
> !
> ip subnet-zero
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 133.3.1.1 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-point
> !
> interface Ethernet0
> ip address 133.3.13.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet1
> no ip address
> no ip directed-broadcast
> !
> interface Serial0
> ip address 133.3.12.1 255.255.255.0
> no ip directed-broadcast
> clockrate 2000000
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router ospf 100
> network 133.3.34.0 0.0.0.255 area 0
> network 133.3.0.0 0.0.255.255 area 0
> !
> router bgp 100
> neighbor 133.3.12.2 remote-as 100
> neighbor 133.3.12.2 route-reflector-client
> neighbor 133.3.13.3 remote-as 100
> neighbor 133.3.13.3 route-reflector-client
> no auto-summary
> !
> ip classless
> >>>>show ip bgp <<<< output
> BGP table version is 2, local router ID is 133.3.1.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *>i100.100.1.0/24 133.3.13.3 10 100 0 ?
>
> Configure on R2
> ===========================================
> interface Loopback0
> ip address 133.3.2.2 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-point
> !
> interface Serial0
> ip address 133.3.12.2 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial1
> ip address 133.3.23.2 255.255.255.0
> no ip directed-broadcast
> clockrate 2000000
> !
> interface TokenRing0
> no ip address
> no ip directed-broadcast
> shutdown
> ethernet-transit-oui 90-compatible
> ring-speed 16
> source-bridge 10 1 100
> source-bridge spanning 100
> !
> router ospf 100
> network 133.3.0.0 0.0.255.255 area 0
> !
> router bgp 100
> bgp router-id 133.3.2.2
> neighbor 133.3.12.1 remote-as 100
> !
> ip classless
> !
> >>>>show ip bgp <<<<
> BGP table version is 1, local router ID is 133.3.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> * i100.100.1.0/24 133.3.13.3 10 100 0 ?
> ======
> It's valid, but not best, so will not advertise to another peer, if there
> are any.
> ======
>
> Configure On R3
> ===================================
> interface Loopback0
> ip address 133.3.3.3 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-point
> !
> interface Loopback1
> ip address 100.100.1.1 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-point
> !
> interface Ethernet0/0
> ip address 133.3.13.3 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial0/0
> ip address 133.3.23.3 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet0/1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router ospf 100
> router-id 133.3.3.3
> redistribute connected subnets route-map con2ospf
> network 133.3.0.0 0.0.255.255 area 0
> !
> router bgp 100
> bgp router-id 133.3.3.3
> redistribute connected metric 10 route-map con2bgp
> neighbor 133.3.13.1 remote-as 100
> no auto-summary
> !
> ip classless
> ip http server
> !
> access-list 1 permit 100.100.1.0
> route-map con2bgp permit 10
> match ip address 1
> !
> route-map con2ospf permit 10
> match ip address 1
>
> >>>>show ip bgp <<<<output
> BGP table version is 6, local router ID is 133.3.3.3
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 100.100.1.0/24 0.0.0.0 10 32768 ?
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> SFeldberg@edeltacom.com
> Sent: Friday, November 09, 2001 4:54 AM
> To: Liekun Ye
> Cc: ccielab@groupstudy.com; nobody@groupstudy.com
> Subject: Re: BGP synchro problem
>
>
> You say that you have redistributed the route into BGP on R3. Is this
> where are you redistributing 100.100.1.0 into OSPF as well? I have a
hunch
> that it is your redistribution of this network is the answer to your
> question about why EIGRP works but OSPF does not. Remember that the key
to
> synchronization is having a valid entry in the routing table. If the BGP
> route is invalid on R2, then you need to investigate why R2 is not
learning
> about 100.100.1.0 from the OSPF protocol.
>
> Steve
>
>
>
>
> "Liekun Ye"
>
> <liekun@china To: <ccielab@groupstudy.com>
>
> weal.com> cc:
>
> Sent by: Subject: BGP synchro problem
>
> nobody@groups
>
> tudy.com
>
>
>
>
>
> 11/08/2001
>
> 07:33 AM
>
> Please
>
> respond to
>
> "Liekun Ye"
>
>
>
>
>
>
>
>
>
> Hi, group,
>
> I have a tough problem in bgp configuration. Look at the scenario
> below,
> Assume that bgp synchronization is enabled by default. R1 act as RR, a
> connected
> route 100.100.1.0/24 is redistribute into bgp 1 at R3; all three router
> runs ospf,
> this ibgp route is valid at R1, but shows invalid at R2, also
> 100.100.1.0/24 is
> redistributed to ospf to make igp route synchronize with bgp route. If use
> eigrp
> to replace ospf as a igp, everything is ok. why ?
>
> Any suggestion is appreciated!
>
> +--------+ +-------+
>
> | | | |
>
> | R1 |------------------| R2 |
>
> +--------+ +---|---+
>
> | |
>
> | |
>
> | |
>
> | |
>
> | +-------+
>
> | | |
>
> +----------------------| R3 |100.100.1.0/24 redis into bgp
>
> | |
>
> +-------+
>
>
> Liekun Ye
> Nov. 3, 2001



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:11 GMT-3