OSPF Route Selection

From: Dennis Dumont (dfdumont@xxxxxxxxx)
Date: Fri Oct 26 2001 - 12:19:04 GMT-3


   
I hope this is simple, but I can't find anything that
works.

I'm unsing a six router pod. R5 is the frame
head-end, R2 and R3 are multipoint to that headend.
The frame is area 0. R6 is connected to R2 via
serial. R4 is connected to R5 via separate P-t-P
link. R4 and R6 share a common ethernet. Here's the
issue:
R6 is learning about the local routes on R4 via RIP
across the ethnet and redistributing them into OSPF,
area 10 which is the serial link to R2. I've set the
default metrics such that R2 should prefer R6 for
routes to R4, but no matter what I set R5 is
preferred.

Is this an area 0 preferrence? or is there something
I'm missing.

Here's R6 config:
Current configuration:
!
version 11.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r6
!
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
 ip address 153.67.60.1 255.255.255.0
!
interface Ethernet0
 ip address 153.67.46.6 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 216.37.59.86 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
!
interface Serial1
 ip address 153.67.26.6 255.255.255.0
 no ip directed-broadcast
 no fair-queue
!
router ospf 100
 redistribute rip
 network 153.67.26.0 0.0.0.255 area 10
 network 153.67.60.0 0.0.0.255 area 12
 default-metric 6000
 area 10 virtual-link 153.67.100.193
 area 12 range 153.67.60.0 255.255.255.0
!
router rip
 passive-interface Loopback0
 passive-interface Serial0
 passive-interface Serial1
 network 153.67.0.0
 distance 90
!
ip classless
alias exec i show ip route
alias exec x show ipx route
alias exec c configure terminal
alias exec d debug
alias exec u undebug all
alias exec ci clear ip route *
alias exec sf show frame pvc
alias exec so show ip ospf
alias exec sb show ip bgp
alias exec si show ip interface brief
alias exec sr show run
alias exec son show ip ospf neighbor
alias exec sov show ip ospf virtual
alias exec sbn show ip bgp neighbor
alias exec sdp show dslw peer
alias exec sdc show dlsw capab
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

Here's R2:
Current configuration : 1914 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 153.67.100.33 255.255.255.224
!
interface Loopback1
 ip address 153.67.100.65 255.255.255.224
!
interface Loopback2
 ip address 153.67.100.129 255.255.255.224
!
interface Loopback3
 ip address 153.67.100.193 255.255.255.224
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0.35 point-to-point
 ip address 153.67.235.2 255.255.255.0
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay interface-dlci 205
!
interface Serial1
 ip address 153.67.26.2 255.255.255.0
 no fair-queue
 clockrate 64000
!
interface TokenRing0
 ip address 65.114.31.34 255.255.255.192
 ring-speed 16
!
router eigrp 100
 passive-interface Serial0.35
 passive-interface Serial1
 passive-interface TokenRing0
 network 153.67.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 100
 log-adjacency-changes
 area 10 virtual-link 153.67.26.6
 summary-address 153.67.100.0 255.255.255.0
 redistribute eigrp 100 subnets
 network 65.114.31.0 0.0.0.255 area 3
 network 153.67.26.0 0.0.0.255 area 10
 network 153.67.235.0 0.0.0.255 area 0
 default-metric 9002
!
ip classless
ip http server
!
!
alias exec i show ip route
alias exec x show ipx route
alias exec c configure terminal
alias exec d debug
alias exec u undebug all
alias exec ci clear ip route *
alias exec sf show frame pvc
alias exec so show ip ospf
alias exec sb show ip bgp
alias exec si show ip interface brief
alias exec sr show run
alias exec son show ip ospf neighbor
alias exec sov show ip ospf virtual
alias exec sbn show ip bgp neighbor
alias exec sdp show dslw peer
alias exec sdc show dlsw capab
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 no login
!
end

Note that R6 is using R2 as a virtual-link to area 0.
I've done some LSA/SPF/Tree debugs on both R2 and R6
after a 'clear ip rout *', and noted that R6 doesn't
ever send R2 an LSA for the 153.67.4x.x routes (all
the routes on R4 are 153.67.4x.x). I'd send that but
its lengthy.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:25 GMT-3