RE: BGP Problem

From: Willy Schoots (w.schoots@xxxxxxxxx)
Date: Tue Oct 23 2001 - 03:54:16 GMT-3


   
Hi Rajeev,

You should look at your BGP table and your IP routing table. The first entry
41.0.0.0 has as origin ? --> implies that this was redistributed into BGP
(either RIP or static). Your network statement is incorrect as you do not
have 41.0.0.0 /24 in your routing table (I assume). RIP will redistribute
41.0.0.0 into BGP and this is where your entry comes from in the BGP table

In your second example you have changed the network statement which now is
working (41.1.1.0 /24 is directly connected) for 41.1.1.0 which has the
origin set to i --> implies network statement. Still your redistribution
works as well --> 2 entries into your BGP table

You should carefully review how the network statement works especially the
difference using:
- network 41.0.0.0
or
- network 41.0.0.0 255.255.255.0

Cheers,

Willy Schoots

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Rajeev Siddappa
Sent: Tuesday, October 23, 2001 6:47 AM
To: ccielab@groupstudy.com
Subject: BGP Problem

Hi friends,

I was working on the Boot camp lab two. I faced this
strange problem.

This is the config I have

> 41.0.0.0 0.0.0.0 0
32768 ?
R4#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
enable password cisco
!
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 44.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 ip address 41.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 173.168.40.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 100.100.100.1 255.255.255.0
 no ip directed-broadcast
 no keepalive
 ring-speed 4
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface PCbus0
 no ip address
 no ip directed-broadcast
 shutdown
!
router rip
 network 41.0.0.0
!
router bgp 1
 no synchronization
 network 44.0.0.0 mask 255.255.255.0
 redistribute static
 redistribute rip
 neighbor 173.168.40.1 remote-as 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 173.168.40.1
ip route 0.0.0.0 0.0.0.0 Null0
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

AND MY SHOW IP BGP WILL SHOW ONLY

R4# SH IP BGP
BGP table version is 2, local router ID is 44.1.1.1
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 41.0.0.0 0.0.0.0 0
32768 ?
R4#

but when I configure it like this

router bgp 1
 no synchronization
 network 44.1.1.0 mask 255.255.255.0
 redistribute static
 redistribute rip
 neighbor 173.168.40.1 remote-as 1

MY SHOW IP BGP WILL SHOW

4#sh ip bgp
BGP table version is 3, local router ID is 44.1.1.1
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 41.0.0.0 0.0.0.0 0
32768 ?
*> 44.1.1.0/24 0.0.0.0 0
32768 i
R4#

why is it behaving like this.

Please help me and explain me.

Thank you,

Rajeev.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:23 GMT-3