Re: BGP Problem

From: Brian Hescock (bhescock@xxxxxxxxx)
Date: Tue Oct 23 2001 - 02:17:49 GMT-3


   
Rajeev,
    In the first configuration you had "network 40.0.0.0 mask
255.255.255.0" but you didn't have an interface with that mask nor
learned via another protocol, static route, etc.. In the second example
you had "network 44.1.1.0 mask 255.255.255.0" and that matched interface
lo0 so it was injected into bgp. And the reason you see 41.1.1.0 is
because in later versions of code if you use "redistribute rip" it will
redistribute a directly connected interface that is part of rip, even
though the route is known as "directly connected" and not as a "rip" rip
route. Normally you would need to do "redistribute connected" to get
it into bgp in that situation but either the default behavior has
changed for redistributing rip or it's a bug since it works as expected
in 11.2 code but has this new behavior in 12.1 and 12.2 (I haven't had
time to check yet and I don't normally work with rip so I hadn't noticed
this change in behavior until very recently). There may already be some
e-mails about that in the archive. I'll try to find some time to
research it in the next day or two and will let you know, it's bugging
me. (no pun intended) Someone on the list may already know and will
surely correct me... ;-)

Brian

Rajeev Siddappa wrote:

>Hi friends,
>
>I was working on the Boot camp lab two. I faced this
>strange problem.
>
>This is the config I have
>
>>41.0.0.0 0.0.0.0 0
>>
>32768 ?
>R4#sh run
>Building configuration...
>
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname R4
>!
>enable password cisco
>!
>ip subnet-zero
>!
>!
>!
>!
>!
>interface Loopback0
> ip address 44.1.1.1 255.255.255.0
> no ip directed-broadcast
>!
>interface Loopback1
> ip address 41.1.1.1 255.255.255.0
> no ip directed-broadcast
>!
>interface Serial0
> ip address 173.168.40.2 255.255.255.0
> no ip directed-broadcast
>!
>interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
>!
>interface TokenRing0
> ip address 100.100.100.1 255.255.255.0
> no ip directed-broadcast
> no keepalive
> ring-speed 4
>!
>interface BRI0
> no ip address
> no ip directed-broadcast
> shutdown
>!
>interface PCbus0
> no ip address
> no ip directed-broadcast
> shutdown
>!
>router rip
> network 41.0.0.0
>!
>router bgp 1
> no synchronization
> network 44.0.0.0 mask 255.255.255.0
> redistribute static
> redistribute rip
> neighbor 173.168.40.1 remote-as 1
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 173.168.40.1
>ip route 0.0.0.0 0.0.0.0 Null0
>!
>!
>!
>line con 0
> transport input none
>line aux 0
>line vty 0 4
> password cisco
> login
>!
>end
>
>AND MY SHOW IP BGP WILL SHOW ONLY
>
>
>
>R4# SH IP BGP
>BGP table version is 2, local router ID is 44.1.1.1
>Status codes: s suppressed, d damped, h history, *
>valid, > best, i - internal
>Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf
>Weight Path
>*> 41.0.0.0 0.0.0.0 0
>32768 ?
>R4#
>
>but when I configure it like this
>
>
>router bgp 1
> no synchronization
> network 44.1.1.0 mask 255.255.255.0
> redistribute static
> redistribute rip
> neighbor 173.168.40.1 remote-as 1
>
>MY SHOW IP BGP WILL SHOW
>
>4#sh ip bgp
>BGP table version is 3, local router ID is 44.1.1.1
>Status codes: s suppressed, d damped, h history, *
>valid, > best, i - internal
>Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf
>Weight Path
>*> 41.0.0.0 0.0.0.0 0
>32768 ?
>*> 44.1.1.0/24 0.0.0.0 0
>32768 i
>R4#
>
>why is it behaving like this.
>
>Please help me and explain me.
>
>Thank you,
>
>Rajeev.
>



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:23 GMT-3