From: perkinsr@xxxxxxxxxxxxxx
Date: Mon Oct 15 2001 - 23:10:16 GMT-3
Here is a config from the cd, according to it there should be nothing
special to be done at all between ether and token and FDDI and serial. Just
throw them all into the same bridge group. In this setup IP is routed and
everything else is bridged. This is exactly what I want to do, it just
doesn't seem to work. Mabe I will try again tommarow.
interface tokenring 0
ip address 131.108.1.1 255.255.255.0
bridge-group 1
!
interface fddi 0
ip address 131.108.2.1 255.255.255.0
bridge-group 1
!
interface ethernet 0
ip address 192.31.7.26 255.255.255.240
bridge-group 1
!
interface serial 0
ip address 192.31.7.34 255.255.255.240
bridge-group 1
!
interface ethernet 1
ip address 192.31.7.65 255.255.255.240
bridge-group 1
!
bridge 1 protocol dec
-----Original Message-----
From: Brian Lodwick [mailto:xpranax@hotmail.com]
Sent: Monday, October 15, 2001 4:19 PM
To: perkinsr@WellsFargo.COM
Cc: ccielab@groupstudy.com
Subject: RE: IRB issues from lab 8
I hate bridging!
Good luck Ray. I'm going to go home now. I haven't been able to get it to
work either. I just remembered we reconfigred our Token-Ring switch the
other day and I don't know what the bridge number is. I'll come in early
tomorrow and get everything worked out with that and reconfigure everything.
I was going for the idea of using source-route bridging on the Token-Ring
connection between r1 and r7, and transparent bridging on the serial link
between r1 and r5, then doing SR/TLB on r1 to go between the two.
>>>Brian
>From: perkinsr@WellsFargo.COM
>Reply-To: perkinsr@WellsFargo.COM
>To: xpranax@hotmail.com
>CC: ccielab@groupstudy.com
>Subject: RE: IRB issues from lab 8
>Date: Mon, 15 Oct 2001 15:54:14 -0700
>
>Ok, here is the latest. I guess I do have time for this...
>
>
> BVI1 BVI1
> | |
>-----R5----------------------R1----------------------R7--t5/3
> s0 s1 to0 t5/0
>
>
>R1 is doing SR/TLB and IRB, R5 is IRB still and R7 is not doing any
>bridging. In this setup nothing works at all. When I ping from R1 to R7,
>R7 gets encap failed trying to reply. When I ping from R5 to R1 nothing
>happens, I haven't spent a lot time on that.
>
>When I ping from R5 to R1, the BVI's mac shows up in R1s bridge table, and
>R7s mac is also in the bridge table.
>
>Looks like two problems, R7 can't get back to R1 and R1 isn't dealing with
>the IPX traffic from R5 for some reason.
>
>configs:
>R5:
>
>ipx routing 0000.0000.0005
>!
>interface Ethernet0
> ip address 137.20.64.5 255.255.240.0
> no ip directed-broadcast
> ip accounting output-packets
> no logging event subif-link-status
> ipx network 695
>!
>interface Serial1
> ip address 137.20.25.1 255.255.255.0
> no ip directed-broadcast
> ip accounting output-packets
> no logging event subif-link-status
> bridge-group 1
>!
>interface BVI1
> no ip address
> no logging event subif-link-status
> ipx network 700
>!
>ipx router eigrp 10
> network 5130
> network 5004
> network 695
>!
>!
>ipx router rip
> no network 695
> no network 5130
> no network 5004
>!
>bridge irb
>bridge 1 protocol ieee
> bridge 1 route ip
> bridge 1 route ipx
> no bridge 1 bridge ip
>
>
>
>
>
>R1
>ipx routing 0000.0000.0001
>!
> source-bridge ring-group 10
> source-bridge transparent 10 3 1 1
> !
> process-max-time 200
> !
> interface Serial0
> ip address 137.20.25.2 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> clockrate 64000
> bridge-group 1
>!
>interface TokenRing0
> ip address 137.20.10.1 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> ring-speed 16
> multiring all
> source-bridge 1 1 10
>!
>interface BVI1
> mac-address 0000.0000.0001
> no ip address
> ipx encapsulation SAP
> ipx network 700
>!
>bridge irb
>bridge 1 protocol ieee
> bridge 1 route ip
> no bridge 1 bridge ip
>
>
>R7
>ipx routing 0000.0000.0007
>!
>source-bridge ring-group 100
>!
>interface TokenRing5/0
> mac-address 0000.0000.00ff
> ip address 5.5.5.5 255.255.255.0 secondary
> ip address 137.20.10.70 255.255.255.0
> ipx network 700
> no ipx route-cache
> ring-speed 16
> multiring all
> source-bridge 1 1 3
>!
>!
>interface TokenRing5/3
> mac-address 0000.0000.00ff
> ip address 172.168.70.1 255.255.255.0
> ring-speed 16
> source-bridge 10 1 100
>!
>
>
>
>
>-----Original Message-----
>From: Brian Lodwick [mailto:xpranax@hotmail.com]
>Sent: Monday, October 15, 2001 12:20 PM
>To: perkinsr@WellsFargo.COM
>Cc: ccielab@groupstudy.com
>Subject: RE: IRB issues from lab 8
>
>
>I'm sorry I am at work and had to go to a meeting, and I was writing
>quickly
>
>without analyzing your information very accurately. I didn't catch that
>good
>
>point you had- no ethernet involved.
>It would seem like in your scenario you would have to use source-route
>bridging on the Token-Ring. I believe it's an either or thing with SRT and
>SR/TLB.
>I would think you would have to configure a ring-group, reconfigure the
>Token-Ring interface to use source-route bridging, and point the next hop
>ring to the ring-group, then add the SR/TLB stuff?
>Have you come up with anything else?
>
>R1
>source-bridge transparent 1000 50 1 1
>!
>source-bridge ring-group 1000
>!
>interface Serial0
> ip address 137.20.25.2 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> clockrate 64000
> bridge-group 1
>!
>interface TokenRing0
> ip address 137.20.10.1 255.255.255.0
> no ip route-cache
> no ip mroute-cache
> ring-speed 16
> source-bridge 10 1 1000
>
> >>>Brian
>
>
> >From: perkinsr@WellsFargo.COM
> >To: xpranax@hotmail.com, perkinsr@WellsFargo.COM
> >CC: ccielab@groupstudy.com
> >Subject: RE: IRB issues from lab 8
> >Date: Mon, 15 Oct 2001 11:46:50 -0700
> >
> >Brian, I don't think you caught that this is SERIAL to TOKEN. There is
>no
> >Ethernet.
> >
> >However, I was under the impression you could just bridge from token to
> >ether if you were doing transparent bridging on the token interface. I
> >have
> >been assuming this is what is done on a cat with both token and ether
> >ports,
> >but I could be wrong. I also think that serial bridging is more like
> >ethernet than serial as far as address formats and whatnot, so I would
> >guess
> >your points about ethernet are still valid.
> >
> >Here is the questions then, how can you configure SR/TLB when you have no
> >SRB to translate through. This is one of the things that lead me to
> >believe
> >that token and ethernet could be bridged transparently without any more
> >config. I don't know...
> >
> >Ray
> >
> >
> >
> >-----Original Message-----
> >From: Brian Lodwick [mailto:xpranax@hotmail.com]
> >Sent: Monday, October 15, 2001 11:00 AM
> >To: perkinsr@WellsFargo.COM
> >Cc: ccielab@groupstudy.com
> >Subject: RE: IRB issues from lab 8
> >
> >
> >It would be logical that RIP updates would work and not pings if SR/TLB
>was
> >not configured. I know you can transparently bridge Token-Ring frames,
>but
> >you cannot just Trnasparently bridge Ethernet frames into Token-Ring. You
> >must translate. SRT is only for going from Token-Ring to Token-Ring.
> >
> > >>>Brian
> >
> >
> > >From: perkinsr@WellsFargo.COM
> > >To: xpranax@hotmail.com
> > >CC: ccielab@groupstudy.com
> > >Subject: RE: IRB issues from lab 8
> > >Date: Mon, 15 Oct 2001 10:55:55 -0700
> > >
> > >These are good points, but my impressin was that Because I have not
> > >configured SRB on the token interface and have configured a bridge
>group
> >I
> > >should be doing transparent bridging over the token interface. The MTU
> > >could be an issue but I don't think it would affect my 100 byte pings.
>I
> > >am
> > >bridiging from Serial to token, but those are still valid issues. I
>just
> > >don't see why this isn't working. Especially when it sort of works,
>RIP
> > >broadcasts are getting through and the route tables are full.
> > >
> > >To be clear I am routing IP and bridging IPX on R1.
> > >
> > >Thanks for your input,
> > >Ray
> > >
> > >
> > >-----Original Message-----
> > >From: Brian Lodwick [mailto:xpranax@hotmail.com]
> > >Sent: Monday, October 15, 2001 10:49 AM
> > >To: perkinsr@WellsFargo.COM
> > >Cc: ccielab@groupstudy.com
> > >Subject: Re: IRB issues from lab 8
> > >
> > >
> > >I'm sorry looks like I jumped a little too fast there. I guess I
> >should've
> > >made sure you trying to bridge IPX from r5 to r7?
> > >If yes, my response should be correct. Also I believe you will run into
> >an
> > >issue bridging between the Ethernet and Token-Ring networks.
> > >Won't you have to configure SR/TLB on r1 since you are trying to bridge
> > >from
> > >
> > >Ethernet to Token-Ring?
> > >Also I believe you will want to assure the max MTU all around is 1500
>so
> > >that you don't get an oversized frame on the Ethernet segment from the
> > >Token-Ring segment?
> > >
> > > >>>Brian
> > >
> > >
> > > >From: perkinsr@WellsFargo.COM
> > > >Reply-To: perkinsr@WellsFargo.COM
> > > >To: ccielab@groupstudy.com
> > > >Subject: IRB issues from lab 8
> > > >Date: Mon, 15 Oct 2001 10:21:01 -0700
> > > >
> > > >I cannot get IRB to work. Here is the IRB scenario from lab 8, the
> >only
> > > >differance is there is token instead of ether between R1 and R7.
> > > >
> > > >
> > > > BVI1
> > > > |
> > > >-----R5----------------------R1----------------------R7--t5/3
> > > > s0 s1 to0 t5/0
> > > >
> > > >
> > > >
> > > >This is tough, I can't ipx ping from R7 to R5, but routing info is
> > >passed.
> > > >R7 all routes beyond R5, R7 is a stub, but net 701 (off t5/3) is
> >visible
> > > >from R5. Pings will not work though. I was thinking frame type
> > > >concic/non-concical type problems. I tried making the MAC of t5/3
> >0.0.ff
> > > >so
> > > >that it would be the same either way, but that didn't work. The BVI1
> >on
> > >R5
> > > >is set to SAP frame type just like the token interface on R7.
> > > >
> > > >Help....
> > > >
> > > >
> > > >
> > > >configs:
> > > >R5
> > > >ipx routing 0000.0000.0005
> > > >!
> > > >interface Serial1
> > > > ip address 137.20.25.1 255.255.255.0
> > > > no ip directed-broadcast
> > > > ip accounting output-packets
> > > > no logging event subif-link-status
> > > > bridge-group 1
> > > >!
> > > >interface BVI1
> > > > no ip address
> > > > no logging event subif-link-status
> > > > ipx encapsulation SAP
> > > > ipx network 700
> > > >!
> > > >ipx router eigrp 10
> > > > network 5130
> > > > network 5004
> > > > network 695
> > > >!
> > > >!
> > > >ipx router rip
> > > > no network 5130
> > > > no network 5004
> > > > no network 695
> > > >!
> > > >bridge irb
> > > >bridge 1 protocol ieee
> > > > bridge 1 route ip
> > > > bridge 1 route ipx
> > > > no bridge 1 bridge ip
> > > >
> > > >R1
> > > >!
> > > >interface Serial0
> > > > ip address 137.20.25.2 255.255.255.0
> > > > no ip route-cache
> > > > no ip mroute-cache
> > > > clockrate 64000
> > > > bridge-group 1
> > > >!
> > > >interface TokenRing0
> > > > ip address 137.20.10.1 255.255.255.0
> > > > no ip route-cache
> > > > no ip mroute-cache
> > > > ring-speed 16
> > > > bridge-group 1
> > > >!
> > > >bridge 1 protocol ieee
> > > >
> > > >R7
> > > >ipx routing 0000.0000.0007
> > > >!
> > > >interface TokenRing5/0
> > > > ip address 5.5.5.5 255.255.255.0 secondary
> > > > ip address 137.20.10.70 255.255.255.0
> > > > ipx network 700
> > > > ring-speed 16
> > > >!
> > > >interface TokenRing5/3
> > > > ip address 172.168.70.1 255.255.255.0
> > > > ipx network 701
> > > > ring-speed 16
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:19 GMT-3