RE: igrp and loopback interface

From: ¾çö¿õ\ (y1700@xxxxxxxxxxxx)
Date: Sun Oct 14 2001 - 03:23:50 GMT-3


   
My full configuration is here.

r1:

interface Loopback0
 ip address 133.1.40.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 150.100.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 133.1.110.4 255.255.255.0
 ip access-group 103 in
 encapsulation frame-relay
 ip split-horizon
 frame-relay map ip 133.1.110.5 100
 frame-relay lmi-type ansi
!
router igrp 1
 redistribute connected metric 1000 100 255 1 1500
 passive-interface FastEthernet0/0
 network 133.1.0.0
!
access-list 103 deny tcp 192.36.57.0 7.26.0.255 any
access-list 103 deny tcp 160.33.0.0 0.0.127.255 any
access-list 103 deny ip 176.30.0.0 0.0.254.255 any
access-list 103 permit ip any any

debug ip igrp tr:

4d00h: IGRP: sending update to 255.255.255.255 via Serial0/0 (133.1.110.4)
4d00h: subnet 133.1.40.0, metric=10100
4d00h: network 150.100.0.0, metric=110
4d00h: IGRP: sending update to 255.255.255.255 via Loopback0 (133.1.40.1)
4d00h: subnet 133.1.5.0, metric=12100
4d00h: subnet 133.1.6.0, metric=12100
4d00h: subnet 133.1.12.0, metric=12100
4d00h: subnet 133.1.20.0, metric=12100
4d00h: subnet 133.1.23.0, metric=12100
4d00h: subnet 133.1.56.0, metric=12100
4d00h: subnet 133.1.100.0, metric=12100
4d00h: subnet 133.1.110.0, metric=10100
4d00h: network 172.51.0.0, metric=12100v
4d00h: network 150.100.0.0, metric=110
4d00h: IGRP: received update from 133.1.110.5 on Serial0/0
4d00h: subnet 133.1.5.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.6.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.12.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.20.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.23.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.56.0, metric 12100 (neighbor 10100)
4d00h: subnet 133.1.100.0, metric 12100 (neighbor 10100)
4d00h: network 172.51.0.0, metric 12100 (neighbor 10100)
4d00h: network 150.100.0.0, metric 10486 (neighbor 8

r2:

interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
 interface Serial0.1 point-to-point
 ip address 133.1.110.5 255.255.255.0
 frame-relay interface-dlci 100
!

router ospf 1
 summary-address 133.1.100.0 255.255.255.0
 redistribute connected subnets
 redistribute igrp 1 subnets
 network 133.1.100.0 0.0.0.15 area 0
 network 133.1.56.0 0.0.0.255 area 5
 network 133.1.33.2 0.0.0.0 area 0
 neighbor 133.1.100.3 priority 1
 neighbor 133.1.100.2 priority 1
 area 0 authentication message-digest
 area 5 virtual-link 133.1.56.1 message-digest-key 1 md5 cisco
!
router igrp 1
 redistribute connected metric 1000 100 255 1 1500
 redistribute ospf 1 metric 1000 100 255 1 1500
 passive-interface BRI0
 passive-interface Serial0.2
 network 133.1.0.0

debug ip igrp tr:

IGRP: sending update to 255.255.255.255 via Ethernet0 (133.1.5.1)
      subnet 133.1.6.0, metric=10100
      subnet 133.1.12.0, metric=10100
      subnet 133.1.20.0, metric=10100
      subnet 133.1.23.0, metric=10100
      subnet 133.1.40.0, metric=12100
      subnet 133.1.56.0, metric=10100
      subnet 133.1.100.0, metric=10100
      subnet 133.1.110.0, metric=10100
      network 172.51.0.0, metric=10100
      network 150.100.0.0, metric=8486
IGRP: sending update to 255.255.255.255 via Serial0.1 (133.1.110.5)
      subnet 133.1.5.0, metric=10100
      subnet 133.1.6.0, metric=10100
      subnet 133.1.12.0, metric=10100
      subnet 133.1.20.0, metric=10100
      subnet 133.1.23.0, metric=10100
      subnet 133.1.56.0, metric=10100
      subnet 133.1.100.0, metric=10100
      network 172.51.0.0, metric=10100
      network 150.100.0.0, metric=8486
IGRP: sending update to 255.255.255.255 via Serial1 (133.1.56.2)
      subnet 133.1.5.0, metric=10100
      subnet 133.1.6.0, metric=10100
      subnet 133.1.12.0, metric=10100
      subnet 133.1.20.0, metric=10100
      subnet 133.1.23.0, metric=10100
      subnet 133.1.40.0, metric=12100
      subnet 133.1.100.0, metric=10100
      subnet 133.1.110.0, metric=10100
      network 172.51.0.0, metric=10100
      network 150.100.0.0, metric=8486

r2, there is no receiving update.

routing table is following.

r1:
I 172.51.0.0/16 [100/12100] via 133.1.110.5, 00:00:43, Serial0/0
B 199.38.3.0/24 [20/10] via 150.100.2.254, 13:16:43
B 199.38.2.0/24 [20/100] via 150.100.2.254, 13:16:43
B 199.38.1.0/24 [20/100] via 150.100.2.254, 13:16:43
     133.1.0.0/24 is subnetted, 9 subnets
I 133.1.5.0 [100/12100] via 133.1.110.5, 00:00:43, Serial0/0
I 133.1.6.0 [100/12100] via 133.1.110.5, 00:00:43, Serial0/0
I 133.1.12.0 [100/12100] via 133.1.110.5, 00:00:43, Serial0/0
I 133.1.20.0 [100/12100] via 133.1.110.5, 00:00:44, Serial0/0
I 133.1.23.0 [100/12100] via 133.1.110.5, 00:00:44, Serial0/0
C 133.1.40.0 is directly connected, Loopback0
I 133.1.56.0 [100/12100] via 133.1.110.5, 00:00:44, Serial0/0
I 133.1.100.0 [100/12100] via 133.1.110.5, 00:00:44, Serial0/0
C 133.1.110.0 is directly connected, Serial0/0
B 199.38.5.0/24 [20/10] via 150.100.2.254, 13:16:46
     150.100.0.0/24 is subnetted, 2 subnets
C 150.100.2.0 is directly connected, FastEthernet0/0
S 150.100.1.0 [1/0] via 133.1.110.5
B 199.38.4.0/24 [20/10] via 150.100.2.254, 13:16:46

r2:
     133.1.0.0/16 is variably subnetted, 11 subnets, 3 masks
C 133.1.5.0/24 is directly connected, Ethernet0
O IA 133.1.6.0/24 [110/74] via 133.1.56.1, 13:14:26, Serial1
O E2 133.1.12.0/24 [110/100] via 133.1.100.2, 13:14:26, Serial0.2
O IA 133.1.20.0/24 [110/65] via 133.1.100.2, 13:14:26, Serial0.2
O IA 133.1.23.0/24 [110/74] via 133.1.100.2, 13:14:26, Serial0.2
                      [110/74] via 133.1.100.3, 13:14:26, Serial0.2
C 133.1.33.0/30 is directly connected, BRI0
I 133.1.40.0/24 [100/12100] via 133.1.110.4, 00:00:35, Serial0.1
C 133.1.56.0/24 is directly connected, Serial1
O 133.1.100.0/24 is a summary, 12:19:50, Null0
C 133.1.100.0/28 is directly connected, Serial0.2
C 133.1.110.0/24 is directly connected, Serial0.1
O E2 172.51.0.0/16 [110/100] via 133.1.100.2, 13:14:26, Serial0.2
B 199.38.1.0/24 [200/100] via 133.1.110.4, 13:20:27
B 199.38.3.0/24 [200/10] via 133.1.110.4, 13:20:27
B 199.38.2.0/24 [200/100] via 133.1.110.4, 13:20:27
B 199.38.5.0/24 [200/10] via 133.1.110.4, 13:20:27
B 199.38.4.0/24 [200/10] via 133.1.110.4, 13:20:27
     150.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
I 150.100.0.0/16 [100/8486] via 133.1.110.4, 00:00:39, Serial0.1
O E2 150.100.1.0/24 [110/100] via 133.1.100.2, 13:14:30, Serial0.2

-----Original Message-----
From: afiddler [mailto:afiddler@wi.rr.com]
Sent: Sunday, October 14, 2001 11:02 AM
To: Kevin(>gC6?u)
Subject: Re: igrp and loopback interface

It is not clear from your configuration information that you are
redistributing the IGRP routes into OSPF. If you don't do this, you won't
see the loopback network from R2. I just tried your example, but I also
redistributed IGRP into OSPF on R1, and was able to see the 133.1.40.0/24
network from R2.
----- Original Message -----
From: "Kevin(>gC6?u)" <y1700@chollian.net>
To: "Ccielab@Groupstudy. Com" <ccielab@groupstudy.com>
Sent: Saturday, October 13, 2001 12:23 PM
Subject: igrp and loopback interface

> I wanna advertise the interface loopback via igrp.
>
> loop0 133.1.40.1/24 --- r1 ------F/R------r2------
> | | |
> ------------------------------------------------------- -------
> IGRP OSPF
>
> r1:
>
> interface Loopback0
> ip address 133.1.40.1 255.255.255.0
>
> router igrp 1
> redistribute connected metric 1000 100 255 1 1500
> network 133.1.0.0
>
>
> r1 can get all redi ospf routes, but r2 can't get r1's loopback address.
>
> What can I do....
>
> Thanks.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:18 GMT-3