Re: PPP Callback and dialer death

From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Fri Oct 12 2001 - 10:48:56 GMT-3


   
I am not at the routers now, but how about I just write the commands here?
Practice makes perfect right?

caller(config)# username CBK password cisco
caller(config)# int bri 0
caller(config-if)# no shut
caller(config-if)# isdn switch-type basic-ni
caller(config-if)# isdn spid1 61455511110101
caller(config-if)# isdn spid2 61455522220101
caller(config-if)# encap ppp
caller(config-if)# ppp auth chap
caller(config-if)# ppp callback request
caller(config-if)# dialer pool-member 1
caller(config-if)# int dialer 0
caller(config-if)# ip address 172.16.50.1 255.255.255.0
caller(config-if)# encap ppp
caller(config-if)# ppp auth chap
caller(config-if)# ppp callback request
caller(config-if)# ppp chap hostname Brian
caller(config-if)# dialer remote-name Jeff
caller(config-if)# dialer string 5553333
caller(config-if)# dialer string 5554444
caller(config-if)# dialer pool 1
caller(config-if)# dialer-group 1
caller(config-if)# dialer-list 1 protocol ip permit

CBK(config)# username caller password cisco
CBK(config)# username Brian password cisco
CBK(config)# int bri 0
CBK(config-if)# no shut
CBK(config-if)# isdn switch-type basic-ni
CBK(config-if)# isdn spid1 61455533330101
CBK(config-if)# isdn spid2 61455544440101
CBK(config-if)# encap ppp
CBK(config-if)# ppp auth chap
CBK(config-if)# ppp callback accept
CBK(config-if)# dialer pool-member 1
CBK(config-if)# int dialer 0
CBK(config-if)# ip address 172.16.50.2 255.255.255.0
CBK(config-if)# encap ppp
CBK(config-if)# ppp auth chap
CBK(config-if)# ppp callback accept
CBK(config-if)# dialer remote-name Brian
CBK(config-if)# dialer pool 1
CBK(config-if)# dialer callback-secure
CBK(config-if)# dialer string 5551111 class CBK
CBK(config-if)# dialer string 5552222 class CBK
CBK(config-if)# map-class dialer CBK
CBK(config-map-class)# dialer callback-server username
CBK(config-map-class)# int dialer 0
CBK(config-if)# dialer-group 1
CBK(config-if)# dialer-list protocol ip permit

>>>Brian

>From: SFeldberg@edeltacom.com
>To: "Brian Lodwick" <xpranax@hotmail.com>
>Subject: Re: PPP Callback and dialer death
>Date: Fri, 12 Oct 2001 09:16:10 -0400
>
>
>Brian,
>
>Would you mind e-mailing me the configs for both sides?
>
>Stephen Feldberg
>e ^ deltacom
>phone: 678.835.5437
>sfeldberg@edeltacom.com
>
>
>
> "Brian
> Lodwick" To: daniel@prove-it.co.uk
> <xpranax@hotm cc: ccielab@groupstudy.com
> ail.com> Subject: Re: PPP Callback and
>dialer death
> Sent by:
> nobody@groups
> tudy.com
>
>
> 10/12/2001
> 09:02 AM
> Please
> respond to
> "Brian
> Lodwick"
>
>
>
>
>
>
>Listers,
>If anyone is interested I have discovered why the dialer-list/dialer-group
>command combination is required on the callback side, and I figured it may
>be of interest of others on the list?
>Either side of the connection is capable of terminating the dialup
>connection, and will, when the line fails to transport "interesting
>traffic"
>for the predetermined time (either fast or regular idle depending upon the
>circumstances). So in summation if there was not a dialer-list/dialer-group
>
>combination on the callback side, the line would not ever be able to stay
>up
>any longer than the idle timers.
>
>Helpfull to anyone? Who knows? But at least it's a technical e-mail message
>
>and not just some BS about the 1-day format or the job market or something.
>
>I can read about that stuff in those free junk-mail magazines I receive
>every week. I myself would much rather use this resource differently.
>Good Luck to everyone out there in pursuit of the Networking Black Belt.
>~:o]
>
> >>>Brian
>
>
>
>
>
> >From: Daniel Prinsloo <daniel@prove-it.co.uk>
> >Reply-To: Daniel Prinsloo <daniel@prove-it.co.uk>
> >To: Brian Lodwick <xpranax@hotmail.com>
> >CC: "'ccielab@groupstudy.com'" <ccielab@groupstudy.com>
> >Subject: Re: PPP Callback and dialer death
> >Date: Tue, 09 Oct 2001 22:03:24 +0100
> >
> >Brian,
> >
> >good evening. Responses are after questions:
> >
> >Brian Lodwick wrote:
> >
> >>Bruce Caslow said several times "ISDN is a CCIE killer" so I am going
> >>to kill it before it kills me (in the lab)! I am currently working on
> >>a scenario that uses ISDN dialer profiles, PPP authentication and is
> >>implementing PPP callback. I am a little curious though of the proper
> >>placement of commands. I don't want the proctors to have any reason to
> >>fail me, so I want to try to cut down on the unneeded commands.
> >>
> >>A couple of questions for the dialer masters out there:
> >>
> >>Do you need to have the commands "ppp callback request" "ppp callback
> >>accept" and (if you were going to bond the b-channels)"ppp multilink"
> >>on both the physical BRI line and the Dialer interface?
> >
> >Both the PPP callback request and PPP callback accept will be placed on
> >the BRI interface. This does make sense as these are features of LCP and
> >not of NCP, LCP is generally associated with the BRI interface.
> >The PPP multilink is placed on the physical interface for incoming
> >calls, in the dialer profile for outgoing calls, and on both the
> >interface and dialer profile when incoming and outgoing calls are
>expected.
> >
> >>
> >>Do you need to have "dialer-group _" on the callback router?
> >
> >Yes, allthough I have allways done this, I am not absolutely sure why it
> >is required?
> >
> >>
> >>
> >>I've also included my configs if anyone would like to tear them apart
> >>to tell me what is wrong with my dialer configurations if they see
> >>any. Cause I know everyone here loves to read through Cisco configs!
> >>
> >>Thanks in advance as always!!!
> >>
> >>>>>Brian
> >>>>
> >>
> >>r3#sh run
> >>Building configuration...
> >>
> >>Current configuration:
> >>!
> >>version 12.0
> >>service timestamps debug uptime
> >>service timestamps log uptime
> >>no service password-encryption
> >>!
> >>hostname r3
> >>!
> >>!
> >>username r10 password 0 cisco
> >>ip subnet-zero
> >>no ip domain-lookup
> >>isdn switch-type basic-ni
> >>!
> >>!
> >>!
> >>interface Ethernet0
> >>ip address 172.16.50.1 255.255.255.248
> >>no ip directed-broadcast
> >>no keepalive
> >>!
> >>interface Serial0
> >>no ip address
> >>no ip directed-broadcast
> >>encapsulation frame-relay
> >>no ip mroute-cache
> >>no fair-queue
> >>!
> >>interface Serial0.1 point-to-point
> >>ip address 172.16.30.2 255.255.255.0
> >>no ip directed-broadcast
> >>ip ospf network point-to-multipoint
> >>no arp frame-relay
> >>frame-relay interface-dlci 307
> >>!
> >>interface Serial1
> >>ip address 209.154.229.1 255.255.255.252
> >>no ip directed-broadcast
> >>clockrate 2000000
> >>!
> >>interface BRI0
> >>no ip address
> >>no ip directed-broadcast
> >>encapsulation ppp
> >>dialer pool-member 1
> >>isdn switch-type basic-ni
> >>isdn spid1 55512121111
> >>isdn spid2 55521211111
> >>ppp callback request
> >>ppp authentication chap
> >>!
> >>interface Dialer0
> >>ip address 172.16.10.1 255.255.255.0
> >>no ip directed-broadcast
> >>encapsulation ppp
> >>dialer remote-name Jeff
> >>dialer string 5551010
> >>dialer string 5550101
> >>dialer-group 1
> >>ppp callback request
> >>ppp authentication chap
> >>ppp chap hostname Brian
> >>!
> >>router ospf 100
> >>network 172.16.10.1 0.0.0.0 area 5
> >>network 172.16.30.2 0.0.0.0 area 0
> >>!
> >>router bgp 300
> >>no synchronization
> >>neighbor 172.16.30.1 remote-as 300
> >>neighbor 172.16.30.1 next-hop-self
> >>neighbor 209.154.229.2 remote-as 500
> >>no auto-summary
> >>!
> >>ip nat translation timeout never
> >>ip nat translation tcp-timeout never
> >>ip nat translation udp-timeout never
> >>ip nat translation finrst-timeout never
> >>ip nat translation syn-timeout never
> >>ip nat translation dns-timeout never
> >>ip nat translation icmp-timeout never
> >>ip classless
> >>ip bgp-community new-format
> >>!
> >>!
> >>map-class dialer Hoochie
> >>dialer-list 1 protocol ip permit
> >>alias exec ip sh ip route
> >>alias exec ipx sh ipx route
> >>alias exec int sh ip int brief
> >>!
> >>line con 0
> >>transport input none
> >>line aux 0
> >>line vty 0 4
> >>login
> >>!
> >>end
> >>
> >>
> >>r10#sh run
> >>Building configuration...
> >>
> >>Current configuration:
> >>!
> >>version 12.0
> >>service timestamps debug uptime
> >>service timestamps log uptime
> >>no service password-encryption
> >>!
> >>hostname r10
> >>!
> >>!
> >>username r3 password 0 cisco
> >>username Brian password 0 cisco
> >>ip subnet-zero
> >>no ip domain-lookup
> >>isdn switch-type basic-ni
> >>!
> >>!
> >>!
> >>interface Ethernet0
> >>ip address 209.154.229.5 255.255.255.252
> >>no ip directed-broadcast
> >>!
> >>interface Serial0
> >>ip address 209.154.229.13 255.255.255.252
> >>no ip directed-broadcast
> >>!
> >>interface Serial1
> >>no ip address
> >>no ip directed-broadcast
> >>shutdown
> >>!
> >>interface BRI0
> >>no ip address
> >>no ip directed-broadcast
> >>encapsulation ppp
> >>shutdown
> >>dialer pool-member 1
> >>isdn switch-type basic-ni
> >>isdn spid1 55510101111
> >>isdn spid2 55501011111
> >>ppp callback accept
> >>ppp authentication chap
> >>!
> >>interface Dialer0
> >>ip address 172.16.10.2 255.255.255.0
> >>no ip directed-broadcast
> >>encapsulation ppp
> >>ip ospf demand-circuit
> >>dialer remote-name Brian
> >>dialer callback-secure
> >>dialer string 5551212 class CBK
> >>dialer pool 1
> >>ppp callback accept
> >>ppp authentication chap
> >>!
> >>router ospf 100
> >>network 172.16.10.2 0.0.0.0 area 310
> >>!
> >>router rip
> >>version 2
> >>network 209.154.229.0
> >>!
> >>router bgp 65002
> >>no synchronization
> >>bgp confederation identifier 500
> >>bgp confederation peers 65001
> >>neighbor 209.154.229.6 remote-as 65002
> >>neighbor 209.154.229.6 next-hop-self
> >>neighbor 209.154.229.6 route-map loc out
> >>neighbor 209.154.229.14 remote-as 300
> >>no auto-summary
> >>!
> >>ip nat translation timeout never
> >>ip nat translation tcp-timeout never
> >>ip nat translation udp-timeout never
> >>ip nat translation finrst-timeout never
> >>ip nat translation syn-timeout never
> >>ip nat translation dns-timeout never
> >>ip nat translation icmp-timeout never
> >>ip classless
> >>!
> >>!
> >>ip prefix-list everything seq 5 permit 0.0.0.0/0 le 32
> >>!
> >>ip prefix-list loc seq 5 permit 172.16.20.0/24 le 32
> >>!
> >>map-class dialer CBK
> >>dialer callback-server username
> >>route-map loc permit 10
> >>match ip address prefix-list loc
> >>set local-preference 500
> >>!
> >>route-map loc permit 20
> >>match ip address prefix-list everything
> >>set local-preference 100
> >>!
> >>alias exec int sh ip int brief
> >>alias exec ip sh ip route
> >>alias exec ipx sh ipx route
> >>!
> >>line con 0
> >>transport input none
> >>line aux 0
> >>line vty 0 4
> >>!
> >>end
> >>
> >>
> >>



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:17 GMT-3