From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Fri Oct 05 2001 - 19:40:06 GMT-3
I read through all kinds of stuff and finally found an excerp at the bottom
of a cisco case study on OSPF. The excerp just said in ISIS all next hops
must be neighbors. In OSPF this is not true though because you can use frame
maps. Aparently you must either have a fully meshed topology for ISIS, not a
hub spoke because all of the other spokes as next-hops are not neighbors. I
thought that was pretty interesting though and wanted to share it with
anyone interested. I have copied the excerp from the case study and the
link. I also included the new configs and the routing tables.
I did just like Raymond suggested, and instead of having a multipoint
sub-interface on the hub I put 2 point-to-point sub-interfaces on there to
overcome the shortfall of ISIS, and everything is working.
Just a little caveat I guess to remember for ISIS. I am going try to use
point-to-point sub-interfaces on any hub spoke topologies when using ISIS.
Another thing I dug up when researching this issue. I remembered in Bruce
Caslow's class he quickly said that there are 2 combinations that don't mix
when using ISIS on an NBMA network. Cannot use point-to-point sub-interfaces
and a physical interface together, and you cannot use a point-to-point
sub-interface with a multipoint sub-interface, but you CAN use a physical
interface and a multipoint sub-interface config together. The reasoning
behind this was realized today while reading Jeff Doyle's Routing TCP/IP
when it said ISIS only describes 2 network types - Broadcast and
Point-to-Point. The problem is obvious if you've been working with OSPF
much. Broadcast will attempt to elect a Designated IS and in Point-to-Point
it won't. If you configure an interface in a NBMA network (such as
Frame-Relay or ATM) with a multipoint sub-interface or right on the physical
interface it will be considered a "Broadcast network type" in ISIS, and the
only type of interface considered a "Point-to-Point network type" in an NBMA
network is a point-to-point sub-interface. Anyways here's the stuff, hope it
helps someone else. Thanks for everyones help and ideas!
>>>Brian
http://www.cisco.com/warp/public/104/ospfdb4.html
The Next Hop on Nonbroadcast Multiaccess Networks
To explore the issue of the next hop in a nonbroadcast multiaccess (NBMA)
network, let's take the following example. There are three routers on a
transit network (Routers non_DR_a, non_DR_b, and DR). It's a hub and spoke
topology on an NBMA media such as Frame Relay, Asynchronous Transfer Mode
(ATM), or X.25.
When Router non_DR_a calculates routes through Router non_DR_b, it makes
Router non_DR_b the next hop. However, Router non_DR_a doesn't have a
virtual circuit (VC) to Router non_DR_b, which means these routers can't
even ping each other. This means OSPF is installing routes into the routing
table with a next-hop that can't be reached.
The solution to this problem is to add a second frame-relay map statement to
make all the neighbors reachable through the VC going to Router DR. For
example:
interface Serial0
frame-relay map ip 1.1.1.1 700 broadcast
!-- This is a map for the DR
frame-relay map ip 1.1.1.2 700 broadcast
!-- This is a map on the same VC data-link connection
!-- identifier (DLCI) for a non-DR router
Let's compare this behavior with that of the Intermediate
System-to-Intermediate System (ISIS) protocol. A router won't install an
ISIS route through a next hop, unless the next hop is a neighbor. This means
ISIS won't work on a multi-point interface unless the routers are fully
meshed.
OSPF installs routes even though the next hop isn't a neighbor, and isn't
reachable through Layer 2. However, you can fix this problem by configuring
multiple map statements.
Hub:
r8#sh run
Building configuration...
Current configuration : 1284 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
logging rate-limit console 10 except errors
!
!
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
no mgcp timer receive-rtcp
!
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface ATM2/0
no ip address
no atm scrambling cell-payload
atm uni-version 3.1
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip address 172.16.70.6 255.255.255.252
ip router isis
pvc 7/15
protocol ip 172.16.70.5 broadcast
protocol clns 49.0000.0007.0007.0007.00 broadcast
!
isis circuit-type level-2-only
!
interface ATM2/0.2 point-to-point
ip address 172.16.70.2 255.255.255.252
ip router isis
pvc 8/15
protocol ip 172.16.70.1 broadcast
protocol clns 49.0000.0002.0002.0002.00 broadcast
!
isis circuit-type level-2-only
!
!
router isis
net 49.0000.0008.0008.0008.00
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
!
snmp-server engineID local 80000009FF0000A100E4E5B4
snmp-server manager
!
dial-peer cor custom
!
!
!
!
alias exec ip sh ip route
alias exec int sh ip int brief
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r8#ip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
i L2 172.16.20.0/28 [115/20] via 172.16.70.1, ATM2/0.2
C 172.16.70.0/30 is directly connected, ATM2/0.2
C 172.16.70.4/30 is directly connected, ATM2/0.1
Spoke:
r7#sh run
Building configuration...
Current configuration : 1958 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging rate-limit console 10 except errors
!
!
!
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
no mgcp timer receive-rtcp
!
!
call rsvp-sync
!
!
!
!
!
!
!
controller T1 1/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 1/1
!
!
interface ATM0/0
no ip address
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
ip address 172.16.70.5 255.255.255.252
ip router isis
pvc 5/15
protocol ip 172.16.70.6 broadcast
protocol clns 49.0000.0008.0008.0008.00 broadcast
!
isis circuit-type level-2-only
!
interface Serial1/0:0
no ip address
encapsulation frame-relay
frame-relay traffic-shaping
!
interface Serial1/0:0.1 point-to-point
ip ospf network point-to-multipoint
!
interface Serial1/0:0.2 multipoint
ip address 172.16.30.1 255.255.255.0
ip ospf network point-to-multipoint
frame-relay interface-dlci 701
class vofr
vofr cisco
frame-relay interface-dlci 703
!
!
router ospf 100
log-adjacency-changes
network 172.16.30.1 0.0.0.0 area 0
!
router isis
net 49.0000.0007.0007.0007.00
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
!
map-class frame-relay vofr
no frame-relay adaptive-shaping
frame-relay fair-queue
frame-relay voice bandwidth 32000
frame-relay fragment 80
!
snmp-server engineID local 80000009FF0000A1012D34BF
snmp-server manager
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 777 pots
destination-pattern 777
port 3/1/0
!
dial-peer voice 111 vofr
destination-pattern 111
session target Serial1/0:0 701
!
!
alias exec ip sh ip route
alias exec int sh ip int brief
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r7#ip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 5 masks
O IA 172.16.50.0/29 [110/84] via 172.16.30.2, 00:31:26, Serial1/0:0.2
O 172.16.30.2/32 [110/74] via 172.16.30.2, 00:31:26, Serial1/0:0.2
O 172.16.30.3/32 [110/74] via 172.16.30.3, 00:31:26, Serial1/0:0.2
C 172.16.30.0/24 is directly connected, Serial1/0:0.2
i L2 172.16.20.0/28 [115/30] via 172.16.70.6, ATM0/0.1
i L2 172.16.70.0/30 [115/20] via 172.16.70.6, ATM0/0.1
C 172.16.70.4/30 is directly connected, ATM0/0.1
Spoke:
r2#sh run
Building configuration...
Current configuration : 2519 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip cef
no ip dhcp-client network-discovery
frame-relay switching
call rsvp-sync
!
!
!
!
!
!
!
controller T1 0/0/0
framing esf
clock source internal
linecode b8zs
channel-group 0 timeslots 1-24 speed 56
!
controller T1 0/0/1
framing esf
linecode b8zs
!
controller T1 0/0/2
framing esf
linecode b8zs
!
controller T1 0/0/3
framing esf
linecode b8zs
!
!
interface Serial0/0/0:0
no ip address
encapsulation frame-relay
no ip route-cache distributed
frame-relay intf-type dce
frame-relay route 701 interface Serial3/1 107
frame-relay route 703 interface Serial3/2 307
!
interface Ethernet0/1/0
ip address 172.16.20.1 255.255.255.240
ip router isis
no ip route-cache distributed
no keepalive
isis circuit-type level-1
isis hello-multiplier 1000
isis hello-interval 300
!
interface Ethernet0/1/1
no ip address
no ip route-cache distributed
shutdown
!
interface Ethernet0/1/2
no ip address
no ip route-cache distributed
shutdown
!
interface Ethernet0/1/3
no ip address
no ip route-cache distributed
shutdown
!
interface ATM1/0
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 172.16.70.1 255.255.255.252
ip router isis
pvc 6/15
protocol ip 172.16.70.2 broadcast
protocol clns 49.0000.0008.0008.0008.00 broadcast
!
isis circuit-type level-2-only
!
interface ATM2/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Serial3/0
no ip address
shutdown
!
interface Serial3/1
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 107 interface Serial0/0/0:0 701
!
interface Serial3/2
no ip address
encapsulation frame-relay
clockrate 2000000
frame-relay intf-type dce
frame-relay route 307 interface Serial0/0/0:0 703
!
interface Serial3/3
no ip address
shutdown
!
interface Serial3/4
no ip address
shutdown
!
interface Serial3/5
no ip address
shutdown
!
interface Serial3/6
no ip address
shutdown
!
interface Serial3/7
no ip address
shutdown
!
router isis
net 49.0000.0002.0002.0002.00
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
alias exec ip sh ip route
alias exec ipx sh ipx route
alias exec int sh ip int brief
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
login
!
end
r2#ip
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.20.0/28 is directly connected, Ethernet0/1/0
C 172.16.70.0/30 is directly connected, ATM1/0.1
i L2 172.16.70.4/30 [115/20] via 172.16.70.2, ATM1/0.1
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:14 GMT-3