From: SFeldberg@xxxxxxxxxxxxx
Date: Thu Oct 04 2001 - 09:43:54 GMT-3
In your example both would work the same. When you are using route maps to
change metrics, for example BGP weight, you will find a difference.
route-map Interfaces permit 10
match interface L0 L1 L2 L3 L4
set weight 200
L0-4 will be assigned a BGP weight of 200
route-map Interfaces permit 10
match interface L0 L1
set weight 500
route-map Interfaces permit 20
match interface L2 L3
set weight 300
L0,L1 will have weight of 500. L2, L3 will have weight of 300.
BTW, they won't let you bring your Bat utility belt into the lab :-)
Steve
"Batman"
<rschotz@quik To: <SFeldberg@edeltacom.com>
net.com> cc: <ccielab@groupstudy.com>
Subject: Re: OSPF Type 5 lsa quest
ion
10/04/2001
06:23 AM
Can you use this command to identify multiple interfaces
Example:
route-map INTERFACES permit 10
match interface Loopback0 Ethernet0
or do you need to do:
route-map INTERFACES permit 10
match interface Loopback0
route-map INTERFACES permit 20
match interface Ethernet0
----- Original Message -----
From: <SFeldberg@edeltacom.com>
To: <ccielab@groupstudy.com>
Sent: Monday, September 17, 2001 6:37 AM
Subject: Re: OSPF Type 5 lsa question
> Omar,
>
> I have used route maps during redistribution to do accomplish this task.
I
> find it simpler to reference the interfaces that I want to redistribute
> since it does not require an access list.
> i.e
> !
> interface Loopback0
> ip address 152.1.11.1 255.255.255.240
> no ip directed-broadcast
> !
> router ospf 1
> redistribute connected subnets route-map Loop0
> !
> route-map Loop0 permit 10
> match interface Loopback0
> !
> R1-RouterA#sh ip route conn
> 1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
> C 1.1.1.0/24 is directly connected, Loopback99
> 152.1.0.0/16 is variably subnetted, 6 subnets, 3 masks
> C 152.1.11.0/28 is directly connected, Loopback0
> C 152.1.10.0/24 is directly connected, Ethernet0
> C 152.1.1.0/30 is directly connected, Serial0
> 168.28.0.0/24 is subnetted, 1 subnets
> C 168.28.179.0 is directly connected, Ethernet1
>
> R1-RouterA#sh ip ospf d
>
> OSPF Router with ID (152.1.11.1) (Process ID 1)
>
> <snip>
>
> Type-5 AS External Link States
>
> Link ID ADV Router Age Seq# Checksum Tag
> 152.1.11.0 152.1.11.1 139 0x80000003 0xE56E 0
>
> Steve
>
>
>
> "Omar"
> <omar_ccie@ya To: <ccielab@groupstudy.com>
> hoo.com> cc:
> Sent by: Subject: OSPF Type 5 lsa
question
> nobody@groups
> tudy.com
>
>
> 09/15/2001
> 05:37 PM
> Please
> respond to
> "Omar"
>
>
>
>
>
>
> Folks,
> I have a 4 router pod and have ospf up and running.
> None of the loopback interfaces have OSPF running on it.
> I decided to redistribute the loopback interface of one the backbone
> routers
> (Router 1) into the ospf network and used the following command....
>
> redistribute connected metric 100 subnet
>
> ....on the surface everything seemed fine. The loopback was advertized an
> EX
> 2.
> However, when I examined the LS database, I notice that all the connected
> links of (Router 1), which already had OSPF running on them, were also
> being
> advertized by type 5 LSAs.
> The remaining routers, perfering the internal routes over external, show
> the
> (Router 1) connected links as internal but they do have type 5 LSAs in
> their
> LS database!!!!
>
> It there any way to prevent other connected links being advertized by
type
> 5
> LSAs?
> I tried route maps but it did not help.
> Any suggestions?
>
> Omar.
> **Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 22:33:13 GMT-3