From: Scott Morris (smorris@xxxxxxxxxxxxxx)
Date: Wed Aug 08 2001 - 20:18:00 GMT-3
Cool! And we have the standard Cisco answer.... "IT DEPENDS"
;)
Thanks Erick!
-----Original Message-----
From: Erick B. [mailto:erickbe@yahoo.com]
Sent: Wednesday, August 08, 2001 5:36 PM
To: Scott Morris; 'Chuck Larrieu'; ccielab@groupstudy.com
Subject: RE: Two areas don't make an ABR?
Hi,
I played around with this and captured the output,
messages, etc. Below are the captures of the old
behavior vs new behavior.
I haven't done any release-note/new feature checking
yet but does anyone know offhand if this is a new
behavior with 12.1(0) or somewhere between 12.1(0) and
12.1(9)?
Basic config:
interface Loopback10
ip address 172.16.2.3 255.255.255.0
!
interface Loopback11
ip address 172.16.3.3 255.255.255.0
!
interface Loopback12
ip address 172.16.5.5 255.255.255.0
12.0(7)T behavior:
r3(config)#router ospf 1
r3(config-router)#network 172.16.0.0 0.0.255.255 area
0
r3(config-router)#network 172.16.5.5 0.0.0.0 area 1
% OSPF: "network 172.16.5.5 0.0.0.0 area 1" is
ignored. It is a subset of a previous entry.
show run snip afterward:
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
12.1.(9) and 12.2(2)T behavior:
r1(config)#router ospf 200
r1(config-router)#network 172.16.0.0 0.0.255.255 area
0
r1(config-router)#network 172.16.5.5 0.0.0.0 area 1
1w6d: %OSPF-6-AREACHG: 172.16.5.5/32 changed from area
0 to area 1
show run snip afterward:
router ospf 432 // IOS reorders network statements
network 172.16.5.5 0.0.0.0 area 1
network 172.16.0.0 0.0.255.255 area 0
--- Scott Morris <smorris@mentortech.com> wrote:
> Go figure, huh? :) I don't know as I'd classify
> that as idiot-proofing or
> not.
>
> I'd be interested in a "show ip ospf interface"
> output to see what interface
> is in what area with conflicting statements there.
> Has it become "best
> match" criteria?
>
> If nothing else, on an exam, always remember it's
> the BEST answer... And
> usually with scenarios like this, it will follow
> Cisco's "best practices"
> for net design/implementation. And... most exams
> are probably still 11.x
> code-related.
>
> *shrug*
>
> :)
>
> Scott
>
> -----Original Message-----
> From: Chuck Larrieu [mailto:chuck@cl.cncdsl.com]
> Sent: Wednesday, August 08, 2001 10:10 AM
> To: smorris@mentortech.com; ccielab@groupstudy.com
> Subject: RE: Two areas don't make an ABR?
>
>
> Scott - check my results on a 12.x IOS. apparently
> what was once true -
> that statements are processed in order entered - has
> changed
>
> MANAGER(config)#
> MANAGER(config)#
> MANAGER(config)#
> MANAGER(config)#router ospf 100
> MANAGER(config-router)#network 10.0.0.1 0.0.0.0 area
> 0.0.0.0
> MANAGER(config-router)#network 192.167.0.0
> 0.0.255.255 area 0.0.0.1
> MANAGER(config-router)#network 192.167.0.1 0.0.0.0
> area 0.0.0.0
> MANAGER(config-router)#^Z
>
> MANAGER#sh run
> Building configuration...
>
> Current configuration:
> !
> !
> router ospf 100
> network 10.0.0.1 0.0.0.0 area 0.0.0.0
> network 192.167.0.1 0.0.0.0 area 0.0.0.0
> network 192.167.0.0 0.0.255.255 area 0.0.0.1
>
> apparently this is part of the idiot proofing that
> Cisco has been
> introducing in 12.x
>
> us old dogs who learned things with real IOS
> versions have some new tricks
> to learn!
>
> Chuck
>
> -----Original Message-----
> From: Scott Morris [mailto:smorris@mentortech.com]
> Sent: Wednesday, August 08, 2001 4:50 AM
> To: 'Chuck Church'; 'Chuck Larrieu';
> ccielab@groupstudy.com
> Subject: RE: Two areas don't make an ABR?
>
>
> After reading a bunch of responses here, I'll
> belabor the obvious by
> pointing out that we need to look at the entirety of
> the commands. :)
>
> Try putting them in a router EXACTLY as they are
> listed right there.
> The masks on the network statements overlap for one,
> but also don't indicate
> what's on the interface...
>
> If you enter answer C, you get:
> 3620-3(config-router)#network 10.0.0.1 0.0.0.0 area
> 0.0.0.0
> 3620-3(config-router)#network 192.168.1.1
> 0.0.255.255 area 0.0.0.1
> 3620-3(config-router)#network 192.168.0.1 0.0.0.0
> area 0.0.0.0
> 3620-3(config-router)#
> % OSPF: "network 192.168.0.1 0.0.0.0 area 0.0.0.0"
> is ignored. It is a
> subset of a previous entry.
>
> So, YES, it makes it "sorta" an ABR since you have
> two areas. But it treats
> BOTH ethernets (your REAL networks) as being part of
> the same area. So for
> all intents and purposes in the real world, you are
> not an ABR!!!
>
> Never overlook the details. The small things will
> kill ya!
>
> Scott
>
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com]On Behalf Of
> Chuck Church
> Sent: Wednesday, August 08, 2001 12:18 AM
> To: 'Chuck Larrieu'; ccielab@groupstudy.com
> Subject: RE: Two areas don't make an ABR?
>
>
> What order are they evaluated in then? I was
> assuming top down, so the
> first statement would put the loopback interface
> into area 0. The second
> statement would match both other interfaces, putting
> them in area 1.
>
> Chuck
>
> -----Original Message-----
> From: Chuck Larrieu [mailto:chuck@cl.cncdsl.com]
> Sent: Tuesday, August 07, 2001 11:11 PM
> To: Chuck Church; ccielab@groupstudy.com
> Subject: RE: Two areas don't make an ABR?
>
>
> the interfaces are placed into areas based on the
> order of the network
> statements. once a match is made ( just like
> access-lists ) the processing
> stops.
>
> answer C 192.168.1.1 0.0.255.255 area 0.0.0.1 places
> both interfaces into
> area 1. processing stops. nothing ends up in area 0.
> therefor the router is
> not an ABR. QED
>
> Chuck
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com]On Behalf Of
> Chuck Church
> Sent: Tuesday, August 07, 2001 7:21 PM
> To: 'ccielab@groupstudy.com'
> Subject: Two areas don't make an ABR?
>
>
> Gang,
>
> Got this email today from Certification Zone. I'm
> not quite sure I
> agree with the answer. Why doesn't answer 'C' meet
> the requirement?
>
> Chuck
>
> P.S. I don't have a Certification Zone subscription,
> otherwise I'd go read
> Howard's explanation!
>
>
> 7) This Week's CCIE Challenge Question
> ==============================================
> Which OSPF configuration fragment will cause abr1 to
> function as an
> area border router?
>
> hostname abr1
> int loop0
> ip addr 10.0.0.1 255.255.255.248
> int e0
> ip addr 192.168.0.1 255.255.255.0
> int e1
> ip addr 192.168.1.1 255.255.255.0
>
> a) router ospf 1
> network 192.168.0.0 0.0.0.0 area 0.0.0.0
> network 192.168.1.0 0.0.0.0 area 0.0.0.1
>
> b) router ospf 1
> network 192.168.1.1 0.0.255.255 area 0.0.0.1
> network 192.168.0.1 0.0.0.0 area 0.0.0.0
>
> c) router ospf 1
> network 10.0.0.1 0.0.0.0 area 0.0.0.0
> network 192.168.1.1 0.0.255.255 area 0.0.0.1
> network 192.168.0.1 0.0.0.0 area 0.0.0.0
>
> d) router ospf 1
> network 10.0.0.1 0.0.0.0 area 0.0.0.0
> network 192.168.1.1 0.0.0.0 area 0.0.0.1
> network 192.168.0.1 0.0.0.0 area 0.0.0.0
>
>
> The answer to this week's question can be found at:
>
http://www.CertificationZone.com/QOW/1/ES/ccie-a.html
>
>
> Chuck Church
> CCNP, CCDP, MCNE, MCSE
> Sr. Network Engineer
> Magnacom Technologies
> 140 N. Rt. 303
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:47 GMT-3