RE: ISDN callback with dialer profiles

From: John W. Redmond (c-john.redmond@xxxxxxxx)
Date: Thu Jun 07 2001 - 17:58:29 GMT-3


   
router r5
1) you need the "ppp callback request" under the dialer profile as well

router r3
1) you need the "ppp callback accept" under the dialer profile as well
2) you don't need to provide a dialer string with the username just a
username and password for the chap authentication

--John

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Nicholas Jaksec
Sent: Thursday, June 07, 2001 12:26
To: CCIE
Subject: ISDN callback with dialer profiles

I am having a problem trying to get callback to work with dialer profiles.
If I use Legacy DDR (just the bri0 interface) I hav no problem whatsoever.
Below are my configs, any response would be appreciated:

R5:

hostname R5
!
!
username R3 password 7 14141B180F0B
no ip domain-lookup
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 55.2.2.1 255.255.255.0
!
interface Loopback1
 ip address 55.3.3.1 255.255.0.0
!
interface Ethernet0
 ip address 172.168.60.1 255.255.255.0
!
interface Serial0
 ip address 55.1.1.1 255.255.255.0
 encapsulation frame-relay
 ip split-horizon
 ip ospf network broadcast
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 isdn spid1 3848500001
 no peer neighbor-route
 no peer default ip address
 no peer default ip address
 dialer pool-member 1
 ppp callback request
 ppp authentication chap
!
interface Dialer1
 ip address 172.168.65.1 255.255.255.0
 encapsulation ppp
 dialer remote-name R3
 dialer idle-timeout 30
 dialer string 384830
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
router igrp 1
 passive-interface BRI0
 passive-interface Dialer1
 network 55.0.0.0
 network 172.168.0.0
!
no ip classless
ip route 0.0.0.0 0.0.0.0 BRI0 120
ip route 192.168.4.0 255.255.255.0 Null0
ip route 192.168.5.0 255.255.255.0 Null0
ip route 192.168.6.0 255.255.255.0 Null0
!
access-list 901 deny any any all any rip
access-list 901 deny any any all any sap
access-list 901 deny any any all any 457
access-list 901 permit any any all any all
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx list 901
!
line con 0
line aux 0
line vty 0 4
 login
!
end

R3:

hostname R3
!
!
username R5 callback-dialstring 384850 password 0 cisco
ipx routing 0003.0003.0003
isdn switch-type basic-5ess
!
interface Loopback0
 ip address 55.4.4.1 255.255.255.0
 ipx network 10
!
interface Ethernet0
 ip address 137.20.20.10 255.255.255.0
 no keepalive
 ipx network 40
!
interface Serial0
 ip address 55.1.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 200
 ipx network 20
 no fair-queue
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 isdn spid1 3848300001
 no peer neighbor-route
 dialer pool-member 1
 no cdp enable
 ppp callback accept
 ppp authentication chap
!
interface Dialer1
 ip address 172.168.65.2 255.255.255.0
 encapsulation ppp
 dialer remote-name R5
 dialer callback-secure
 dialer idle-timeout 30
 dialer string 384850 class callback
 dialer max-call 250
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
router igrp 1
 passive-interface BRI0
 passive-interface Dialer1
 network 55.0.0.0
 network 172.168.0.0
!
no ip classless
!
map-class dialer callback
 dialer callback-server username
access-list 901 deny any any all any rip
access-list 901 deny any any all any sap
access-list 901 deny any any all any 457
access-list 901 permit any any all any all
!
!
!
ipx sap 4 Novell 40.0001.0002.0003 451 2
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx list 901
!
line con 0
line aux 0
line vty 0 4
 login
!
end

********************************************
Nicholas R. Jaksec, CCNP, CCDP, MCSE+I, CNA
Network Systems Engineer
Lucent Worldwide Services
One North Shore Center
12 Federal St. Suite 420
Pittsburgh, Pa 15212
Office: 412-330-6336 Fax: 412-323-7665
Pager: 1-800-467-1467
Email: jaksec@lucent.com
********************************************
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:20 GMT-3