From: Luke (luke.mendoza@xxxxxxxx)
Date: Tue Jun 05 2001 - 12:52:52 GMT-3
Hello all,
I am well aware of ISDN flaps due to routing instabilities and I believe I
had made my proper adjustments and filters. I am still getting the lines to
flap.
Here is how the topology is laid out:
R1
Serial2.1 - >>>>>>>>> R2
Dialer0 - >>>>>>>>>> R2
R1 is running OSPF with Serial2.1 attached to Area 0 and Dialer 0 Attached
to Area 100
R2 is running OSPF on Serial2.1 attached to Area 0 and Dialer 0 attached to
Area 100
R2 is also running IGRP for Ethernet 0 which is 172.16.2.0 (so IGRP is
advertising for the whole 172.16.0.0 network)
R1 Serial2.1 is 172.16.124.1
R1 Dialer 0 is 172.16.12.1
R2 Serial2.1 is 172.16.124.2
R2 Dialer0 is 172.16.12.2
On R2 I deny 172.16.12.0 from redistributing from IGRP to OSPF so that when
the isdn line goes down, OSPF won't propagate LSAs... But its still flapping
and the dialer cause on R1 is "224.0.0.5" which tells me that it is still
propogating LSAs due to a change in the network.
----------------------------------------------------------------------------
-----------------------
here is the brief relevant config for R1
interface Serial2.1 point-to-point
ip address 172.16.124.1 255.255.255.0
no ip route-cache
ip ospf network point-to-multipoint
frame-relay interface-dlci 212
!
interface Dialer0
ip address 172.16.12.1 255.255.255.0
encapsulation ppp
ip ospf demand-circuit
dialer remote-name r2
dialer idle-timeout 30
dialer string 2222
dialer pool 1
dialer-group 1
ppp authentication chap
!
router ospf 1
network 140.10.1.1 0.0.0.0 area 2
network 172.16.1.0 0.0.0.255 area 2
network 172.16.12.1 0.0.0.0 area 100
network 172.16.124.1 0.0.0.0 area 0
area 2 range 172.16.1.32 255.255.255.224
dialer-list 1 protocol ip permit
show ip ospf database
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
172.16.1.0 172.16.125.2 1 (DNA) 0x8000000A 0xEB46 0
172.16.2.0 172.16.125.2 1 (DNA) 0x80000001 0x4493 0
172.16.5.0 172.16.125.2 1569 0x80000002 0x21B2 0
172.16.6.0 172.16.144.97 1529 0x80000002 0x379F 0
172.16.12.1 172.16.125.2 3602 0x80000026 0xB3D5 0
172.16.16.0 172.16.144.97 1529 0x80000002 0x7D5E 0
172.16.23.32 172.16.125.2 1569 0x80000002 0x5E62 0
172.16.24.0 172.16.144.97 1529 0x80000002 0x8893 0
172.16.25.0 172.16.144.97 1529 0x80000002 0x7D9D 0
172.16.26.0 172.16.144.97 1530 0x80000002 0x72A7 0
172.16.27.0 172.16.144.97 1530 0x80000002 0x67B1 0
172.16.50.0 172.16.125.2 1 (DNA) 0x80000001 0xE029 0
172.16.50.0 172.16.144.97 1530 0x80000002 0xD514 0
172.16.124.0 172.16.125.2 1570 0x80000002 0xFE5D 0
172.16.124.0 172.16.144.97 1530 0x80000002 0x2040 0
172.16.125.0 172.16.125.2 1570 0x80000002 0xF367 0
172.16.144.0 172.16.125.2 1 (DNA) 0x80000001 0xD2D8 0
172.16.252.0 172.16.125.2 1 (DNA) 0x80000001 0x6C73 0
Notice that 172.16.12.1 shows up as an External Link State....
Here is the config for R2
hostname r2
interface Ethernet0
ip address 172.16.2.1 255.255.255.0
no ip route-cache
no ip mroute-cache
interface Serial2.1 multipoint
ip address 172.16.124.2 255.255.255.0
no ip route-cache
ip ospf network point-to-multipoint
no ip mroute-cache
frame-relay map ip 172.16.124.1 221 broadcast
frame-relay map ip 172.16.124.2 224 broadcast
frame-relay map ip 172.16.124.4 224 broadcast
no frame-relay inverse-arp
!
interface Dialer0
ip address 172.16.12.2 255.255.255.0
encapsulation ppp
dialer remote-name r1
dialer idle-timeout 30
dialer pool 1
dialer-group 1
ppp authentication chap
!
router eigrp 100
passive-interface BRI0
passive-interface Dialer0
passive-interface Ethernet0
passive-interface Serial2.1
passive-interface Serial2.2
network 172.16.0.0
no auto-summary
!
router ospf 1
summary-address 172.16.1.0 255.255.255.0
summary-address 172.16.50.0 255.255.255.0
summary-address 172.16.252.0 255.255.252.0
summary-address 172.16.144.0 255.255.255.0
redistribute rip metric 1500 subnets route-map allowrip <<<<<< Here
denying IGRP from sending updates for 172.16.12.0
network 172.16.12.2 0.0.0.0 area 100
network 172.16.124.2 0.0.0.0 area 0
!
router rip
redistribute ospf 1 metric 5
passive-interface BRI0
passive-interface Dialer0
passive-interface Ethernet0
passive-interface Serial2.1
network 172.16.0.0
!
ip classless
!
no logging console
access-list 11 deny 172.16.12.0 <<<<<< Here denying IGRP from sending
updates for 172.16.12.0
access-list 11 permit any
dialer-list 1 protocol ip permit
route-map allowrip permit 10 <<<<<< Here denying IGRP from sending
updates for 172.16.12.0
match ip address 11 <<<<<< Here denying IGRP from sending updates
for 172.16.12.0
!
route-map allowrip deny 20
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:31:18 GMT-3