From: Cheong Kok Yong (kycheong@xxxxxxxxxxxxxx)
Date: Thu May 24 2001 - 06:20:08 GMT-3
Hi,
In fatkid lab 501, Trying to find method to redistribute the 170.10.7.0/28
to igrp router.
question is to redistribute the ospf /28 route to r1 (igrp), what I did was
putting "area 0 range 170.10.7.0 255.255.255.0" in R5 (ABR) and
"summary-address 170.10.7.0 255.255.255.0" in R4, but doesn't seem to work.
I thought "area x range" command can only be used in other areas, e.g "area
2 range ...." but not area 0. another doubt is that when you create the
"summary-address ...." at the ospf router, you will see the "O
170.10.7.0/24 is a summary, 00:48:33, Null0" is created in that particular
router OR the down/upstream router OR all ospf routers. and why they created
"summary-address..." command at 2 routers ?
Another interesting thing is that when I tried to create the summary-address
at other router, I get:
r2#sh ip os s
OSPF Process 1, Summary-address
170.10.7.0/255.255.255.0 Metric -1, Type 0, Tag 0
But the one created at R4 is:
r4#sh ip os s
OSPF Process 1, Summary-address
170.10.7.0/255.255.255.0 Metric 16777215, Type 0, Tag 0
Any Clues.
Appreciate your advise.
Thanks
Cheong
r5#sh run
hostname r5
!
interface Loopback0
ip address 170.10.9.5 255.255.255.0
!
interface Ethernet0
ip address 170.10.128.5 255.255.255.192
!
interface Serial0
ip address 170.10.7.5 255.255.255.240
encapsulation frame-relay
ip ospf network point-to-multipoint
no fair-queue
frame-relay map ip 170.10.7.2 102 broadcast
frame-relay map ip 170.10.7.3 103 broadcast
no frame-relay inverse-arp
!
interface Serial1
no ip address
shutdown
!
router ospf 1
network 170.10.7.0 0.0.0.15 area 0
network 170.10.128.0 0.0.0.63 area 2
network 170.10.9.0 0.0.0.255 area 2
area 0 range 170.10.7.0 255.255.255.0
area 2 range 170.10.9.0 255.255.255.0
area 2 range 170.10.128.0 255.255.255.0
area 2 virtual-link 170.10.5.4
!
ip classless
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
r4#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn voice-call-failure 0
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
ip address 170.10.5.4 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-point
!
interface Ethernet0/0
ip address 170.10.128.4 255.255.255.192
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
interface TokenRing0/0
ip address 170.10.3.4 255.255.255.0
no ip directed-broadcast
ring-speed 16
!
interface BRI0/0
no ip address
no ip directed-broadcast
shutdown
isdn guard-timer 0 on-expiry accept
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1/0
ip address 170.10.2.4 255.255.255.0
no ip directed-broadcast
!
interface Serial1/1
ip address 192.19.15.4 255.255.255.0
no ip directed-broadcast
!
interface Serial1/2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1/3
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
area 2 virtual-link 170.10.9.5
area 3 range 170.10.5.0 255.255.255.0
summary-address 170.10.200.0 255.255.255.0
summary-address 170.10.7.0 255.255.255.0
redistribute rip subnets route-map rip2ospf
redistribute igrp 1 subnets route-map igrp2ospf
network 170.10.5.0 0.0.0.255 area 3
network 170.10.128.0 0.0.0.255 area 2
!
router rip
redistribute igrp 1 route-map igrp2ospf
redistribute ospf 1 route-map ospf2igrp
passive-interface Ethernet0/0
passive-interface Serial1/0
passive-interface Loopback0
network 170.10.0.0
default-metric 3
!
router igrp 1
redistribute rip route-map rip2ospf
redistribute ospf 1 route-map ospf2igrp
passive-interface Ethernet0/0
passive-interface TokenRing0/0
passive-interface Loopback0
network 170.10.0.0
default-metric 10000 1000 255 1 1500
!
ip classless
no ip http server
!
access-list 1 permit 170.10.5.0 0.0.0.255
access-list 1 permit 170.10.128.0 0.0.0.255
access-list 1 permit 170.10.9.0 0.0.0.255
access-list 1 permit 170.10.7.0 0.0.0.255
access-list 1 permit 170.10.8.0 0.0.0.255
access-list 1 permit 170.10.4.0 0.0.0.255
access-list 1 permit 170.10.144.0 0.0.0.255
access-list 1 permit 170.10.6.0 0.0.0.255
access-list 1 permit 170.10.6.0 0.0.0.255
access-list 2 permit 170.10.4.0 0.0.0.255
access-list 3 permit 170.10.1.0 0.0.0.255
access-list 3 permit 170.10.2.0 0.0.0.255
access-list 3 permit 170.10.3.0 0.0.0.255
access-list 4 permit 170.10.6.0 0.0.0.255
access-list 4 permit 170.10.144.0 0.0.0.255
route-map ospf2igrp permit 10
match ip address 1
!
route-map igrp2ospf permit 10
match ip address 3
!
route-map rip2ospf permit 10
match ip address 2
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
r4#
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:51 GMT-3