From: Theodore TZEVELEKIS (theodore_tzevelekis@xxxxxxxxx)
Date: Wed May 23 2001 - 20:08:21 GMT-3
here you go
interface Loopback0
description base
ip address 135.3.2.2 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
description ID
ip address 135.3.242.2 255.255.255.0
no ip directed-broadcast
!
interface Loopback999
description vlan B - IGRP
ip address 135.3.20.2 255.255.255.128
no ip directed-broadcast
!
interface Ethernet0/0
description ->6 - OSPF5
ip address 135.3.26.2 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
!
interface Serial0/0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
no fair-queue
no frame-relay inverse-arp
!
interface Serial0/0.1 point-to-point
description ->3 - IGRP
ip address 135.3.231.2 255.255.255.128 secondary
ip address 135.3.232.2 255.255.255.224 secondary
ip address 135.3.23.2 255.255.255.0
no ip directed-broadcast
no arp frame-relay
frame-relay interface-dlci 203
!
interface Serial0/0.2 multipoint
description frame - OSPF0
ip address 135.3.124.2 255.255.255.0
no ip directed-broadcast
ip ospf interface-retry 0
ip ospf priority 255
frame-relay interface-dlci 201
frame-relay interface-dlci 204
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
router igrp 1
passive-interface Ethernet0/0
passive-interface Serial0/0.2
network 135.3.0.0
!
ip classless
!
!
ip access-list standard red-con-igrp
permit 135.3.20.0 0.0.0.255
!
route-map red-con-igrp permit 10
match ip address red-con-igrp
**************************************************************
interface Loopback0
description base
ip address 135.3.3.3 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
description ID
ip address 135.3.243.3 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0/0
description ->BB2 - BGP
no ip address
no ip directed-broadcast
!
interface Serial0/0
description ->2 - IGRP
ip address 135.3.231.3 255.255.255.128 secondary
ip address 135.3.232.3 255.255.255.224 secondary
ip address 135.3.23.3 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
ip split-horizon
no ip mroute-cache
no fair-queue
frame-relay map ip 135.3.23.2 302 broadcast
frame-relay map ip 135.3.231.2 302
frame-relay map ip 135.3.232.2 302
no frame-relay inverse-arp
!
interface TokenRing0/0
ip address 135.3.30.3 255.255.255.224
no ip directed-broadcast
ring-speed 16
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
router igrp 1
network 135.3.0.0
-----Original Message-----
From: Dean Olson [mailto:dolson@cisco.com]
Sent: Thursday, May 24, 2001 12:39 AM
To: Theodore TZEVELEKIS
Cc: Theodore TZEVELEKIS; Casassa, Nathan; ccielab@groupstudy.com
Subject: RE: IGRP and VLSM
Forward your configs.
At 05:12 PM 5/23/2001, Theodore TZEVELEKIS wrote:
>ok... so I configured it... and now it advertises all /24, /25 and /26
>networks with a /26 mask :-( .....
>
>Result: I get routes looping around: router 1 advertises a /24 route out to
>router 2, router 2 send it back with a /27 mask and router 1 enters it in
>its routing table as a more specific route than its local one..... This is
>crazy!
>
>I removed the secondaries and it works fine. I put them back, clear ip
route
>and here we go again.... this is ridiculous....
>
>Any ideas?
>
>-----Original Message-----
>From: Theodore TZEVELEKIS [mailto:theodore_tzevelekis@yahoo.com]
>Sent: Wednesday, May 23, 2001 11:12 PM
>To: Casassa, Nathan
>Cc: 'ccielab@groupstudy.com'
>Subject: RE: IGRP and VLSM
>
>
>well not according to my routers :-)
>unless I'm doing something wrong......
>
>{trying again)
>
>well, u know something... you are both absolutely right....
>
>I don't know why it didn't accept it before but it does now: I just tried
it
>again. (probably getting late for me :-)
>I stand absolutely corrected!!!!! Thank you for insisting :-)
>
>Now, back to the issue:
>
>This is one solution that should work... though not very elegant. Any other
>ideas? Something "cleaner"?
>
>-----Original Message-----
>From: Casassa, Nathan [mailto:ncasassa@gnilink.net]
>Sent: Wednesday, May 23, 2001 10:59 PM
>To: 'Theodore TZEVELEKIS'
>Cc: 'ccielab@groupstudy.com'
>Subject: RE: IGRP and VLSM
>
>
>What do you mean it only accepts one? Using the secondary command will
>allow as many secondary IP addys that the memory can handle according to
>cisco.
>
>-----Original Message-----
>From: Theodore TZEVELEKIS [mailto:theodore_tzevelekis@yahoo.com]
>Sent: Wednesday, May 23, 2001 1:38 PM
>To: Michael E. Flannagan
>Cc: ccielab@groupstudy.com
>Subject: RE: IGRP and VLSM
>
>
>It only accepts one :-)
>I tried that already. The interface will only keep the last one you
>enter.... :-(
>
>(Besides, it would be an AWFUL waste of IP addresses.... Something that our
>friend who needed more than a trillion address wouldn't appreciate :-)
>
>-----Original Message-----
>From: Michael E. Flannagan [mailto:mflannag@cisco.com]
>Sent: Wednesday, May 23, 2001 10:07 PM
>To: Theodore TZEVELEKIS
>Subject: RE: IGRP and VLSM
>
>
>Why not configure multiple secondary addresses?
>
>
>---------------------------------------------------------
> C i s c o S y s t e m s Michael E. Flannagan
> | | Network Consulting Engineer
> ||| ||| Research Triangle Park, NC
> ||||||| ||||||| (919) 392-4550
>.:|||||||||||:.:|||||||||||:. mflannag@cisco.com
>---------------------------------------------------------
>
>
>
>
>
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > Theodore TZEVELEKIS
> > Sent: Wednesday, May 23, 2001 3:48 PM
> > To: ccielab@groupstudy.com
> > Subject: IGRP and VLSM
> >
> >
> > I have another - probably can't be done - scenario :-)
> >
> > 2 routers running IGRP.
> >
> > Router A: 1TR /26, 1 loopback /24
> > Router B: 1E /25
> > link between the two: /24
> >
> > How can you exchange all the networks between the two routers?
> >
> > With 2 types of masks, the solution I have found is to
> > configure secondary
> > address on the link with the adequate mask. But for 3....
> > can't think or
> > find anything.
> > Can it be done? Any ideas?
> >
> > Cheers,
> > Theo
> >
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:50 GMT-3