RE: Old wound revisited- lab 8 ISDN keeps flapping

From: Chris Mott (cmott@xxxxxxxx)
Date: Sun May 13 2001 - 21:14:31 GMT-3


   
An easier solution is to totally control the routes during redist. by only
"allowing" IGRP networks from IGRP into OSPF, BGP routes (the correct ones)
into OSPF, and OSPF routes into each, instead of more general "denys"... for
testing the flapping, check your OSPF database for internal routes that show
up as Type-5 external, an easy pointer to the problem, but not necessarily
the solution ... in my solution, these route-maps are quite specific as to
what is injected into OSPF, thus OSPF routes are learned and stay internal
to OSPF ... thus my dialer-list is, like you, a simple ip permit, and once
the ISDN link learns it is a demand-circuit, all goes as planned ... this
one bugged me to no end (read: weeks!), but once I learned the
redistribution issues, no problem, at least in that lab ... now, the REAL
lab is, well, .....

HTH

waiting for try #3 ...

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
ChrisH
Sent: Saturday, May 12, 2001 2:35 PM
To: Dennis Laganiere; ccielab@groupstudy.com
Subject: RE: Old wound revisited- lab 8 ISDN keeps flapping

I have it working by:

1) in R5: in my access-list 101 for the dialer-list 1, I put in statement to
deny IGRP any
2) in R5: since R5 is the ABR and ASBR, you will have to block the ISDN
route from being redistributed back from IGRP into OSPF.
        you can have a statement such as:

                router ospf 100
                        redistribute igrp 100 metric 30 subnets route-map igrp-
into-ospf

                route-map igrp-into-ospf deny 10
                        match ip address 1

                access-list 1 permit 137.20.224 0.0.0.225

3) in R6: block the ISDN route from being redistribute back into OSPF from
BGP.

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Dennis Laganiere
Sent: Saturday, May 12, 2001 11:47 AM
To: 'ccielab@groupstudy.com'
Subject: RE: Old wound revisited- lab 8 ISDN keeps flapping

Isn't the solution to use snapshot routing?

--- Dennis

-----Original Message-----
From: Bernard Omrani [mailto:one@dollarpower.com]
Sent: Saturday, May 12, 2001 7:23 AM
To: 'ccielab@groupstudy.com'
Subject: Old wound revisited- lab 8 ISDN keeps flapping

I am yet to manage to keep this line quiet.
I would like to hear from the people who are currently working on lab 8 and
have managed to control this link.

I know that igrp redistribution could be the culprit. As a last resort, I
have removed igrp from r5 totally and shut down int s0.2.
I know BGP connection from r1-r6 could be the culprit. There was a
recommendation in the archives to lengthen the keepalive and hold periods
using BGP neighbor timers command. Although I do not see this as
ccbootcamp's solution, I lengthened this timer to 300 and 600. The chat
keeps on going & going.

Thanks,
Bernard

hostname r5

interface Loopback0
 ip address 137.20.240.1 255.255.240.0
 no ip directed-broadcast
!
interface BRI0/0
 ip address 137.20.224.5 255.255.240.0
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 60
 dialer map ip 137.20.224.6 name r6 broadcast
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101
 isdn spid2 0835866301
 no cdp enable
 ppp authentication chap
!
interface BRI0/1
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI0/2
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface BRI0/3
 no ip address
 no ip directed-broadcast
 shutdown
 isdn switch-type basic-ni
!
interface Ethernet1/0
 ip address 137.20.64.5 255.255.240.0
 no ip directed-broadcast
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/0.1 multipoint
 ip address 137.20.100.34 255.255.255.224
 no ip directed-broadcast
 frame-relay map ip 137.20.100.33 501 broadcast
 frame-relay map ip 137.20.100.35 503 broadcast
!
interface Serial1/0.2 point-to-point
 ip address 137.20.200.17 255.255.255.240
 no ip directed-broadcast
 frame-relay interface-dlci 504
!
interface TokenRing1/0
 no ip address
 no ip directed-broadcast
 shutdown
 ring-speed 16
!
interface Serial1/1
 ip address 137.20.25.2 255.255.255.0
 no ip directed-broadcast
!
router ospf 100
 area 1 virtual-link 200.200.100.1
 area 1 virtual-link 137.20.33.33
 redistribute igrp 100 metric 100 metric-type 1 subnets route-map
filter_igrp
 network 137.20.25.2 0.0.0.0 area 2
 network 137.20.64.5 0.0.0.0 area 0
 network 137.20.100.34 0.0.0.0 area 1
 network 137.20.240.1 0.0.0.0 area 0
 network 137.20.244.5 0.0.0.0 area 0
!
router igrp 100
 redistribute ospf 100
 passive-interface BRI0/0
 passive-interface Ethernet1/0
 passive-interface Serial1/0.1
 passive-interface Serial1/1
 network 137.20.0.0
 default-metric 1000 100 255 1 1500
!
ip classless
!
access-list 1 permit 137.20.100.32 0.0.0.31
access-list 1 permit 137.20.240.0 0.0.0.255
access-list 1 permit 137.20.64.0 0.0.0.255
access-list 1 permit 137.20.224.0 0.0.0.255
access-list 1 permit 137.20.25.0 0.0.0.255
access-list 2 permit any
dialer-list 1 protocol ip permit
route-map filter-igrp deny 10
 match ip address 1
!
route-map filter-igrp permit 20
 match ip address 2
!

hostname r6
interface Loopback0
 ip address 137.20.60.1 255.255.240.0
!
interface FastEthernet0/0
 ip address 137.20.64.6 255.255.240.0
 no ip redirects
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 137.20.86.2 255.255.255.0
!
interface BRI0/0
 ip address 137.20.224.6 255.255.240.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 60
 dialer map ip 137.20.224.5 name r5 broadcast 8358661
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866201
 isdn spid2 0835866401
 no cdp enable
 ppp authentication chap
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 100
 log-adjacency-changes
 redistribute connected metric 200 subnets route-map allow_conn_s0
 redistribute bgp 2 metric 100 subnets
 network 137.20.60.1 0.0.0.0 area 0
 network 137.20.64.6 0.0.0.0 area 0
 network 137.20.224.6 0.0.0.0 area 0
!
router bgp 2
 bgp log-neighbor-changes
 network 137.20.86.0 mask 255.255.255.0
 redistribute ospf 100 metric 100 route-map osfp1bgponr6_ctrl
 neighbor 137.20.25.1 remote-as 2
 neighbor 137.20.25.1 update-source Loopback0
 neighbor 137.20.25.1 timers 300 600
 neighbor 137.20.86.1 remote-as 1
 neighbor 137.20.86.1 timers 300 600
 neighbor 137.20.86.1 default-originate
 no auto-summary
!
ip classless
ip http server
!
access-list 1 permit 137.20.86.0 0.0.0.255
access-list 6 permit 172.168.70.0 0.0.0.255
access-list 6 permit 137.20.10.0 0.0.0.255
access-list 6 permit 160.0.0.0 0.255.255.255
access-list 65 permit 137.20.224.0 0.0.0.255
dialer-list 1 protocol ip permit
route-map allow_conn_s0 permit 10
 match ip address 1
!
route-map osfp1bgponr6_ctrl deny 5
 match ip address 65
!
route-map osfp1bgponr6_ctrl permit 10
 match route-type internal
!
route-map osfp1bgponr6_ctrl deny 20
!
route-map osfp1bgponr6_ctrl permit 30
 match route-type external

r6#sh dialer

BRI0/0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
8358661 12460 37 00:00:00 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0/0:1 - dialer type = ISDN
Idle timer (60 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=137.20.224.6, d=224.0.0.5)
Time until disconnect 59 secs
Connected to 8358661 (r5)

BRI0/0:2 - dialer type = ISDN
Idle timer (60 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
r6#
!
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:30:41 GMT-3