From: crl (cisco@xxxxxxxxxxxx)
Date: Fri Apr 27 2001 - 13:13:21 GMT-3
Doing some experiments. Topology is:
r4---token-ring---r3---ethernet---r2
On r3, I'm doing SR/TLB and IRB. The Token Ring and Ethernet are a common,
bridged subnet, and r3 has other interfaces that are routed (serials) but I
don't think they're relvant to this discussion.
Experimenting with various routing protocols on this network segment. I
found that RIP1, RIP2, and IGRP work well in this situation. OSPF and EIGRP
do not establish adjacencies. I have the bitswap-layer3-addresses command in
place to allow ping, telnet etc to work well between all three routers.
Take OSPF for example.
r4#sh ip ospf nei
<no output>
r3#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
197.7.77.1 1 INIT/DROTHER 00:00:35 197.7.8.4 BVI1
197.7.8.10 1 FULL/DR 00:00:33 197.7.8.10 BVI1
r2#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
197.7.77.1 1 INIT/DROTHER 00:00:39 197.7.8.4 Ethernet0
197.7.8.3 1 FULL/BDR 00:00:31 197.7.8.3 Ethernet0
Doesn't seem to make much sense. I suspected it was a multicast issue, but
RIP2 works well. It's not an MTU problem, I checked that out - everything is
set to 1500. I suspect the bitswap-layer3 command might be mangling EIGRP
and/or OSPF, but not RIP and IGRP.
Here's the relevant configs. I'd just like to know if this is impossible
(great!) or if I'm missing something (doh!):
r4#sh run
!
interface Loopback0
ip address 197.7.77.1 255.255.255.0
no ip directed-broadcast
!
interface TokenRing0
mtu 1500
ip address 197.7.6.4 255.255.255.0 secondary
ip address 197.7.8.4 255.255.255.0
no ip directed-broadcast
ip nat outside
ring-speed 16
!
router ospf 1
network 197.7.0.0 0.0.255.255 area 0
-------------------------------------------
r3#sh run
!
bridge irb
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1
!
interface Serial1
ip address 197.7.7.3 255.255.255.0
no ip directed-broadcast
!
interface TokenRing0
mtu 1500
no ip address
no ip directed-broadcast
ring-speed 16
bridge-group 1
!
interface BVI1
ip address 197.7.8.3 255.255.255.0
no ip directed-broadcast
!
router ospf 1
network 197.7.0.0 0.0.255.255 area 0
!
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
bridge 1 route ip
-------------------------------------------
r2#sh run
!
interface Ethernet0
ip address 197.7.8.10 255.255.255.0
!
!
router ospf 1
network 197.7.0.0 0.0.255.255 area 0
**Please read:http://www.groupstudy.com/list/posting.html
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:59 GMT-3