From: Dirar Hakeem (dirarhakeem@xxxxxxxxx)
Date: Wed Apr 11 2001 - 11:05:58 GMT-3
This is from the cisco CD at:
http://127.0.0.1:8080/cc/td/doc/product/software/ios120/12cgcr/np1_c/1cprt1/1cb
gp.htm
How BGP Selects Paths
A router running Cisco IOS Release 12.0 or later does
not select or use an IBGP route unless both of the
following are true:
the router has a route available to the next-hop
router
the router has received synchronization via an
IGP (unless IGP synchronization has been disabled)
--- Fair Chiz <s3s9@yahoo.com> wrote:
> Heres the scenario, 4 routers connected in series,
> the
> middle two routers using IBGP and eigrp, the
> outer two strictly EBGP.
>
>
>
> R1--R2--R3--R4
>
> R1= AS100
> R2= AS200
> R3= AS200
> R4= AS300
>
>
>
> R1 has four loopbacks,
> 11.11.1.0,11.11.2.0,11.11.3.0,11.11.4.0
>
> R4 has four loopbacks,
> 55.55.1.0,55.55.2.0,55.55.3.0,55.55.4.0,
>
>
> Heres the problem:
> R2 has a route to the next-hop for R4's routes
> R1 has a route to the next-hop for R1's routes
> R2 doesnt list the loopbacks from R4 in its route
> table (but they are in its BGP table)
> R3 doesnt list the loopbacks from R1 in its route
> table (but they are in its BGP table)
>
> debug shows:
>
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
=-=-=-=-=-=-
> BGP: 10.2.2.6 rcv UPDATE about 55.55.1.0/24, next
> hop
> 10.1.1.10, path 300 metric 0
> BGP: 10.2.2.6 rcv UPDATE about 55.55.2.0/24, next
> hop
> 10.1.1.10, path 300 metric 0
> BGP: 10.2.2.6 rcv UPDATE about 55.55.3.0/24, next
> hop
> 10.1.1.10, path 300 metric 0
> BGP: 10.2.2.6 rcv UPDATE about 55.55.4.0/24, next
> hop
> 10.1.1.10, path 300 metric 0
> BGP: 10.2.2.6 rcv UPDATE about 10.1.1.4/30, next hop
> 10.2.2.6, path metric 0
> BGP: nettable_walker 10.1.1.4/255.255.255.252
> calling
> revise_route
> BGP: revise route installing
> 10.1.1.4/255.255.255.252
> -> 10.2.2.6
> BGP: nettable_walker 55.55.1.0/255.255.255.0 not
> synchronized
> BGP: nettable_walker 55.55.2.0/255.255.255.0 not
> synchronized
> BGP: nettable_walker 55.55.3.0/255.255.255.0 not
> synchronized
> BGP: nettable_walker 55.55.4.0/255.255.255.0 not
> synchronized
>
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
=-=-=-=-=-=
>
>
>
> OK, so I set no sync, and everything works, but
> somehow I'm not quite satisfied,
> I understand IBGP learned routes won't be advertised
> to EBGP neighbors unless sync'd
> but should IBGP neighbors share (and use) routes
> learned via EBGP without having to redistribute
> via an igp? Running eigrp on R1 and R4 is not an
> option.
>
>
>
> Thanks,
>
> Rob
>
>
>
>
> configs below:
>
> R1
> *************************************
> interface Loopback101
> ip address 11.11.1.1 255.255.255.0
> !
> interface Loopback102
> ip address 11.11.2.1 255.255.255.0
> !
> interface Loopback103
> ip address 11.11.3.1 255.255.255.0
> !
> interface Loopback104
> no ip address
> !
> interface Loopback105
> ip address 11.11.4.1 255.255.255.0
>
> interface Serial0
> ip address 10.1.1.1 255.255.255.252
> no ip mroute-cache
> no fair-queue
> !
> router bgp 100
> network 11.11.1.0 mask 255.255.255.0
> network 11.11.2.0 mask 255.255.255.0
> network 11.11.3.0 mask 255.255.255.0
> network 11.11.4.0 mask 255.255.255.0
> neighbor 10.1.1.2 remote-as 200
> !
>
>
> R2
> *************************************
> !
> interface Loopback100
> ip address 10.2.2.5 255.255.255.255
> !
> interface Serial0
> ip address 10.1.1.2 255.255.255.252
> no fair-queue
> clockrate 1000000
> !
> interface Serial1
> ip address 10.1.1.5 255.255.255.252
> clockrate 1000000
> !
> router eigrp 100
> network 10.0.0.0
> !
> router bgp 200
> network 10.1.1.4 mask 255.255.255.252
> neighbor 10.1.1.1 remote-as 100
> neighbor 10.2.2.6 remote-as 200
> neighbor 10.2.2.6 update-source Loopback100
> !
>
>
>
> R3
> **************************************
>
> interface Loopback100
> ip address 10.2.2.6 255.255.255.255
> !
> interface Serial0
> ip address 10.1.1.6 255.255.255.252
> no fair-queue
> !
> interface Serial1
> ip address 10.1.1.9 255.255.255.252
>
> router eigrp 100
> network 10.0.0.0
> !
> router bgp 200
> network 10.1.1.4 mask 255.255.255.252
> neighbor 10.1.1.10 remote-as 300
> neighbor 10.2.2.5 remote-as 200
> neighbor 10.2.2.5 update-source Loopback100
> !
>
>
>
> R4
> ******************************************
> interface Loopback101
> ip address 55.55.1.1 255.255.255.0
> !
> interface Loopback102
> ip address 55.55.2.1 255.255.255.0
> !
> interface Loopback103
> ip address 55.55.3.1 255.255.255.0
> !
> interface Loopback104
> no ip address
> !
> interface Loopback105
> ip address 55.55.4.1 255.255.255.0
> !
> interface Serial1
> ip address 10.1.1.10 255.255.255.252
> clockrate 1000000
> !
> router bgp 300
> network 55.55.0.0 mask 255.255.0.0
> network 55.55.1.0 mask 255.255.255.0
> network 55.55.2.0 mask 255.255.255.0
> network 55.55.3.0 mask 255.255.255.0
> network 55.55.4.0 mask 255.255.255.0
> neighbor 10.1.1.9 remote-as 200
>
>
>
>
>
>
=== message truncated ===
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:44 GMT-3