From: Mike Gutknecht (mgutknec@xxxxxxxxx)
Date: Wed Apr 04 2001 - 03:31:17 GMT-3
The simple topology:
R1 - bri0 -----bri0 R2
R1:ISDN number 1111
R2 ISDN number 2222
I want R2, the snapshot client, to call R1.
The problem: R2 dials and connects with R1. R1 gets R2s routes but R2 does
not get routes from R1. By debugging (IP packet, dialer packet, snapshot),
I find that "encapsulation failed" on R1's RIP packets as they are sent out
bri0 to R2. I can't figure out why. I have a dialer map statement on R1's
bri0 pointing to R2 with the broadcast keyword. Also, a ping from R2-bri0
to R1-bri0 works. I did notice that when the call came in to R1 the calling
party's number (2222) was not identified.
Any ideas? Also, does the called party always need a "dialer map
...broadcast" statement for snapshot to work?
Here is the debug ip packet on the RIP updates at router 1. Recall that a
ping from 10.0.1.1 to 10.0.1.2 works.
01:36:41: IP: s=10.0.1.2 (BRI0), d=255.255.255.255, len 92, rcvd 2
01:36:41: IP: s=10.0.1.2 (BRI0), d=255.255.255.255, len 32, rcvd 2
router1#
01:36:54: IP: s=10.0.1.1 (local), d=255.255.255.255 (BRI0), len 92, sending
broad/multicast
01:36:54: IP: s=10.0.1.1 (local), d=255.255.255.255 (BRI0), len 92,
encapsulation failed
01:36:54: IP: s=10.0.1.1 (local), d=255.255.255.255 (BRI0), len 32, sending
broad/multicast
01:36:54: IP: s=10.0.1.1 (local), d=255.255.255.255 (BRI0), len 32,
encapsulation failed
01:36:54: IP: s=10.1.1.1 (local), d=255.255.255.255 (Ethernet0), len 172,
sending broad/multicast
01:36:55: IP: s=10.1.2.1 (local), d=255.255.255.255 (Loopback0), len 172,
sending broad/multicast
01:36:55: IP: s=10.1.3.1 (local), d=255.255.255.255 (Loopback1), len 172,
sending broad/multicast
01:36:55: IP: s=10.1.2.1 (Loopback0), d=255.255.255.255, len 172, unroutable
01:36:55: IP: s=10.1.3.1 (Loopback1), d=255.255.255.255, len 172, unroutable
01:36:55: IP: s=10.0.1.1 (local), d=10.0.1.2 (BRI0), len 132, sending ! DUE
to the neighbor statement in the RIP config, still fails
01:36:55: IP: s=10.0.1.1 (local), d=10.0.1.2 (BRI0), len 132, encapsulation
failed
01:36:55: IP: s=10.0.1.1 (local), d=10.0.1.2 (BRI0), len 32, sending
01:36:55: IP: s=10.0.1.1 (local), d=10.0.1.2 (BRI0), len 32, encapsulation
failed
Here are the relevant portions of the configs
router1#sh run
Building configuration...
Current configuration:
!
version 11.3
!
hostname router1
!
enable password cisco
!
username router2 password 0 cisco
isdn switch-type basic-5ess
!
!
!
!
interface Loopback0
ip address 10.1.2.1 255.255.255.0
!
interface Loopback1
ip address 10.1.3.1 255.255.255.0
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip route-cache
no ip mroute-cache
!
interface BRI0
ip address 10.0.1.1 255.255.255.0
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer map ip 10.0.1.2 broadcast 2222
dialer-group 1
isdn switch-type basic-5ess
snapshot server 5 dialer
ppp authentication chap
hold-queue 75 in
!
router rip
network 10.0.0.0
neighbor 10.0.1.2
!
ip classless
!
no logging console
dialer-list 1 protocol ip permit
------
!
hostname router2
!
isdn switch-type basic-5ess
username router1 password 0 cisco
!
!
!
!
interface Loopback0
ip address 10.2.2.1 255.255.255.0
!
interface Loopback1
ip address 10.2.3.1 255.255.255.0
!
interface Ethernet0
ip address 10.2.1.1 255.255.255.0
no ip route-cache
no ip mroute-cache
!
interface BRI0
ip address 10.0.1.2 255.255.255.0
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer idle-timeout 30
dialer map snapshot 1 1111
dialer map ip 10.0.1.1 broadcast 1111
dialer-group 1
isdn switch-type basic-5ess
snapshot client 5 10 suppress-statechange-update dialer
ppp authentication chap
hold-queue 75 in
!
router rip
network 10.0.0.0
!
ip classless
!
dialer-list 1 protocol ip permit
!
Mike Gutknecht
Systems Engineer
Cisco Systems
4550 SW Kruse Way Suite 365
Lake Oswego, OR 97035
Email:mgutknec@cisco.com
Desk: 503.699.4679
Cell: 503.704.8365
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:39 GMT-3