From: Corey M. Ellis (corey.m.ellis@xxxxxxxx)
Date: Tue Apr 03 2001 - 21:48:39 GMT-3
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Corey M. Ellis
Sent: Tuesday, April 03, 2001 2:20 PM
To: CCIE Mailist
Subject: ISDN backup problem, not working correctly
Hi everyone,
I have been working on a ISDN backup scenario, where IPX can traverse the
ISDN line at all time, and IP only when the frame interface goes down. This
scenario has to use Dialer profiles because of requirements. I have
configured what I feel to be a correct configuration using dialer watch, and
snapshot for IPX.
Any way my IPX dialer interface is fine, I can ping and everything. But my
IP dialer interface can't ping the remote side of the ISDN link. I see
where the dialer binds to the bri interface but when I do a debug ip packet
I get encapsulation failed. Both sides are using ppp so I don't understand
where the encapsulation failed is pointing to. I am posting my configs.
Any help will be appreciated. The routers are r5 (Called router) and r6
(Calling router). The primary line is the Serial 0 subinterfaces on both
routers r6 is p-to-p and r5 is multipoint. if this goes down it should
bring up the ISDN line for IP.
Thanks in advance
This is the CALLED Router!!!!
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
!
username non-ip password 0 cisco
username backup password 0 cisco
username r6 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0005.0005.0005
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Ethernet0
ip address 172.16.195.5 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay lmi-type ansi
!
interface Serial0.125 multipoint
ip address 172.16.125.5 255.255.255.0
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-multipoint
ipx network 654
no ipx split-horizon eigrp 1
frame-relay map ipx 654.0004.0004.0004 103 broadcast
frame-relay map ipx 654.0006.0006.0006 102 broadcast
frame-relay map ip 172.16.125.4 103 broadcast
frame-relay map ip 172.16.125.6 102 broadcast
!
interface Serial0.140 point-to-point
ip address 172.16.140.5 255.255.255.0
ipx network 5588
frame-relay interface-dlci 104
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation ppp
shutdown
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 3840200001 384020
isdn spid2 3840200002 384030
ppp authentication chap
!
interface Dialer0
description ip dialer interface
ip address 172.16.15.5 255.255.255.0
encapsulation ppp
dialer remote-name backup
dialer idle-timeout 30
dialer max-call 4096
dialer-group 1
ppp authentication chap
ppp chap password 7 104D000A0618
!
interface Dialer1
description ipx dialer interface
no ip address
encapsulation ppp
dialer remote-name non-ip
dialer pool 1
dialer idle-timeout 30
dialer max-call 4096
dialer-group 2
ipx network AAA
snapshot server 5
ppp authentication chap
ppp chap password 7 00071A150754
!
router ospf 1
redistribute rip metric-type 1 subnets
network 172.16.15.0 0.0.0.255 area 0
network 172.16.125.5 0.0.0.0 area 0
!
router rip
version 1
redistribute ospf 1 metric 2
passive-interface BRI0
passive-interface Ethernet0
passive-interface Serial0.125
network 172.16.0.0
default-information originate
!
router bgp 100
no synchronization
neighbor 172.16.125.6 remote-as 200
neighbor 172.16.140.8 remote-as 100
neighbor 172.16.140.8 next-hop-self
!
no ip classless
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ipx permit
!
!
!
ipx router eigrp 1
network 654
!
!
ipx router rip
no network 654
!
!
!
tftp-server flash:c2500-jos56i-l_121-1.bin
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
login
!
end
###########CALLING ROUTER############
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
username r5 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0006.0006.0006
isdn switch-type basic-ni
cns event-service server
!
!
interface Loopback0
ip address 172.16.75.1 255.255.255.252
ipx network 6600
!
interface Loopback1
ip address 172.16.75.5 255.255.255.252
ipx network 6601
!
interface Loopback2
ip address 172.16.75.9 255.255.255.252
!
interface Loopback3
ip address 147.10.1.145 255.255.255.224
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.125 point-to-point
ip address 172.16.125.6 255.255.255.0
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-multipoint
ipx network 654
frame-relay interface-dlci 201
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface TokenRing0
ip address 140.10.1.1 255.255.255.0
ring-speed 16
!
interface BRI0
no ip address
encapsulation ppp
no ip mroute-cache
shutdown
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 3840000001 384000
isdn spid2 3840000002 384010
no fair-queue
ppp authentication chap
!
interface Dialer0
ip address 172.16.15.6 255.255.255.0
encapsulation ppp
ip ospf demand-circuit
dialer remote-name r5
dialer pool 1
dialer watch-disable 20
dialer string 384020 class ISDN
dialer load-threshold 1 outbound
dialer max-call 4096
dialer watch-group 1
dialer-group 1
ppp authentication chap
ppp chap hostname backup
ppp chap password 7 02050D480809
!
interface Dialer1
no ip address
encapsulation ppp
dialer remote-name r5-ipx
dialer pool 1
dialer idle-timeout 30
dialer string 384030
dialer max-call 4096
dialer-group 2
ipx network AAA
snapshot client 5 15 dialer
ppp authentication chap
ppp chap hostname non-ip
ppp chap password 7 1511021F0725
!
router ospf 1
area 2 range 172.16.75.0 255.255.255.224
network 172.16.15.0 0.0.0.255 area 0
network 172.16.75.0 0.0.0.255 area 2
network 172.16.125.6 0.0.0.0 area 0
!
router bgp 200
network 147.10.1.128 mask 255.255.255.224
neighbor 172.16.125.5 remote-as 100
!
no ip classless
no ip http server
!
!
map-class dialer ISDN
dialer idle-timeout 30
dialer watch-list 1 ip 172.16.125.0 255.255.255.0
dialer-list 1 protocol ip permit
dialer-list 2 protocol ipx permit
!
!
!
ipx router eigrp 1
network 654
!
!
ipx router rip
no network 654
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:29:39 GMT-3