RE: How to config isdn caller callback?

From: Bernard Dunn (dunn@xxxxxxxxx)
Date: Tue Feb 20 2001 - 10:27:50 GMT-3


   
Sylvian,

I've got this one for some reference:

limno --( )-- stego
 \______ISDN__/

==============================

hostname Stego
!
username Limno password 0 cisco
ip subnet-zero
no ip finger
!
isdn switch-type basic-ts013
!
interface Loopback0
 ip address 150.100.1.4 255.255.255.0
!
interface Loopback1
 ip address 150.100.20.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial0
 bandwidth 64
 no ip address
 encapsulation frame-relay
 no fair-queue
 clockrate 64000
 frame-relay interface-dlci 201 switched
  class 64k
 frame-relay intf-type dce
 frame-relay policing
!
interface Serial1
 bandwidth 2000
 no ip address
 encapsulation frame-relay
 no fair-queue
 clockrate 2000000
 frame-relay intf-type dce
 frame-relay policing
 frame-relay congestion-management
  threshold ecn bc 15
  threshold ecn be 0
  threshold de 30
!
interface Serial2
 bandwidth 64
 no ip address
 encapsulation frame-relay
 no fair-queue
 clockrate 64000
 frame-relay intf-type dce
 frame-relay policing
!
interface TokenRing0
 ip address 150.100.17.4 255.255.255.0
 ring-speed 16
 source-bridge 3 1 404
 source-bridge spanning
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ts013
 isdn calling-number 0294595100
!
interface Dialer1
 bandwidth 64
 ip address 150.100.19.2 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer pool 1
 dialer remote-name Limno
 dialer idle-timeout 300
 dialer string 0293551270
 dialer-group 1
 dialer callback request
 ppp authentication chap
!
router ospf 1
 no log-adjacency-changes
 area 2 stub
 network 150.100.17.0 0.0.0.255 area 2
 network 150.100.19.2 0.0.0.0 area 2
 network 150.100.20.1 0.0.0.0 area 2
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.100.19.1 190
no ip http server
!
!
access-list 101 deny ospf any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!

==========================

sh run
Building configuration...

Current configuration:
!
version 11.2
!
hostname Limno
!
enable secret 5 $1$5Al9$naxqovEmYYjYtagNG.D6Z.
!
username Stego password 0 cisco
no ip domain-lookup
isdn switch-type basic-ts013
source-bridge ring-group 505
!
interface Loopback0
 ip address 150.100.1.2 255.255.255.0
!
interface Loopback1
 ip address 150.100.18.2 255.255.255.0
!
interface Serial0
 ip address 150.100.2.2 255.255.255.0
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 bandwidth 64
 load-interval 60
 no fair-queue
 frame-relay map ip 150.100.2.1 201 broadcast
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 ip address 150.100.17.2 255.255.255.0
 ring-speed 16
 source-bridge 3 1 505
 source-bridge spanning
!
interface BRI0
 no ip address
 encapsulation ppp
 isdn calling-number 0293551270
 dialer pool-member 1
!
interface Dialer1
 ip address 150.100.19.1 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 bandwidth 64
 dialer remote-name Stego
 dialer idle-timeout 300
 dialer string 0294595100 class cb
 dialer pool 1
 dialer-group 1
 ppp callback accept
 ppp authentication chap
!
router ospf 1
 network 150.100.2.0 0.0.0.255 area 0
 network 150.100.17.0 0.0.0.255 area 2
 network 150.100.19.1 0.0.0.0 area 2
 area 2 stub no-summary
 area 2 range 150.100.16.0 255.255.240.0
!
ip classless
ip pim rp-address 150.100.2.1
!
map-class dialer cb
 dialer callback-server username
access-list 109 deny ospf any any
access-list 109 permit ip any any
!
snmp-server community public RO
dialer-list 1 protocol ip list 109
dialer-list 1 protocol appletalk list 610

On Tue, 20 Feb 2001, Sylvain Kouda wrote:

>
> Hi Bernard,
>
> I did a search with your name in the archives and I can't
> find information about "dialer profile and ppp callback".
> To recap, we know how to make the setup of "ppp callback"
> with bri interface.
> Once again if you can help , many thanks in advance.
>
> Sylvain.
>
>
> At 07:35 PM 2/20/01 +1100, Bernard Dunn wrote:
>
> >If you can search in the archives with my name, pretty sure there's one in
> >there.
> >
> >Sorry, but haven't got a copy of my sent-mail.
> >
> >Regards
> >
> >Bernard.
> >
> >
> >On Tue, 20 Feb 2001, Devender Singh wrote:
> >
> > > Has someone got callback working configs using dialer profiles. I tried
> > this
> > > sometimes back, with legacy it worked fine but not with dialer profiles.
 I
> > > donot have isdn simulator handy.
> > >
> > > Devender Singh
> > > BE(Hons), CCNP
> > > IP Solution Specialist
> > >
> > >
> > > -----Original Message-----
> > > From: Curtis Lindsay [mailto:clindsay_98@yahoo.com]
> > > Sent: Tuesday, 20 February 2001 12:37
> > > To: michheal david; ccielab@groupstudy.com
> > > Subject: Re: How to config isdn caller callback?
> > >
> > >
> > > Hi,
> > >
> > > Here is an example of callback> this config works. I
> > > have tested several times. Rember your map class
> > > statement. This tells the call back server which dial
> > > string to use.
> > >
> > > Brgds
> > > Curtis
> > >
> > > R1
> > > isdn switch-type basic-dms100
> > > !
> > > username R2 password cisco
> > > !
> > > int BRI0
> > > ip address 10.10.10.1 255.255.255.0
> > > encap PPP
> > > dialer secure
> > > dialer enable-timeout 2
> > > dialer load-threshold 1
> > > dialer map ip 10.10.10.2 name R2 class dialer1
> > > broadcast 8358662
> > > isdn switch-type basic-dms100
> > > isdn spid1 0835866101 8358661
> > > isdn spid2 0835866301 8358663
> > > ppp callback accept
> > > ppp multilink
> > > ppp authentication chap
> > > !
> > > map-class dialer dialer1
> > > dialer callback-server username
> > > !
> > > R2
> > > !
> > > isdn switch-type basic-dms100
> > > !
> > > username R1 password cisco
> > > !
> > > int bri0
> > > ip add 10.10.10.2 255.255.255.0
> > > encap ppp
> > > dialer map ip 10.10.10.1 name R1 broadcast 8358661
> > > isdn spid1 0835866201 8358662
> > > isdn spid2 0835866404 8358664
> > > ppp callback request
> > > ppp multilink
> > > ppp authentication chap
> > > !
> > > --- michheal david <michael302au@yahoo.com.au> wrote:
> > > > i config isdn caller callback in my lab,i config
> > > > accoding to DOC,but it isn't work.pls give a sample
> > > > config.
> > > >
> > > >
> > >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:28:53 GMT-3