RE: RE: AUX-AUX simulated DDR - and it works!

From: Rob Webber (rwebber@xxxxxxxxxxxx)
Date: Tue Feb 13 2001 - 15:57:16 GMT-3


   
On r3 (the router being called) you need:

line aux 0
  modem dialin

instead of:

line aux 0
  modem host

Try this and see if it works...
Rob.

-----Original Message-----
From: xuefengleng [mailto:xuefengleng@163.com]
Sent: Thursday, February 08, 2001 9:52 PM
To: rwebber@callisma.com; ccielab@groupstudy.com
Subject: Re: RE: AUX-AUX simulated DDR - and it works!

Hi,Rob Webber

 Thanks first for you help,The following is my config and deb dialer
messages:

R1:
Current configuration:
!
version 12.0
!
hostname r1
!
username r3 password 0 snow
username r1 password 0 snow
ip subnet-zero
chat-script snow "" ""
!
interface Async1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer pool-member 2
 async dynamic address
 async dynamic routing
 async mode dedicated
 ppp authentication chap
!
interface Dialer2
 ip address 10.1.1.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name r3
 dialer string 1234
 dialer pool 2
 dialer-group 1
 ppp authentication chap
!
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 script dialer snow
 modem Host
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 password cisco
 no login
!
end

R3:

Current configuration:
!
version 12.0
hostname r3
!
username r1 password 0 snow
username r3 password 0 snow
ip subnet-zero
chat-script snow "" ""
!
interface Loopback0
 ip address 177.0.0.3 255.255.255.255
 no ip directed-broadcast
!
interface Async1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer pool-member 3
 async dynamic address
 async dynamic routing
 async mode dedicated
 ppp authentication chap
!
interface Dialer3
 ip address 10.1.1.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name r1
 dialer string 1234
 dialer pool 3
 dialer-group 1
 ppp authentication chap
!
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
 script dialer snow
 modem Host
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 password cisco
 no login
!
end

r1#ping 10.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:

01:53:54: Async1 DDR: rotor dialout [priority]
01:53:54: Async1 DDR: Dialing cause ip (s=10.1.1.1, d=10.1.1.2)
01:53:54: Async1 DDR: Attempting to dial 1234
01:53:54: CHAT1: Attempting async line dialer script
01:53:54: CHAT1: Dialing using Modem script: snow & System script: none
01:53:54: CHAT1: process started
01:53:54: CHAT1: Asserting DTR....
01:54:01: CHAT1: Timed out waiting for CTS
01:54:01: Async1 DDR: disconnecting call.
Success rate is 0 percent (0/5)

snow

ÔÚ 01-2-6 21:41:00 ÄúдµÀ£º
>Hi,
>
>Yes, any console cable should work. The blue or black cable that you can
use
>as a console cable will work. If you wish, send me your configs and I will
>look at them.
>
>The async interface must match the line of the aux port. For example, if
you
>do a "show line" the AUX port will show up with a number next to it. On
>2501's its usually "1". On my terminal server its "9". Also note that only
>the router with the "modem Host" command can dial - I haven't been able to
>get it to dial the other way yet.
>
>Best Regards, Rob.
>
>-----Original Message-----
>From: xuefengleng [mailto:xuefengleng@163.com]
>Sent: Tuesday, February 06, 2001 6:27 PM
>To: Rob Webber; ccielab@groupstudy.com
>Subject: Re: AUX-AUX simulated DDR - and it works!
>
>
>Hi,Rob Webber
>
> What is the cable between the two router,
>
> r2 (Aux) ---------------------- (Aux)R3
> rollover cable
>
> I have tried, but I fail to dial, I must miss something, any suggestion?
>
>
>ÔÚ 01-1-26 12:55:00 ÄúдµÀ£º
>>I know there have been a few requests to be able to simulate DDR without
>>using modems, ISDN lines, simulators, etc. I believe I have an answer. I
>>have been able to get r3 to "dial" r4 in my rack. Yes, the line stays
quiet
>>until interesting traffic passes. Yes, it does time-out after the idle
>timer
>>expires. Here's how did it:
>>
>>I used the standard console cable ("null" cable, "rollover" cable) between
>>the AUX ports of my r3 and r4. As you can see I am using dialer profiles.
>>r4's config is fairly vanilla as far as dial is concerned. There are two
>key
>>commands on r3:
>>
>>line aux 0
>> modem Host
>> script dialer myscript
>>
>>The modem Host command instructs the router to be able to dial out and to
>>use DSR for modem control instead of CTS (no, I don't really understand
>>this). The second command instructs r3 to use the chat-script called
>>"myscript" when it dials. This command references the global command
>>chat-script myscript "" "". This effectively tells the router not to
>perform
>>any modem commands.
>>
>>So far I have tested it with pinging the actual dialer interface IP
address
>>at the other end as well as with floating static routes. I haven't gone
any
>>farther (dial watch, snapshot, etc.) yet. In this config r3 can call r4,
>but
>>not the other way.
>>
>>If anyone has any suggestions or improvements, feel free to post them!
>>Good luck, Rob.
>>------------------------------------------------------
>>Here are the actual configs:
>>
>>r3#c
>>Building configuration...
>>
>>
>>
>>Current configuration:
>>!
>>! Last configuration change at 16:25:42 EST Fri Jan 26 2001
>>!
>>version 12.0
>>service timestamps debug uptime
>>service timestamps log uptime
>>no service password-encryption
>>!
>>hostname r3
>>!
>>enable secret 5 $1$XyuD$Oej63qbu0VVbBSV9qMuti0
>>!
>>username r4 password 0 cisco
>>ip subnet-zero
>>ip tcp synwait-time 5
>>no ip domain-lookup
>>ip host r5 2002 200.200.200.1
>>ip name-server 207.238.183.71
>>ip name-server 207.238.183.72
>>ipx routing 0003.0003.0003
>>chat-script myscript "" ""
>>!
>>!
>>clock timezone EST 0
>>!
>>source-bridge ring-group 1000
>>dlsw local-peer peer-id 172.168.30.33 group 1 promiscuous
>>dlsw remote-peer 0 tcp 172.168.40.1
>>dlsw icanreach mac-address 0000.1234.1234 mask ffff.ffff.ffff
>>dlsw icanreach netbios-name BLOWME
>>!
>>!
>>interface Loopback0
>> ip address 172.168.30.65 255.255.255.224
>> no ip directed-broadcast
>> ipx network 3065
>>!
>>interface Loopback1
>> ip address 172.168.30.97 255.255.255.224
>> no ip directed-broadcast
>> ipx network 3097
>>!
>>interface Serial0
>> ip address 172.168.100.3 255.255.255.0
>> no ip directed-broadcast
>> encapsulation frame-relay
>> no ip route-cache
>> ip ospf network point-to-multipoint
>> no ip mroute-cache
>> logging event subif-link-status
>> logging event dlci-status-change
>> ipx network 100
>> frame-relay map ipx 100.0003.0003.0003 105 broadcast
>> frame-relay map ipx 100.0005.0005.0005 105 broadcast
>> frame-relay map ipx 100.0006.0006.0006 105 broadcast
>> frame-relay map ip 172.168.100.3 105 broadcast
>> frame-relay map ip 172.168.100.5 105 broadcast
>> frame-relay map ip 172.168.100.6 105 broadcast
>>!
>>interface Serial1
>> ip address 150.100.50.42 255.255.255.248
>> no ip directed-broadcast
>> no ip route-cache
>> no ip mroute-cache
>> ipx network 500
>>!
>>interface TokenRing0
>> mtu 1500
>> ip address 172.168.30.33 255.255.255.240
>> no ip directed-broadcast
>> no ip route-cache
>> no ip mroute-cache
>> ipx network 3033
>> ipx network 3034 encapsulation SNAP secondary
>> ring-speed 16
>> source-bridge 100 1 1000
>>!
>>interface Async9
>> no ip address
>> no ip directed-broadcast
>> encapsulation ppp
>> no ip route-cache
>> no ip mroute-cache
>> dialer in-band
>> dialer pool-member 1
>> async default routing
>> async dynamic routing
>> async mode dedicated
>> no peer default ip address
>> ppp authentication chap
>>!
>>interface Dialer0
>> ip address 1.1.1.1 255.255.255.0
>> no ip directed-broadcast
>> encapsulation ppp
>> dialer remote-name r4
>> dialer string 1234
>> dialer pool 1
>> dialer-group 1
>> ppp authentication chap
>>!
>>router ospf 1
>> area 3 range 172.168.30.0 255.255.255.0
>> area 10 virtual-link 172.168.200.1
>> passive-interface TokenRing0
>> network 172.168.30.32 0.0.0.31 area 3
>> network 172.168.30.64 0.0.0.31 area 3
>> network 172.168.30.96 0.0.0.31 area 3
>> network 172.168.100.0 0.0.0.255 area 10
>>!
>>router bgp 1
>> no synchronization
>> neighbor 172.168.100.5 remote-as 1
>> no auto-summary
>>!
>>ip classless
>>!
>>dialer-list 1 protocol ip permit
>>!
>>!
>>!
>>ipx router eigrp 1
>> network 100
>>!
>>!
>>!
>>banner motd ^CC
>>This is the 2510
>>^C
>>alias exec i show ip route
>>alias exec c show running-config
>>alias exec b show ip int brief
>>alias exec t config term
>>!
>>line con 0
>> exec-timeout 0 0
>> privilege level 15
>> password lucy
>> length 42
>> transport input none
>>line 1 8
>> no exec
>> transport input all
>>line aux 0
>> exec-timeout 0 0
>> script dialer myscript
>> modem Host
>> transport input all
>> speed 38400
>> flowcontrol hardware
>>line vty 0 4
>> exec-timeout 0 0
>> privilege level 15
>> password lucy
>> no login
>> length 42
>>!
>>ntp clock-period 17179941
>>ntp server 150.100.50.41
>>end
>>
>>r3#ping 1.1.1.2
>>
>>Type escape sequence to abort.
>>Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
>>
>>18:33:51: As9 DDR: rotor dialout [priority]
>>18:33:51: As9 DDR: Dialing cause ip (s=1.1.1.1, d=1.1.1.2)
>>18:33:51: As9 DDR: Attempting to dial 1234
>>18:33:51: CHAT9: Attempting async line dialer script
>>18:33:51: CHAT9: Dialing using Modem script: myscript & System script:
none
>>18:33:51: CHAT9: process started
>>18:33:51: CHAT9: Asserting DTR
>>18:33:52: CHAT9: Chat script myscript started
>>18:33:52: CHAT9: Chat script myscript finished, status = Success.
>>18:33:54: %LINK-3-UPDOWN: Interface Async9, changed state to up
>>18:33:54: %DIALER-6-BIND: Interface As9 bound to profile Di0.!!!
>>Success rate is 60 percent (3/5), round-trip min/avg/max = 80/84/92 ms
>>18:33:54: As9 DDR: dialer protocol up
>>18:33:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async9, changed
>>state
>>to up
>>
>>r3# ping 1.1.1.2
>>Type escape sequence to abort.
>>Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
>>!!!!!
>>Success rate is 100 percent (5/5), round-trip min/avg/max = 76/78/80 ms
>>r3#
>>r3#
>>r3#sho as st
>>Async protocol statistics:
>>
>> Int Local Remote Qd InPack OutPac Inerr Drops
>>MTU
>>* 9 0.0.0.0 1.1.1.2 0 250 257 0 0
>>1500
>>
>>
>> Rcvd: 250 packets, 19549 bytes
>> 0 format errors, 0 checksum errors, 0 overrun
>> Sent: 257 packets, 19975 bytes, 0 dropped
>>
>>r3#
>>17:51:55: As9 DDR: re-enable timeout
>>
>>r4#c
>>Building configuration...
>>
>>
>>
>>Current configuration:
>>!
>>version 12.0
>>service timestamps debug uptime
>>service timestamps log uptime
>>no service password-encryption
>>!
>>hostname r4
>>!
>>!
>>username r3 password 0 cisco
>>ip subnet-zero
>>ip tcp synwait-time 5
>>no ip domain-lookup
>>ip name-server 207.238.183.71
>>ip name-server 207.238.183.72
>>ipx routing 0004.0004.0004
>>ipx gns-response-delay 1100
>>!
>>!
>>!
>>source-bridge ring-group 1000
>>dlsw local-peer peer-id 172.168.40.1 group 1 border promiscuous
>>!
>>!
>>interface Serial0
>> ip address 172.168.200.2 255.255.255.0
>> no ip directed-broadcast
>> encapsulation frame-relay
>> ip split-horizon
>> no ip mroute-cache
>> logging event subif-link-status
>> logging event dlci-status-change
>> ipx network 200
>> no fair-queue
>>!
>>interface Serial1
>> no ip address
>> no ip directed-broadcast
>> shutdown
>>!
>>interface TokenRing0
>> ip address 172.168.40.1 255.255.255.0
>> no ip directed-broadcast
>> ipx network 40
>> ring-speed 16
>> source-bridge 100 1 1000
>>!
>>interface Async1
>> no ip address
>> no ip directed-broadcast
>> encapsulation ppp
>> dialer in-band
>> dialer pool-member 1
>> async dynamic routing
>> async mode dedicated
>> no peer default ip address
>> ppp authentication chap
>>!
>>interface Dialer0
>> ip address 1.1.1.2 255.255.255.0
>> no ip directed-broadcast
>> encapsulation ppp
>> dialer remote-name r3
>> dialer string 1234
>> dialer pool 1
>> dialer-group 1
>> ppp authentication chap
>>!
>>router igrp 1
>> network 172.168.0.0
>>!
>>router bgp 1
>> no synchronization
>> redistribute static
>> neighbor 172.168.200.1 remote-as 1
>> no auto-summary
>>!
>>ip classless
>>ip default-network 137.20.0.0
>>ip route 4.4.0.0 255.255.0.0 Null0
>>ip route 172.168.30.0 255.255.255.0 1.1.1.1 200
>>!
>>dialer-list 1 protocol ip permit
>>!
>>!
>>!
>>ipx router eigrp 1
>> network 200
>>!
>>!
>>ipx router rip
>> no network 200
>>!
>>!
>>!
>>tftp-server flash:c2500-jos56i-l.120-14.bin.Z
>>alias exec i show ip route
>>alias exec c show running-config
>>alias exec b show ip int brief
>>alias exec t config term
>>!
>>line con 0
>> exec-timeout 0 0
>> privilege level 15
>> transport input none
>>line aux 0
>> modem Dialin
>> transport input all
>> speed 38400
>> flowcontrol hardware
>>line vty 0 4
>> exec-timeout 0 0
>> privilege level 15
>> no login
>>!
>>end
>>
>>r4#
>>r4#sho as st
>>Async protocol statistics:
>>
>> Int Local Remote Qd InPack OutPac Inerr Drops
>>MTU
>>* 1 0.0.0.0 1.1.1.1 0 148 156 2 0
>>1500
>>
>>
>> Rcvd: 148 packets, 11459 bytes
>> 0 format errors, 2 checksum errors, 0 overrun
>> Sent: 156 packets, 11746 bytes, 0 dropped
>>
>>r4#sho dialer int as1
>>
>>As1 - dialer type = IN-BAND ASYNC NO-PARITY
>>Dialer pool 1, priority 0
>>Idle timer (120 secs), Fast idle timer (20 secs)
>>Wait for carrier (30 secs), Re-enable (15 secs)
>>Dialer state is data link layer up
>>Interface bound to profile Di0
>>Time until disconnect 39 secs
>>Current call connected 00:08:03
>>Connected to 1234 (r3)
>>r4#
>>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:28:47 GMT-3