VLSM-FLSM Mutual Redistribution Question

From: Peter (peter@xxxxxxxxx)
Date: Sun Feb 11 2001 - 21:36:53 GMT-3


   
Hello,

This is my topology:
r1s0--r2s0
          r2s1--r3s0
          r2e0--r4e0

r1 and r2 are running IGRP and r2, r3 and r4 are running OSPF. r2 is doing
mutual redistribution which works fine EXCEPT for the serial link between r2
and r3. If I add the 'summary-address 10.1.23.0 255.255.255.0' to the ospf
process on r2, the network shows up on r1. I then save all configs, reload
the routers and the 10.1.23.0 network will not summarize and get
redistributed. I have included the configs and route tables for r1 and r2
both before and after reload. If anyone can shed some light on this, it
would be greatly appreciated.

Thank you.
Peter

r1#sho run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
!
controller T1 0
 clock source line primary
!
controller T1 1
 clock source line secondary
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 10.1.1.11 255.255.255.0
 no ip directed-broadcast
 ip nat outside
!
interface Serial0
 ip address 10.1.12.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router igrp 10
 network 1.0.0.0
 network 10.0.0.0
!
ip nat inside source list 1 interface Ethernet0 overload
ip classless
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
!
line con 0
 transport input none
line 1 24
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
end

r2#sho run
Building configuration...

Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname r2
!
enable password cisco
!
no ip domain-lookup
!
controller T1 0
!
controller T1 1
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0
 ip address 10.1.24.2 255.255.255.0
 ip ospf message-digest-key 1 md5 cisco
!
interface Serial0
 ip address 10.1.12.2 255.255.255.0
 clockrate 56000
!
interface Serial1
 ip address 10.1.23.5 255.255.255.252
 ip ospf message-digest-key 1 md5 cisco
 clockrate 56000
!
router ospf 10
 summary-address 10.1.4.0 255.255.255.0
 summary-address 10.1.3.0 255.255.255.0
 summary-address 10.1.23.0 255.255.255.0
 redistribute connected metric 30 subnets route-map serial
 redistribute igrp 10 metric 30 subnets
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.23.5 0.0.0.0 area 0
 network 10.1.24.2 0.0.0.0 area 24
 distribute-list 1 out igrp 10
 area 0 authentication message-digest
 area 24 virtual-link 4.4.4.4 message-digest-key 1 md5 cisco
!
router igrp 10
 redistribute connected metric 100 1 255 1 1500 route-map loop
 redistribute ospf 10 metric 100 1 255 1 1500
 passive-interface Ethernet0
 passive-interface Serial1
 network 10.0.0.0
 distribute-list 2 out ospf 10
!
no ip classless
no logging console
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 1.0.0.0 0.255.255.255
access-list 2 permit 3.0.0.0 0.255.255.255
access-list 2 permit 4.0.0.0 0.255.255.255
access-list 2 permit 10.1.12.0 0.0.0.255
access-list 2 permit 10.1.23.0 0.0.0.255
access-list 2 permit 10.1.4.0 0.0.0.255
access-list 2 permit 2.0.0.0 0.255.255.255
access-list 2 permit 10.1.3.0 0.0.0.255
access-list 3 permit 2.0.0.0 0.255.255.255
access-list 4 permit 10.1.12.0 0.0.0.255
route-map serial permit 10
 match ip address 4
!
route-map loop permit 10
 match ip address 3
!
!
!
line con 0
line 1 24
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
end

r2#

*****ROUTING TABLES BEFORE RELOAD*****
r1#sho ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
I 2.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:17, Serial0
I 3.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:17, Serial0
I 4.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:17, Serial0
     10.0.0.0/24 is subnetted, 6 subnets
C 10.1.12.0 is directly connected, Serial0
I 10.1.3.0 [100/102001] via 10.1.12.2, 00:00:17, Serial0
C 10.1.1.0 is directly connected, Ethernet0
I 10.1.4.0 [100/102001] via 10.1.12.2, 00:00:17, Serial0
I 10.1.24.0 [100/102001] via 10.1.12.2, 00:00:17, Serial0
I 10.1.23.0 [100/102001] via 10.1.12.2, 00:00:17, Serial0
r1#

r2#sho ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

I 1.0.0.0/8 [100/8976] via 10.1.12.1, 00:00:10, Serial0
     2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 10.1.23.6, 00:19:26, Serial1
     4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/11] via 10.1.24.4, 00:19:36, Ethernet0
     10.0.0.0/8 is variably subnetted, 10 subnets, 5 masks
C 10.1.12.0/24 is directly connected, Serial0
O 10.1.3.0/24 is a summary, 00:00:31, Null0
I 10.1.1.0/24 [100/8576] via 10.1.12.1, 00:00:10, Serial0
O 10.1.4.0/24 is a summary, 00:00:31, Null0
C 10.1.24.0/24 is directly connected, Ethernet0
C 10.1.23.4/30 is directly connected, Serial1
O 10.1.23.0/24 is a summary, 00:00:32, Null0
O IA 10.1.4.16/28 [110/20] via 10.1.24.4, 00:19:28, Ethernet0
O IA 10.1.4.40/29 [110/20] via 10.1.24.4, 00:19:28, Ethernet0
O IA 10.1.3.32/27 [110/74] via 10.1.23.6, 00:19:28, Serial1
r2#

*****ROUTING TABLES AFTER RELOAD*****
r1#sho ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
I 2.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:56, Serial0
I 3.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:56, Serial0
I 4.0.0.0/8 [100/102001] via 10.1.12.2, 00:00:56, Serial0
     10.0.0.0/24 is subnetted, 5 subnets
C 10.1.12.0 is directly connected, Serial0
I 10.1.3.0 [100/102001] via 10.1.12.2, 00:00:56, Serial0
C 10.1.1.0 is directly connected, Ethernet0
I 10.1.4.0 [100/102001] via 10.1.12.2, 00:00:56, Serial0
I 10.1.24.0 [100/102001] via 10.1.12.2, 00:00:56, Serial0
r1#
r2#sho ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

I 1.0.0.0/8 [100/8976] via 10.1.12.1, 00:00:53, Serial0
     2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 10.1.23.6, 00:17:17, Serial1
     4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/11] via 10.1.24.4, 00:17:27, Ethernet0
     10.0.0.0/8 is variably subnetted, 9 subnets, 5 masks
C 10.1.12.0/24 is directly connected, Serial0
O 10.1.3.0/24 is a summary, 00:17:36, Null0
I 10.1.1.0/24 [100/8576] via 10.1.12.1, 00:00:53, Serial0
O 10.1.4.0/24 is a summary, 00:17:36, Null0
C 10.1.24.0/24 is directly connected, Ethernet0
C 10.1.23.4/30 is directly connected, Serial1
O IA 10.1.4.16/28 [110/20] via 10.1.24.4, 00:17:18, Ethernet0
O IA 10.1.4.40/29 [110/20] via 10.1.24.4, 00:17:19, Ethernet0
O IA 10.1.3.32/27 [110/74] via 10.1.23.6, 00:17:19, Serial1
r2#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:28:45 GMT-3