From: Michael Le (mmle@xxxxxxxxxxxxxxxxx)
Date: Fri Jan 26 2001 - 19:35:37 GMT-3
I'm trying to get this command to work and it's acting weird.
I have just two routers who are EBGP peers. I want it that if R1 has the
route 10.10.10.0/24 in it's routing table, then it will send the 0.0.0.0
route to R2.
[R1]-------[R2]
The configs are as follows:
R1
!
int Serial 0
description To EBGP Peer R2
ip address 192.168.1.1 255.255.255.0
int Loopback 0
description BGP Source Interface
ip address 1.1.1.1 255.255.255.0
int Loopback 1
ip address 10.10.10.1 255.255.255.0
!
router bgp 1
network 192.168.1.2 remote-as 2
network 192.168.1.2 update-source Loopback 0
network 192.168.1.2 ebgp multihop
network 192.168.1.2 default-originate route-map mymap
!
route-map mymap permit 10
match ip address 1
!
access-list 1 permit 10.10.10.0
Please assume next-hop connectivity and all that, as I haven't posted entire
config. Config for R2 isn't really needed.
If I have the configuration as above, then R1 will not advertise the
default route to R2.
However, if I change Loopback 1 to '10.10.10.1 255.0.0.0' and I change the
access-list to 'permit 10.0.0.0', it will work.
It seems as if it only works with classful networks. I have tried this
with
other network masks too and it only works when the network and the masks
match each other classfully.
This makes no sense to me. Could someone please explain if I'm doing
something wrong or if the command was made to work this way? And if it was
made to work this way, why? Because it doesn't really give you that much
flexibility with your route-maps.
Thank you.
Michael Le
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:45 GMT-3