From: Vikas Gupta (vicky_gupta1803@xxxxxxxxx)
Date: Tue Jan 23 2001 - 13:34:28 GMT-3
In this case the OPSF network type on R1 would be
non_broadcast, and since R1 has direct connectivity to
R2 and R3, you will have to make R1 as DR with
neighbor satatments pointing to R2 and R3.
Additionally on R2 and R3 under you point-to-point
interfaces, you have to use "ip ospf network
non_broadcast", since FR point-to-point interfaces are
OSPF point-to-point network types by default. A good
practice is to have "ip ospf pri 0" command on spokes
making them ineligible for DR. Also in this scenario
you don't need "broadcast" keyword on your FR map
statments on R1 as the neighbor adj. packets will be
unicasted to addresses specified in neighbor command.
HTH
Vikas
--- Paul Adams <paul.adams@callisma.com> wrote:
> Greeting All,
>
> While playing around on a few routers last night, I
> encountered the
> following issue:
>
>
> ________
> | |-----------------R2
> R1---------- FS |
> |_______ |-------------R4
>
> The objective was to use Physical -no sub int's on
> R1 and Point to Point
> ints on R2 & R3.
> Exchange OSPF routes between hub and spokes with one
> restriction- NO ip
> ospf network multipoint command- on R1 or point to
> point on R1
>
> Is this doable? or is it a must to use point to
> multipoint in this
> situation?
>
> Please review the configs when the opportunity
> permits.
>
> I also tried to set R1 ip ospf priority to zero so
> no one would
> become the DR since P to P's do not support a DR but
> the
> neighbors just stayed in INIT mode
>
> In the following config, the neighbors become
> adjacent but no
> routes are being exchanged......
>
> Thanks for any insight....
>
>
> R1 (HUB)
> interface Serial0
> ip address 172.16.1.1 255.255.255.0
> no ip directed-broadcast
> encapsulation frame-relay
> no ip mroute-cache
> frame-relay map ip 172.16.1.4 400 broadcast
> frame-relay map ip 172.16.1.2 200 broadcast
> frame-relay lmi-type ansi
>
> R1#sh ip ospf ne
>
> Neighbor ID Pri State Dead Time
> Address Interface
> 4.5.5.5 0 FULL/DROTHER 00:01:56
> 172.16.1.4 Serial0
> 8.8.8.8 0 FULL/DROTHER 00:01:42
> 172.16.1.2 Serial0
>
> R1#sh ip ospf int s0
> Serial0 is up, line protocol is up
> Internet Address 172.16.1.1/24, Area 0
> Process ID 1, Router ID 2.2.2.2, Network Type
> NON_BROADCAST, Cost: 64
> Transmit Delay is 1 sec, State DR, Priority 1
> Designated Router (ID) 2.2.2.2, Interface address
> 172.16.1.1
> No backup designated router on this network
> Timer intervals configured, Hello 30, Dead 120,
> Wait 120, Retransmit 5
> Hello due in 00:00:14
> Neighbor Count is 2, Adjacent neighbor count is 2
> Adjacent with neighbor 4.5.5.5
> Adjacent with neighbor 8.8.8.8
> Suppress hello for 0 neighbor(s)
>
> R1#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP,
> M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA
> - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external
> type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> level-2, * - candidate
> default
> U - per-user static route, o - ODR
>
> Gateway of last resort is not set
>
> 2.0.0.0/24 is subnetted, 3 subnets
> C 2.0.0.0 is directly connected, Loopback32
> C 2.1.1.0 is directly connected, Loopback1
> C 2.2.2.0 is directly connected, Loopback0
> 172.16.0.0/24 is subnetted, 1 subnets
> C 172.16.1.0 is directly connected, Serial0
>
****************************************************************************
> ****
>
> R2 (spoke)
> interface Serial0
> no ip address
> no ip directed-broadcast
> encapsulation frame-relay
> no ip mroute-cache
> frame-relay lmi-type ansi
> !
> interface Serial0.1 point-to-point
> ip address 172.16.1.2 255.255.255.0
> no ip directed-broadcast
> ip ospf hello-interval 30
> ip ospf priority 0
> frame-relay interface-dlci 200
>
> R2#sh ip ospf ne (Note R1 int lo0 is 2.2.2.2 /24)
>
> Neighbor ID Pri State Dead Time
> Address Interface
> 2.2.2.2 1 FULL/ - 00:01:45
> 172.16.1.1 Serial0.1
>
> R2#sh ip ospf int s0.1
> Serial0.1 is up, line protocol is up
> Internet Address 172.16.1.2/24, Area 0
> Process ID 1, Router ID 8.8.8.8, Network Type
> POINT_TO_POINT, Cost: 64
> Transmit Delay is 1 sec, State POINT_TO_POINT,
> Timer intervals configured, Hello 30, Dead 120,
> Wait 120, Retransmit 5
> Hello due in 00:00:17
> Neighbor Count is 1, Adjacent neighbor count is 1
> Adjacent with neighbor 2.2.2.2
> Suppress hello for 0 neighbor(s)
>
> R2#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP,
> M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA
> - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external
> type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> level-2, * - candidate
> default
> U - per-user static route, o - ODR
>
> Gateway of last resort is not set
>
> 172.16.0.0/24 is subnetted, 1 subnets
> C 172.16.1.0 is directly connected, Serial0.1
> 7.0.0.0/24 is subnetted, 3 subnets
> C 7.9.9.0 is directly connected, Loopback2
> C 7.8.8.0 is directly connected, Loopback1
> C 7.7.7.0 is directly connected, Loopback0
> 8.0.0.0/24 is subnetted, 1 subnets
> C 8.8.8.0 is directly connected, Loopback5
>
>
****************************************************************************
> ****************************************
> R4 (spoke)
> interface Serial0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0.1 point-to-point
> ip address 172.16.1.4 255.255.255.0
> ip ospf hello-interval 30
> ip ospf priority 0
> frame-relay interface-dlci 400
>
> R4#sh ip ospf ne
>
> Neighbor ID Pri State Dead Time
> Address Interface
> 2.2.2.2 1 FULL/ - 00:01:58
> 172.16.1.1 Serial0.1
>
> R4#sh ip ospf int s0.1
> Serial0.1 is up, line protocol is up
> Internet Address 172.16.1.4/24, Area 0
> Process ID 1, Router ID 4.5.5.5, Network Type
> POINT_TO_POINT, Cost: 64
> Transmit Delay is 1 sec, State POINT_TO_POINT,
> Timer intervals configured, Hello 30, Dead 120,
> Wait 120, Retransmit 5
> Hello due in 00:00:08
> Index 4/4, flood queue length 0
> Next 0x0(0)/0x0(0)
> Last flood scan length is 1, maximum is 1
> Last flood scan time is 0 msec, maximum is 0 msec
> Neighbor Count is 1, Adjacent neighbor count is 1
> Adjacent with neighbor 2.2.2.2
> Suppress hello for 0 neighbor(s)
>
> R4#sh ip route
> Codes: C - connected, S - static, I - IGRP, R - RIP,
> M - mobile, B - BGP
>
=== message truncated ===
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:41 GMT-3