RE: policy routing

From: Steve Clubb (sclubb@xxxxxxxxxxx)
Date: Thu Jan 18 2001 - 20:24:39 GMT-3


   
OK - It's working now, thank to all you contributors.

Here's the config:

interface Loopback4
 ip address 192.168.100.1 255.255.255.0
 ip policy route-map policy
!
interface Serial0
 ip address 137.20.29.9 255.255.255.240
 ip rip send version 2
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
!
router rip
 version 1
 network 137.20.0.0
 network 192.168.100.0
!
ip local policy route-map policy
ip classless
ip route 0.0.0.0 0.0.0.0 64.166.75.129
!
access-list 101 permit ip any 137.20.0.0 0.0.255.255
route-map policy permit 10
 match ip address 101
 set ip next-hop 137.20.29.2
!
route-map policy permit 20

The loopback4 had to be added to rip, which was redistributed into the
neighboring OSPF domain 137.20.0.0. Those networks had to know about the
loopback network.

Extended ping from the loopback worked successfully.

Also, interface command ip policy had to work in conjuction with the global
ip local policy command.

Thanks everyone,

Steve

-----Original Message-----
From: Frank Buffington [mailto:frank@buff-net.com]
Sent: Wednesday, January 17, 2001 7:51 PM
To: Steve Clubb
Cc: ccielab@groupstudy.com
Subject: Re: policy routing

Steve,
    When you set a default route it's only used if there's no route in the
routing table. Well the same thing applies here. If you use:

set ip default next-hop 137.20.29.2

that will set the next hop only if there is no route in the routing table
for
packets matching access-list 1.

If you want to change the next-hop for all packets matching your access-list
1
then use:

set ip next-hop 137.20.29.2

Hope this helps. v/r, Frank

Steve Clubb wrote:

> Hey people -
>
> I have a situation where I want to forward traffic going to a certain
subnet
> out an interface or to a next-hop IP. All other traffic to take the
default
> route configured on the router. I can't use a static route. I tried this
> but it's not working. Any ideas?
>
> ip local policy route-map policy
> ip classless
> ip route 0.0.0.0 0.0.0.0 64.168.75.12
> !
> access-list 1 permit 137.20.0.0 0.0.255.255
> access-list 2 permit any
> !
> !
> !
> route-map policy permit 10
> match ip address 1
> set ip default next-hop 137.20.29.2
> !
> route-map policy permit 20
> match ip address 2
>
> Thanks,
>
> Steve
>
>
>
>
>
>
>
>
>
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:27:34 GMT-3