From: Fred Ingham (fningham@xxxxxxxxxxxxxxxx)
Date: Mon Dec 18 2000 - 01:23:11 GMT-3
Long Answer.
There are some general principles for redistributing VLSM-FLSM:
RIP will redistribute the 0.0.0.0 default network
use the default-information originate command
IGRP does not distribute the 0.0.0.0 network
use the ip default-network command
network must be classful, in routing table,
and not on FLSM router
Split horizon will effect routes
ip classless must be configured on the FLSM router.
Sample config OSPF/RIP:
R1 - router running RIP and OSPF:
int s0/0
encap frame
bandwidth 1000
!
int s 0/0.1 point-to-multipoint
description serial to r2 and r3
ip add 172.16.65.1 255.255.255.128 /25 will not be distributed
frame map ip 172.16.65.2 102 br to RIP or to IGRP
frame map ip 172.16.65 3 103 br
!
int s 0/0.2 point-to-point
description serial to r4
ip add 172.16.33.1 255.255.255.0 /24 in RIP or IGRP domain
frame-relay interface-dlci 102
!
router ospf 1
redistribute rip subnets
summary-address 172.16.44.0 255.255.252.0 r4 loopbacks
netw 172.16.65.0 0.0.0.255 area 0
neighbor 172.16.65.2 r1 is DR, this is
neighbor 172.16.65.3 another topic
router rip
redistribute ospf 1 metric 3 Mutual redistribution
default-information originate distribute a default route
passive-interface s0/0.1
netw 172.16.0.0
Note that route maps or distribute lists are not needed to
prevent loops. Why?
R4 - router running RIP:
int s 0
encap frame
ip add 172.16.33.4 255.255.255.0
frame map ip 172.16.33.1 401 br
ip split-horizon off by default, needs to be enabled
!
int loop 0
ip add 172.16.44.4 255.255.255.0
int loop 1
ip add 172.16.45.4 255.255.255.0
int loop 2
ip add 172.16.46.4 255.255.255.0
int loop 3
ip add 172.16.47.4 255.255.255.0
!
router rip
netw 172.16.0.0
ip classless
Discussion: r4 will announce and accept /24 routes. r4 will also
accept host, /32, routes, and classful routes. r1 will not advertise
/25 routes to r4. Without split horizon enabled r4 would announce
routes back to r1. With the default-information-originate there
will be a default route in r4's route table pointing to r1 s0/0.2.
The /25 routes will not be in r4's routing table but all interfaces
will be able to be pinged using the default route.
r4 route table before default-information originate command:
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.44.0 is directly connected, Loopback44
C 172.16.45.0 is directly connected, Loopback45
C 172.16.46.0 is directly connected, Loopback46
C 172.16.47.0 is directly connected, Loopback47
C 172.16.33.0 is directly connected, Serial0
r4 route table after adding default-information originate:
Gateway of last resort is 172.16.33.1 to network 0.0.0.0
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.44.0 is directly connected, Loopback44
C 172.16.45.0 is directly connected, Loopback45
C 172.16.46.0 is directly connected, Loopback46
C 172.16.47.0 is directly connected, Loopback47
C 172.16.33.0 is directly connected, Serial0
R* 0.0.0.0/0 [120/1] via 172.16.33.1, 00:01:18, Serial0
***********************************************************
R1 - router running IGRP and OSPF (changes from above only):
int e 0 another network which can be
ip address 192.168.1.1 255.255.255.0 from ospf or a connected interface
no keep on r1
router ospf 1
no redistribute rip subnets
redistribute igrp 1 subnets
no router rip
router igrp 1
redistribute ospf 1
default-metric 1000 2000 255 1 1500
network 172.16.0.0
network 192.168.1.0 required since network is not in
passive-interface s0/0.1 ospf, could also redis connected
ip default-network 192.168.1.0 classful, in r1's routing table,
not advertised by r4
R4 - router running IGRP (changes only):
no router rip
router igrp 1
netw 172.16.0.0
Discussion: Same comments as for RIP except now there
is no default 0.0.0.0 route. r4's routing table will have
a default gateway pointing to r1's s0/0.2. The /25 networks
will not be in the routing table but can be pinged using the
gateway of last resort. ip classless must be configured on r4.
r4's routing table before ip default-network command:
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.44.0 is directly connected, Loopback44
C 172.16.45.0 is directly connected, Loopback45
C 172.16.46.0 is directly connected, Loopback46
C 172.16.47.0 is directly connected, Loopback47
C 172.16.33.0 is directly connected, Serial0
r4's routing table after default network command:
Gateway of last resort is 172.16.33.1 to network 192.168.1.0
172.16.0.0/24 is subnetted, 5 subnets
C 172.16.44.0 is directly connected, Loopback44
C 172.16.45.0 is directly connected, Loopback45
C 172.16.46.0 is directly connected, Loopback46
C 172.16.47.0 is directly connected, Loopback47
C 172.16.33.0 is directly connected, Serial0
I* 192.168.1.0/24 [100/8576] via 172.16.33.1, 00:00:05, Serial0
HTH to clearify issues. Fred.
Roy Grego wrote:
>
> Hello,
>
> When I red OSPF routes into IGRP I am losing some
> routes.
>
> Example:
>
> OSPF clouds -- R1 --- IGRP ----- R2
>
> R1 has these routes in its OSPF database & Routing
> table. R1 can ping all these addresses.
> C 1.1.1.1 /24
> E2 2.2.2.2 /30
> E2 3.3.3.3 /24
> C 4.4.4.4 /24
> O 5.5.5.5 /24
> O 6.6.6.6 /30
>
> BUT R2 will not see 3.3.3.3 or 6.6.6.6. Where do
> these go? The routes being lost are not all subnetted,
> nor are they External OSPF routes.
>
> Sample configs:
> router ospf 1
> network 1.1.1.1 0.0.0.0 area 0
> red igrp 4 subnets metric 500 route-map IGRP2OSPF
>
> router igrp 4
> network 4.0.0.0
> red ospf 1 match e i metric 1500 100 255 1 1500
>
> Is there a debug to see the routes being redistributed
> and/or routes rejected for redistribution?
>
> FYI, R1 has a Frame connection with Multipoint subint.
> and networks 3, 5, & 6 can be routed 2 different ways.
> Does OSPF have a problem with this?
>
> Thanks,
> ROY
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:26:04 GMT-3