RE: Demand routes in OSPF

From: Andrew Lennon (andrew.lennon@xxxxxxxxxxxxx)
Date: Wed Dec 06 2000 - 11:33:31 GMT-3


   
Here is an attempt at a diagram...

          r5-s0--frame-s0-r9
          ! !
         bri s0
          ! !
         r2-e0--r6
         !
        s0-igrp 172.16.164.0/24
        !
        r7-172.16.160/1/2/3.0/24,172.16.7.0/24

frame=172.16.130.0/28
isdn=172.16.130.252/30
ether=172.16.132.0/22
frame - ospf area1
isdn - ospf area5
eth0 - ospf area0
r2/s0 - igrp

configs:
r5:

hostname r5
!
enable password cisco
!
username ccielab password 0 ccielab
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-net3
!
source-bridge ring-group 2000
dlsw local-peer peer-id 172.16.5.5
dlsw remote-peer 0 tcp 172.16.7.7
!
!
interface Loopback0
 ip address 172.16.5.5 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 bandwidth 2000
 ip address 172.16.130.5 255.255.255.240
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 no fair-queue
 cdp enable
 frame-relay map ip 172.16.130.6 102 broadcast
 frame-relay map ip 172.16.130.10 102 broadcast
 no frame-relay inverse-arp
!
interface TokenRing0
 ip address 172.16.8.5 255.255.255.0
 no ip directed-broadcast
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning
!
interface BRI0
 bandwidth 64
 ip address 172.16.130.253 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf demand-circuit
 dialer map ip 172.16.130.254 name r2 broadcast 2222
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap
!
router ospf 100
 network 172.16.5.0 0.0.0.255 area 1
 network 172.16.8.0 0.0.0.255 area 1
 network 172.16.130.0 0.0.0.31 area 1
 network 172.16.130.252 0.0.0.3 area 5
!
ip classless
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

r2:

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
enable password cisco
!
ip subnet-zero
ip name-server 194.112.32.10
ipx routing 0000.0c3d.d632
isdn switch-type basic-net3
!
!
!
interface Loopback0
 ip address 172.16.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.16.132.2 255.255.252.0
 no ip directed-broadcast
!
interface Ethernet0.1
 no ip directed-broadcast
 ipx network 2
 arp timeout 0
!
interface Serial0
 bandwidth 2000
 ip address 172.16.164.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 bandwidth 64
 ip address 172.16.130.254 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 dialer idle-timeout 90
 dialer map ip 172.16.130.253 name r5 broadcast 1111
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap callin
 ppp chap hostname ccielab
 ppp chap password 7 1414110209082B29
!
router ospf 100
 redistribute connected metric 110 metric-type 1 subnets route-map
filter-bri0
 redistribute igrp 100 metric 110 metric-type 1 subnets route-map igrp-route
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.130.252 0.0.0.3 area 5
 network 172.16.132.0 0.0.3.255 area 0
!
router igrp 100
 passive-interface BRI0
 passive-interface Loopback0
 passive-interface Serial1
 network 172.16.0.0
 no default-information in
 no default-information out
 default-metric 2000 100 255 1 1500
 distance 115
!
ip classless
!
access-list 1 permit 172.16.130.252 0.0.0.3
access-list 1 permit 172.16.2.0 0.0.0.255
access-list 10 permit 172.16.7.0 0.0.0.255
access-list 10 permit 172.16.160.0 0.0.0.255
access-list 10 permit 172.16.161.0 0.0.0.255
access-list 10 permit 172.16.162.0 0.0.0.255
access-list 10 permit 172.16.163.0 0.0.0.255
access-list 10 permit 172.16.164.0 0.0.0.255
access-list 11 deny any
dialer-list 1 protocol ip permit
!
!
ipx router eigrp 100
 network 2
!
!
!
route-map igrp-route permit 10
 match ip address 10
!
route-map igrp-route permit 20
 match ip address 11
!
route-map filter-bri0 deny 10
 match ip address 1
!
route-map filter-bri0 permit 20
!

Thanks

Andy

-----Original Message-----
From: Tony Olzak [mailto:aolzak@buckeye-express.com]
Sent: Tuesday, December 05, 2000 18:54
To: Andrew Lennon; ccielab@groupstudy.com
Subject: Re: Demand routes in OSPF

Paste your configs and a network diagram.

Tony

----- Original Message -----
From: "Andrew Lennon" <andrew.lennon@nscglobal.com>
To: <ccielab@groupstudy.com>
Sent: Tuesday, December 05, 2000 10:56 AM
Subject: RE: Demand routes in OSPF

> Having done a b4 and after, the routes not reverting are the IGRP routes
> from r2 and the loopback on r2. The metric is 170 via s0 and 1672 via
bri0.
> I am stumped!
>
> Andy
>
> Before:
>
> Gateway of last resort is 172.16.130.10 to network 0.0.0.0
>
> O E2 192.168.10.0/24 [110/15] via 172.16.130.10, 00:44:12, Serial0
> O E2 172.17.0.0/16 [110/1] via 172.16.130.6, 00:43:41, Serial0
> 172.16.0.0/16 is variably subnetted, 19 subnets, 5 masks
> O E2 172.16.164.0/24 [110/20] via 172.16.130.6, 00:44:12, Serial0
> O E1 172.16.160.0/24 [110/170] via 172.16.130.6, 00:40:19, Serial0
> O E1 172.16.161.0/24 [110/170] via 172.16.130.6, 00:40:19, Serial0
> O E1 172.16.162.0/24 [110/170] via 172.16.130.6, 00:44:12, Serial0
> O E1 172.16.163.0/24 [110/170] via 172.16.130.6, 00:44:12, Serial0
> O IA 172.16.136.0/24 [110/100] via 172.16.130.6, 00:44:12, Serial0
> O IA 172.16.137.0/24 [110/106] via 172.16.130.6, 00:44:08, Serial0
> O IA 172.16.132.0/22 [110/60] via 172.16.130.6, 00:44:13, Serial0
> C 172.16.130.0/28 is directly connected, Serial0
> O 172.16.10.1/32 [110/51] via 172.16.130.10, 00:44:13, Serial0
> C 172.16.5.0/24 is directly connected, Loopback0
> O E1 172.16.7.0/24 [110/170] via 172.16.130.6, 00:44:26, Serial0
> O IA 172.16.17.17/32 [110/61] via 172.16.130.6, 00:44:26, Serial0
> O IA 172.16.6.6/32 [110/51] via 172.16.130.6, 00:44:26, Serial0
> O IA 172.16.4.4/32 [110/101] via 172.16.130.6, 00:44:26, Serial0
> O IA 172.16.2.2/32 [110/61] via 172.16.130.6, 00:44:26, Serial0
> O E2 172.16.2.0/24 [110/20] via 172.16.130.6, 00:44:26, Serial0
> C 172.16.130.252/30 is directly connected, BRI0
> C 172.16.100.0/24 is directly connected, TokenRing0
> O E2 158.152.0.0/16 [110/1] via 172.16.130.6, 00:43:56, Serial0
> O E2 192.168.5.0/24 [110/15] via 172.16.130.10, 00:44:27, Serial0
> O E2 195.92.65.0/24 [110/15] via 172.16.130.10, 00:44:27, Serial0
> O E2 10.0.0.0/8 [110/1] via 172.16.130.6, 00:43:56, Serial0
> 192.168.6.0/27 is subnetted, 1 subnets
> O 192.168.6.224 [110/60] via 172.16.130.10, 00:44:27, Serial0
> O E2 192.168.7.0/24 [110/15] via 172.16.130.10, 00:44:27, Serial0
> O E2 62.0.0.0/8 [110/15] via 172.16.130.10, 00:44:27, Serial0
> O E2 135.136.0.0/16 [110/1] via 172.16.130.6, 00:44:27, Serial0
> O*E2 0.0.0.0/0 [110/1] via 172.16.130.10, 00:44:27, Serial0
>
> After: (once the bri has come up and gone down again)
>
> Gateway of last resort is 172.16.130.10 to network 0.0.0.0
>
> O E2 192.168.10.0/24 [110/15] via 172.16.130.10, 00:07:30, Serial0
> O E2 172.17.0.0/16 [110/1] via 172.16.130.6, 00:07:30, Serial0
> 172.16.0.0/16 is variably subnetted, 19 subnets, 5 masks
> O E2 172.16.164.0/24 [110/20] via 172.16.130.254, 00:07:30, BRI0
> O E1 172.16.160.0/24 [110/1672] via 172.16.130.254, 00:07:30, BRI0
> O E1 172.16.161.0/24 [110/1672] via 172.16.130.254, 00:07:30, BRI0
> O E1 172.16.162.0/24 [110/1672] via 172.16.130.254, 00:07:30, BRI0
> O E1 172.16.163.0/24 [110/1672] via 172.16.130.254, 00:07:30, BRI0
> O IA 172.16.136.0/24 [110/100] via 172.16.130.6, 00:07:30, Serial0
> O IA 172.16.137.0/24 [110/106] via 172.16.130.6, 00:07:31, Serial0
> O IA 172.16.132.0/22 [110/60] via 172.16.130.6, 00:07:31, Serial0
> C 172.16.130.0/28 is directly connected, Serial0
> O 172.16.10.1/32 [110/51] via 172.16.130.10, 00:54:02, Serial0
> C 172.16.5.0/24 is directly connected, Loopback0
> O E1 172.16.7.0/24 [110/1672] via 172.16.130.254, 00:07:32, BRI0
> O IA 172.16.17.17/32 [110/61] via 172.16.130.6, 00:07:32, Serial0
> O IA 172.16.6.6/32 [110/51] via 172.16.130.6, 00:07:32, Serial0
> O IA 172.16.4.4/32 [110/101] via 172.16.130.6, 00:07:32, Serial0
> O IA 172.16.2.2/32 [110/61] via 172.16.130.6, 00:07:32, Serial0
> O E2 172.16.2.0/24 [110/20] via 172.16.130.254, 00:07:32, BRI0
> C 172.16.130.252/30 is directly connected, BRI0
> C 172.16.100.0/24 is directly connected, TokenRing0
> O E2 158.152.0.0/16 [110/1] via 172.16.130.6, 00:07:33, Serial0
> O E2 192.168.5.0/24 [110/15] via 172.16.130.10, 00:07:33, Serial0
> O E2 195.92.65.0/24 [110/15] via 172.16.130.10, 00:07:33, Serial0
> O E2 10.0.0.0/8 [110/1] via 172.16.130.6, 00:07:33, Serial0
> 192.168.6.0/27 is subnetted, 1 subnets
> O 192.168.6.224 [110/60] via 172.16.130.10, 00:54:04, Serial0
> O E2 192.168.7.0/24 [110/15] via 172.16.130.10, 00:07:33, Serial0
> O E2 62.0.0.0/8 [110/15] via 172.16.130.10, 00:07:33, Serial0
> O E2 135.136.0.0/16 [110/1] via 172.16.130.6, 00:07:33, Serial0
> O*E2 0.0.0.0/0 [110/1] via 172.16.130.10, 00:07:33, Serial0
> r2504b#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:59 GMT-3