From: Justin Menga (Justin.Menga@xxxxxxxxxxxxxxxxxx)
Date: Sun Oct 29 2000 - 17:10:54 GMT-3
Using PPP Multilink fragmentation introduces extra overhead, which increases
the bandwidth requirement for a voice stream.
The fragment size you are using is not a good size if you consider the
following:
I assume G.729 is being used. The default configuration will use a 60 byte
IP packet (20 byte voice payload + 40 byte IP header). Add onto this the
MLPPP header of 6 bytes, and you have a total of 66 bytes.
If you use a fragment size of 40 bytes, each frame must be split into two
fragments, which increases the overhead per voice packet, and is probably
over the 28800bps bandwidth you have set....
To change the number of voice samples per IP packet:
dial-peer voice 1 voip
codec <codec> bytes <number of bytes>
If you took off the multilink, the performance might be better, but once you
started mixing other traffic, the voice would suffer. 28800 is too little
bandwidth.
Regards,
Justin Menga MCSE+I CCNP CCSE ASE
WAN Specialist
Computerland New Zealand
PO Box 3631, Auckland
DDI: (+64) 9 360 4864 Mobile: (+64) 25 349 599
mailto: justin.menga@computerland.co.nz
-----Original Message-----
From: Guoxing Jiang [mailto:jianggx@transcentury.com.cn]
Sent: Saturday, 28 October 2000 8:03 p.m.
To: ccielab@groupstudy.com
Subject: VOIP, why does the multilink make the voice worse??
Hello,
I just borrowed two 1750-4Vs, and did some pratices according the
examples that found in CCO. But I met some puzzled things when I did
the example--VoIP with PPP over Low Bandwidth leased Line and RTP Priority
(http://www.cisco.com/warp/customer/793/voip/voip_ppp_lowbw_rtp_prio.html).
First I set the clock rate at 64000. everthing seems ok. But when I
lowered the clock rate to 28800. the voice became worse,jetter,
something lost. But if I don't using multilink(remove the serial
interface from the multilink interface), the voice is ok and
acceptable. Later I found every frame be splited into 40 bytes long
packets when using multilink. Maybe it make the voice worse, so I add
"no ppp multilink fragmentation" under the multilink interface. It is
ok, but if I need to add this command, what's the aim of using
multilink ppp with interleaving?? I think the fragmentation is the
core of "multilink with interleave", am I right?
I want to control the split packet size, but I can't find how to change
the default 40 bytes length.
Another strange things, when I using multilink, if I using extended
ping and set the packet size above 500, it am always failed. but it is
ok, if the packet size less than 500. why?????
Final question, can I simulated payload using long ping when the call
is active? It's really affected the voice quality, and I tried to
config RSVP and the multiling with interleaving, just like I said
above, it didn't resolve the problem, maybe more worse.
My equipments is two 1750-4v, two 2 vic-2fxs, three phones.
my configuration:
r7#show running-config
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
voice-port 2/0
!
voice-port 2/1
!
dial-peer voice 1 voip
destination-pattern 888..
dtmf-relay cisco-rtp
ip precedence 5
session target ipv4:8.8.8.8
!
dial-peer voice 2 pots
destination-pattern 77701
port 2/0
!
process-max-time 200
!
interface Loopback1
ip address 7.7.7.7 255.255.255.0
no ip directed-broadcast
!
interface Multilink1
ip unnumbered Loopback1
no ip directed-broadcast
ip rtp priority 16384 16383 24
ip rtp header-compression iphc-format
ip tcp header-compression iphc-format
no ip mroute-cache
fair-queue 64 16 0
no cdp enable
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
multilink-group 1
!
interface Serial0
bandwidth 28
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
multilink-group 1
!
interface FastEthernet0
no ip address
no ip directed-broadcast
shutdown
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
!
end
r7#
r8#show run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
voice-port 2/0
!
voice-port 2/1
!
dial-peer voice 1 voip
destination-pattern 777..
dtmf-relay cisco-rtp
ip precedence 5
session target ipv4:7.7.7.7
!
dial-peer voice 2 pots
destination-pattern 88801
port 2/0
!
dial-peer voice 3 pots
destination-pattern 88802
port 2/1
!
process-max-time 200
!
interface Loopback1
ip address 8.8.8.8 255.255.255.0
no ip directed-broadcast
!
interface Multilink1
ip unnumbered Loopback1
no ip directed-broadcast
ip rtp priority 16384 16383 24
ip rtp header-compression iphc-format
ip tcp header-compression iphc-format
no ip mroute-cache
fair-queue 64 16 0
no cdp enable
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
multilink-group 1
!
interface Serial0
bandwidth 28
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 28800
ppp multilink
multilink-group 1
!
interface FastEthernet0
no ip address
no ip directed-broadcast
shutdown
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
!
end
r8#
r8#ping
Protocol [ip]:
Target IP address: 7.7.7.7
Repeat count [5]:
Datagram size [100]: 500
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 500-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/179/180 ms
r8#
r8#ping
Protocol [ip]:
Target IP address: 7.7.7.7
Repeat count [5]:
Datagram size [100]: 600
Timeout in seconds [2]: 4
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 600-byte ICMP Echos to 7.7.7.7, timeout is 4 seconds:
.....
Success rate is 0 percent (0/5)
r8#
Best regards,
Guoxing Jiang mailto:jianggx@transcentury.com.cn
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:31 GMT-3