From: Horton, Jeff (jhorton@xxxxxxxx)
Date: Tue Oct 17 2000 - 11:37:44 GMT-3
My apologies for the config I sent. For some reason at some point during my
troubleshooting late last night I temporarily removed the statement
disabling split-horizon on S0/0.2 for testing and forgot to add it back in.
I put it back in my config and still have the same problem.
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
memory-size iomem 20
ip subnet-zero
no ip domain-lookup
!
appletalk routing eigrp 1
appletalk route-redistribution
ipx routing 0001.0001.0001
!
!
!
!
interface Loopback0
ip address 137.20.1.33 255.255.255.240
no ip directed-broadcast
!
interface Loopback1
ip address 137.20.1.17 255.255.255.240
no ip directed-broadcast
!
interface Ethernet0/0
ip address 137.20.10.1 255.255.255.0
no ip directed-broadcast
appletalk cable-range 100-100 100.1
appletalk zone z100
!
interface Serial0/0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0/0.1 point-to-point
ip address 137.20.100.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-multipoint
appletalk cable-range 12-12 12.1
appletalk zone z12
appletalk protocol eigrp
no appletalk protocol rtmp
ipx network 12
frame-relay interface-dlci 901
!
interface Serial0/0.2 multipoint
ip address 137.20.101.1 255.255.255.0
no ip directed-broadcast
ip ospf network point-to-multipoint
ipx network 156
no ipx split-horizon eigrp 1
frame-relay map ip 137.20.101.5 913 broadcast
frame-relay map ip 137.20.101.6 912 broadcast
frame-relay map ipx 156.0005.0005.0005 913 broadcast
frame-relay map ipx 156.0006.0006.0006 912 broadcast
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 137.20.1.32 0.0.0.15 area 11
network 137.20.10.0 0.0.0.255 area 10
network 137.20.100.0 0.0.0.255 area 0
network 137.20.101.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
!
ipx router eigrp 1
network 156
!
!
ipx router rip
no network 12
no network 156
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
-----Original Message-----
From: Rogell, Dennis [mailto:Dennis_Rogell@milgo.com]
Sent: Tuesday, October 17, 2000 10:10 AM
To: 'Horton, Jeff'
Subject: RE: IPX w/EIGRP
Jeff
All you need to do is turn off ipx split-horizon on the multipoint
subinterface. If it still does not work do a clear ipx route.
Hope this helps let me know what happens
Dennis Rogelll
Email : dennis_rogell@milgo,com
Phone: (954) 426-2581
> -----Original Message-----
> From: Horton, Jeff [SMTP:jhorton@lsfi.com]
> Sent: Tuesday, October 17, 2000 05:48
> To: CCIE Groupstudy (E-mail)
> Subject: IPX w/EIGRP
>
> Greetings. I have been mostly a lurker on this list so far but I do
> appreciate many of the useful questions and comments I have read. I am
> having a problem with IPX and EIGRP in a configuration in my lab. I really
> believe it is more of an IPX issue then EIGRP. Anyway, I have four routers
> R1, R2, R5, and R6. R1, R5, and R6 are connected over an NBMA frame-relay
> network connected via EIGRP. R1 is the hub connected via S0/0.2(a
> multipoint
> interface) to R5 AND R6.R1 is connected to S2 via S0/0.1(P2P) and works
> fine. I turned off split-horizon on int S0/0.2. The problem is that R1 can
> ping R5 and R1 can Ping R6 but R5 cannot ping R6. R2 can ping R5 and R6. I
> have tried this both with frame-relay maps and without. I know RIP will
> not
> work because of the split-horizon issue on R1. I realize this is probably
> something that will seem obvious once pointed out but right now I cannot
> see
> the forest for the trees.
>
> Thanks for any helpful comments or suggestions. Below is a copy of my
> latest
> config from on R1 (the hub) from late last night.
>
> Jeff
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> memory-size iomem 20
> ip subnet-zero
> no ip domain-lookup
> !
> appletalk routing eigrp 1
> appletalk route-redistribution
> ipx routing 0001.0001.0001
> !
> !
> !
> !
> interface Loopback0
> ip address 137.20.1.33 255.255.255.240
> no ip directed-broadcast
> !
> interface Loopback1
> ip address 137.20.1.17 255.255.255.240
> no ip directed-broadcast
> !
> interface Ethernet0/0
> ip address 137.20.10.1 255.255.255.0
> no ip directed-broadcast
> appletalk cable-range 100-100 100.1
> appletalk zone z100
> !
> interface Serial0/0
> no ip address
> no ip directed-broadcast
> encapsulation frame-relay
> no ip mroute-cache
> !
> interface Serial0/0.1 point-to-point
> ip address 137.20.100.1 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-multipoint
> appletalk cable-range 12-12 12.1
> appletalk zone z12
> appletalk protocol eigrp
> no appletalk protocol rtmp
> ipx network 12
> frame-relay interface-dlci 901
> !
> interface Serial0/0.2 multipoint
> ip address 137.20.101.1 255.255.255.0
> no ip directed-broadcast
> ip ospf network point-to-multipoint
> ipx network 156
> frame-relay map ip 137.20.101.5 913 broadcast
> frame-relay map ip 137.20.101.6 912 broadcast
> frame-relay map ipx 156.0005.0005.0005 913 broadcast
> frame-relay map ipx 156.0006.0006.0006 912 broadcast
> !
> interface Serial0/1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router ospf 1
> network 137.20.1.32 0.0.0.15 area 11
> network 137.20.10.0 0.0.0.255 area 10
> network 137.20.100.0 0.0.0.255 area 0
> network 137.20.101.0 0.0.0.255 area 0
> !
> ip classless
> no ip http server
> !
> !
> !
> ipx router eigrp 1
> network 156
> !
> !
> ipx router rip
> no network 12
> no network 156
> !
> !
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
> R1#
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:27 GMT-3