RE: DLSW prioritzation - Results

From: Jack Heney (jheneyccie@xxxxxxxxxxx)
Date: Tue Oct 10 2000 - 14:28:57 GMT-3


   
Okay...I don't know if this is the purpose, but I set up a lab and the
theory I proposed actually works...The setup looks like this:

Host A----f0/0-R1-s0/0------s0/0-R2-f0/0------f0/0-R3-to0/0-----Host C
                |
              f0/1
                |
                |
             Host B

I established a DLSW+ connection with priority between R1 and R3. I then
set up a SAP priority list that gave netbios and IPX traffic high priority
and put it on f0/0 only....When I initiated a NetBios connection from Host A
to Host C, the DLSW packets used port 2065, but when I initiated a conection
from Host B to Host C, all data packets used port 1982 (the default for data
packets)...Thus, I can conclude that using the "DLSW bridge-group x
sap-priority y" command will prioritize all traffic on interfaces in the
bridge-group, whereas leaving off the sap-priority on the above command and
using the "sap-priority" command on one interface in the bridge-group will
only prioritize traffic on that interface. Here is my config for R1:

sap-priority-list 1 high ssap F0 dsap F0
sap-priority-list 1 high ssap E0 dsap E0
dlsw local-peer peer-id 10.46.1.4
dlsw remote-peer 0 tcp 10.6.2.254 priority
dlsw bridge-group 1
!

interface FastEthernet0/0
no ip address
bridge-group 1
sap-priority 1
!
interface FastEthernet0/1
no ip address
bridge-group 1
!
interface Serial0/0
ip address 10.46.1.4 255.255.255.0
encapsulation frame-relay
custom-queue-list 1
!
queue-list 1 protocol ip 1 tcp 2065
queue-list 1 protocol ip 2 tcp 1981
queue-list 1 protocol ip 3 tcp 1982
queue-list 1 protocol ip 4 tcp 1983
queue-list 1 default 5
queue-list 1 queue 1 byte-count 500
queue-list 1 queue 2 byte-count 500
queue-list 1 queue 3 byte-count 500
queue-list 1 queue 4 byte-count 500
bridge 1 protocol ieee

Next I'll see if I can use a port-list with an ethernet port. Hope this
helped...Jack

>From: "Jack Heney" <jheneyccie@hotmail.com>
>Reply-To: "Jack Heney" <jheneyccie@hotmail.com>
>To: Simon.Baxter@au.logical.com, ccielab@groupstudy.com
>Subject: RE: DLSW prioritsation
>Date: Tue, 10 Oct 2000 01:13:40 GMT
>
>I've got a theory, but it is really nothing more than a theory, so if
>anyone
>knows I would love to hear the answer...What if you wanted to prioritize
>based on saps, but only for one interface in a bridge group that spanned
>multiple interfaces? I.E. if you don't specify a priority level but you
>turn on prioritization for DLSW, all data packets are classified for normal
>priority, so what if all traffic on one bridge-group interface was to be
>prioritized but all traffic on another could simply be classified as normal
>priority...Specifying "sap-priority" on the end of "dlsw bridge-group"
>wouldn't allow you to do this (all traffic from the bridge group would be
>prioritized). I'll try it out in the lab tomorrow, but that's the only
>thing I can come up with. Seems to make sense, though.
>
>As far as your other question goes, I think it has to do with backwards
>compatability...First, look at this link (careful with the word wrap) for
>IOS 12.0...It says that port-list can be used for token ring and serial:
>
>http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/ibm_r/b
rprt2/brdlsw.htm
>
>Then look at this link (version 11.2)...It says that port-list works for
>TR,
>serial, and ethernet (but strangely enough, the bgroup-list command is also
>shown, which I would assume replaced the use of port-list for ethernet
>interfaces...go figure):
>
>http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/112cg_cr/8rboo
k/8rdlsw.htm
>
>Doesn't make a whole lot of sense, and I'll check that one out tomorrow as
>well (whether or not it works with ethernet, that is)
>
>Jack
>
>
>>From: Simon Baxter <Simon.Baxter@au.logical.com>
>>To: Jack Heney <jheneyccie@hotmail.com>, ccielab@groupstudy.com
>>Subject: RE: DLSW prioritsation
>>Date: Tue, 10 Oct 2000 10:53:16 +1100
>>
>>Thanks for that..
>>
>>but...
>>
>>the sap-priority command also exists for the ethernet interface.....why?
>>Is it not for dlsw but for a multi-port bridge scenario?
>>
>>ie
>>int e0
>>bridge 5
>>sap-priority 1
>>!
>>int e1
>>bridge 5
>>sap-priority 1
>>
>>??
>>
>>Also, any idea why you can build a dlsw port list that includes ethernet
>>interfaces?? I thought TLSRB had to always be used with ethernets??
>>
>>thanks!
>>
>>Simon
>>
>>-----Original Message-----
>>From: Jack Heney [mailto:jheneyccie@hotmail.com]
>>Sent: Tuesday, October 10, 2000 8:08 AM
>>To: Simon Baxter; ccielab@groupstudy.com
>>Subject: Re: DLSW prioritsation
>>
>>
>>The configs you have posted are correct in that you have used the priority
>>command to open 4 tcp pipes to the remote peer, mapped incoming traffic to
>>the appropriate pipes (with the dlsw bridge-group sap-priority command),
>>and
>>
>>specified how traffic from those pipes will be handled in the output queue
>>(through custom queuing)...The sap-priority command associates incoming
>>traffic with a sap-priority-list, which is a function that you have
>>performed using the DLSW bridge-group sap-priority command (because
>>incoming
>>
>>traffic on any interface in the bridge group will be prioritized according
>>to your sap-priority-list)...Since token ring traffic is bridged into dlsw
>>with a source-bridge command (there is no equivalent of ethernet's
>>bridge-group), it requires a separate command to associate incoming
>>traffic
>>with a sap-priority-list, so the sap-priority command is used on incoming
>>interfaces. Hope this clears things up.
>>Jack
>>
>>
>> >From: Simon Baxter <Simon.Baxter@au.logical.com>
>> >Reply-To: Simon Baxter <Simon.Baxter@au.logical.com>
>> >To: "CCIE Group Study (E-mail)" <ccielab@groupstudy.com>
>> >Subject: DLSW prioritsation
>> >Date: Sun, 8 Oct 2000 19:08:17 +1100
>> >
>> >I've managed to get dlsw priority working as it should, but have a few
>> >queries.
>> >
>> >After the basic setup of :
>> >local peering
>> >remote peering
>> >dlsw remote priority
>> >
>> >I set up some sap-priority-lists to put netbios traffic ahead of sna etc
>> >etc.
>> >
>> >(RA-RB-RC)
>> >
>> >I found that I all I needed was :
>> >
>> >!
>> >hostname RA
>> >!
>> >!
>> >sap-priority-list 1 medium ssap F0 dsap F0
>> >sap-priority-list 1 high ssap 4 dsap 4
>> >dlsw local-peer peer-id 1.1.1.1
>> >dlsw remote-peer 0 tcp 3.3.3.3 priority
>> >dlsw bridge-group 5 sap-priority 1
>> >!
>> >interface Loopback0
>> > ip address 1.1.1.1 255.255.255.0
>> >!
>> >interface Ethernet0
>> > no ip address
>> > bridge-group 5
>> >!
>> >interface Serial0
>> > ip address 192.1.1.1 255.255.255.0
>> > custom-queue-list 1
>> >!
>> >!
>> >router eigrp 1
>> > network 192.1.1.0
>> >!
>> >no ip classless
>> >queue-list 1 protocol ip 1 tcp 2065
>> >queue-list 1 protocol ip 2 tcp 1981
>> >queue-list 1 protocol ip 3 tcp 1982
>> >queue-list 1 protocol ip 4 tcp 1983
>> >queue-list 1 protocol ip 5
>> >queue-list 1 queue 1 byte-count 500
>> >queue-list 1 queue 2 byte-count 500
>> >queue-list 1 queue 3 byte-count 500
>> >queue-list 1 queue 4 byte-count 500
>> >bridge 5 protocol ieee
>> >alias exec c conf t
>> >!
>> >
>> >RA#
>> >RC#term len 0
>> >RC#sh ru
>> >Building configuration...
>> >
>> >
>> >
>> >hostname RC
>> >!
>> >sap-priority-list 1 medium ssap F0 dsap F0
>> >sap-priority-list 1 high ssap 4 dsap 4
>> >dlsw local-peer peer-id 3.3.3.3
>> >dlsw remote-peer 0 tcp 1.1.1.1 priority
>> >dlsw bridge-group 5 sap-priority 1
>> >!
>> >interface Loopback0
>> > ip address 3.3.3.3 255.255.255.0
>> > no logging event subif-link-status
>> >!
>> >interface Ethernet0
>> > bridge-group 5
>> >!
>> >interface Async1
>> > ip address 193.1.1.1 255.255.255.0
>> > encapsulation ppp
>> > no logging event subif-link-status
>> > async default routing
>> > async dynamic routing
>> > async mode dedicated
>> > custom-queue-list 1
>> >!
>> >router eigrp 1
>> > network 193.1.1.0
>> > default-metric 38400 2 255 1 1500
>> >!
>> >queue-list 1 protocol ip 1 tcp 2065
>> >queue-list 1 protocol ip 2 tcp 1981
>> >queue-list 1 protocol ip 3 tcp 1982
>> >queue-list 1 protocol ip 4 tcp 1983
>> >queue-list 1 protocol ip 5
>> >queue-list 1 queue 1 byte-count 500
>> >queue-list 1 queue 2 byte-count 500
>> >queue-list 1 queue 3 byte-count 500
>> >queue-list 1 queue 4 byte-count 500
>> >!
>> >bridge 5 protocol ieee
>> > bridge 5 route ip
>> >line con 0
>> > exec-timeout 0 0
>> > privilege level 15
>> >line aux 0
>> > modem InOut
>> > rotary 1
>> > transport input all
>> > stopbits 1
>> > speed 38400
>> > flowcontrol hardware
>> >line vty 0 4
>> > privilege level 15
>> > no login
>> >!
>> >end
>> >
>> >RC#
>> >
>> >
>> >Question :
>> >
>> > I don't seem to need the "sap-priority 1" on either ethernet - but I
>>have
>> >seen it on token examples??? Why??
>> >
>> >
>> >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:25 GMT-3