From: Tony Olzak (aolzak@xxxxxxxxxxxxxxxxxxx)
Date: Mon Sep 25 2000 - 00:49:10 GMT-3
All,
Just wanted to close this topic and share my findings.
Without using the default-network command or static routes, the only
way to redistribute OSPF into IGRP with VLSM is to use the
summary-address command on the OSPF router. This route will be
redistirbuted into IGRP and allow that router to communicate with the
other networks. One catch is that this summary address must have the
same mask as the IGRP link that is enabled on that major network.
Example:
Router 1
!
interface Loopback1
ip address 172.17.59.1 255.255.255.248
!
interface Loopback2
ip address 172.17.59.17 255.255.255.240
!
interface Loopback3
ip address 172.17.59.33 255.255.255.224
!
interface Serial1
ip address 172.17.59.129 255.255.255.192
!
router ospf 100
summary-address 172.17.59.0 255.255.255.192
redistribute igrp 100 metric 64 subnets
passive-interface Serial1
network 172.17.59.0 0.0.0.7 area 0
network 172.17.59.16 0.0.0.15 area 1
network 172.17.59.32 0.0.0.31 area 2
!
router igrp 100
redistribute ospf 100 metric 64 10 255 1 1500
passive-interface Loopback1
passive-interface Loopback2
passive-interface Loopback3
network 172.17.0.0
!
ip classless
Router 2
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
!
interface Serial0
ip address 172.17.59.130 255.255.255.192
clockrate 64000
!
router igrp 100
network 10.0.0.0
network 172.17.0.0
!
ip classless
Router 1 and 2 are connected through their serial interfaces. The mask
on this connection is /26, so the summary on Router 1 must have a mask
of /26 also or it will not redistribute to router 2. At first I tried
a summary of 172.17.0.0 255.255.0.0 thinking that since IGRP only
understood classful networks that the summary address would have to be
a class B standard mask. The route did not make it to Router 2. After
skimming through Doyle's book, it reminded me how since the 172.17.0.0
network on router 2 had a mask of /26, only matching subnet masks
would redistribute from router 1.
Tony
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:01 GMT-3