Policy Routing and OSPF Adjacencies

From: Jason T. Rohm (jtrohm@xxxxxxxxxxx)
Date: Sat Sep 23 2000 - 22:31:08 GMT-3


   

I am working on CCIE Bootcamp lab #3 (Those of you with copies please refer
to the first diagram on lab 3).

I have four routers (1,3,4,5), three are connected via a partial-mesh frame
network. Routers 3 and 5 are connected via PVCs to router 1, while router 4
is connected to router 3 via a direct serial cable.

The requirements of the lab explicitly forbid the use of multiple frame-map
statements to overcome the partial-mesh issues. I have used a route-map that
forces traffic from router 3 to router 5 to be forced through router 1's
frame interface. However, when the policy is applied to local packets (ip
local policy...) router 3 fails to form an adjacency with router 4 (Sits in
INIT state). I am however able to ping router 4 from router 3. If I remove
the local policy, the routers form an adjacency.

Has anyone else seen this?

Configs:

Router 1

interface Serial0/0.2 multipoint
 ip address 137.20.30.1 255.255.255.0
 ip ospf priority 250
 frame-relay interface-dlci 103
 frame-relay interface-dlci 105
 no frame-relay inverse-arp
!
router ospf 137
 network 137.20.30.0 0.0.1.255 area 0
  neighbor 137.20.30.3
  neighbor 137.20.30.5
!
ip classless
!

Router 3

!
interface Serial0
 ip address 137.20.30.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay interface-dlci 301
!
interface Serial1
 ip address 137.20.63.3 255.255.255.0
 encapsulation ppp
 ip policy route-map NBMAFRAME
!
router ospf 137
 network 137.20.30.0 0.0.1.255 area 0
 network 137.20.63.0 0.0.0.255 area 1
!
ip classless
!
ip local policy route-map NBMAFRAME
!
access-list 30 permit 137.20.30.5
!
route-map NBMAFRAME permit 10
 match ip next-hop 30
 set ip next-hop 137.20.30.1
!

Router 4

interface Serial0
 ip address 137.20.63.4 255.255.255.0
 encapsulation ppp
 no fair-queue
 clockrate 250000
!
router ospf 137
 network 137.20.63.0 0.0.0.255 area 1
!
ip classless
!

Router 5

interface Serial0
 ip address 137.20.30.5 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf interface-retry 0
 ip ospf priority 0
 no ip mroute-cache
 frame-relay interface-dlci 501
!
router ospf 137
 network 137.20.30.0 0.0.1.255 area 0
!
ip local policy route-map NBMAFRAME
ip classless
!
access-list 30 permit 137.20.30.3
!
route-map NBMAFRAME permit 10
 match ip next-hop 30
 set ip next-hop 137.20.30.1
!



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:25:01 GMT-3