RE: DLSW versus STUN w/ Local Ack

From: Ron.Fuller@xxxxxx
Date: Thu Sep 07 2000 - 08:47:43 GMT-3


   

Here's the config from the router that is on the same ethernet segment as
the AS/400.
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Dublin_FR1
!
boot system flash 1:aaa0425.bin
logging buffered 4096 debugging
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip multicast-routing
ip dvmrp route-limit 20000
ipx routing 00d0.5874.fa60
!
source-bridge ring-group 20
dlsw local-peer peer-id 192.168.253.3
dlsw remote-peer 0 tcp 192.168.253.7
dlsw remote-peer 0 tcp 192.168.253.5
dlsw remote-peer 0 tcp 192.168.253.8
dlsw remote-peer 0 tcp 192.168.253.4
dlsw remote-peer 0 tcp 192.168.253.9
dlsw remote-peer 0 tcp 192.168.253.12
dlsw remote-peer 0 tcp 192.168.253.10
dlsw bridge-group 1
!
!
!
interface Loopback0
 description Loopback Interface for DLSW
 ip address 192.168.253.3 255.255.255.255
 no ip directed-broadcast
!
interface FastEthernet0/0
 description Ethernet LAN Segment in Dublin, OH
 ip address 192.168.2.1 255.255.255.0
 no ip directed-broadcast
 ip pim dense-mode
 ip igmp join-group 224.0.1.2
 ip cgmp
 speed 100
 full-duplex
 ipx network 20 encapsulation SAP
 bridge-group 1
!
interface Serial0/0
 description T-1 Circuit to QWEST DS1-1784884 (512k)
 bandwidth 512
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 priority-group 1
 service-module t1 timeslots 1-8
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description Frame Relay PVC for Alsip, IL DS1-1785044
 bandwidth 128
 ip address 192.168.254.5 255.255.255.252
 no ip directed-broadcast
 ipx network 2544
 frame-relay interface-dlci 607
!
interface Serial0/0.3 point-to-point
 description Frame Relay PVC for Grand Prairie, TX DS1-1790808
 bandwidth 128
 ip address 192.168.254.13 255.255.255.252
 no ip directed-broadcast
 ipx network 25412
 frame-relay interface-dlci 601
!
interface Serial0/0.4 point-to-point
 description Frame Relay PVD for Greensboro, NC DS1-1790766
 bandwidth 128
 ip address 192.168.254.17 255.255.255.252
 no ip directed-broadcast
 ipx network 25416
 frame-relay interface-dlci 602
!
interface Serial0/0.5 point-to-point
 description Frame Relay PVC for Ocala, FL DS1-1790350
 bandwidth 128
 ip address 192.168.254.21 255.255.255.252
 no ip directed-broadcast
 ipx network 25420
 frame-relay interface-dlci 603
!
interface Serial0/0.6 point-to-point
 description Frame Relay PVC for Rochester, NY DS1-1790297
 bandwidth 128
 ip address 192.168.254.25 255.255.255.252
 no ip directed-broadcast
 ipx network 25424
 frame-relay interface-dlci 604
!
interface Serial0/0.7 point-to-point
 description Frame Relay PVC for Union City, CA DS1-1785084
 bandwidth 256
 ip address 192.168.254.29 255.255.255.252
 no ip directed-broadcast
 ipx network 25428
 frame-relay interface-dlci 606
!
interface Serial0/0.8 point-to-point
 description Frame Relay PVC for Lexington, KY DS1-2144889
 bandwidth 64
 ip address 192.168.254.33 255.255.255.252
 no ip directed-broadcast
 ipx network 25432
 frame-relay interface-dlci 888
!
interface Serial0/1
 description T-1 Circuit to Global Crossings FRO2000126527FRA (512K)
 bandwidth 512
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 service-module t1 timeslots 1-8
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0/1.1 point-to-point
 description Frame Relay PVC for Rockwall, TX FRO2000126529FRP
 bandwidth 56
 ip address 192.168.254.37 255.255.255.252
 no ip directed-broadcast
 ipx network 25436
 frame-relay interface-dlci 201
!
interface Serial0/1.2 point-to-point
 description Frame Relay PVC for Jacksonville, FL FRO2000126529FRP
 bandwidth 56
 ip address 192.168.254.41 255.255.255.252
 no ip directed-broadcast
 ipx network 25440
 frame-relay interface-dlci 202
!
interface Serial0/1.3 point-to-point
 description Frame Relay PVC for Sparks, NV FRO2000163781FRP
 bandwidth 56
 ip address 192.168.254.1 255.255.255.252
 no ip directed-broadcast
 ipx network 2540
 frame-relay interface-dlci 203
!
interface Serial0/1.4 point-to-point
 description Frame Relay PVC for Mechanicsburg, PA FRO2000163783FRP
 bandwidth 56
 ip address 192.168.254.9 255.255.255.252
 no ip directed-broadcast
 ipx network 2548
 frame-relay interface-dlci 204
!
router eigrp 1
 redistribute static
 network 192.168.2.0
 network 192.168.253.0
 network 192.168.254.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.5
no ip http server
!
priority-list 1 protocol dlsw high
priority-list 1 default medium
!
!
ipx router eigrp 1
 network 2544
 network 2548
 network 25412
 network 25416
 network 25420
 network 25424
 network 25428
 network 25432
 network 25436
 network 25440
 network 2540
!
!
!
bridge 1 protocol ieee

And here's the config for one of the remote routers with two controllers on
it

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname UnionCity_FR1
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
ipx routing 00d0.5875.0820
!
dlsw local-peer peer-id 192.168.253.7
dlsw remote-peer 0 tcp 192.168.253.3
!
!
!
interface Loopback0
 description Loopback Interface for DLSW
 ip address 192.168.253.7 255.255.255.255
 no ip directed-broadcast
!
interface FastEthernet0/0
 description Ethernet LAN Segment in Union City, CA
 ip address 192.168.8.1 255.255.255.0
 ip helper-address 192.168.1.11
 no ip directed-broadcast
 speed 100
 full-duplex
 ipx network 80 encapsulation SAP
!
interface Serial0/0
 description Fractional T-1 to Dublin, OH DS1-1785084
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 priority-group 1
 service-module t1 timeslots 1-4
 service-module t1 remote-alarm-enable
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 description Frame Relay PVC to Dublin
 bandwidth 256
 ip address 192.168.254.30 255.255.255.252
 no ip directed-broadcast
 ipx network 25428
 frame-relay interface-dlci 600
!
interface BRI0/0
 description Disabled - Not In Use
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 description SDLC connection to IBM 5494 Controller 1
 no ip address
 no ip directed-broadcast
 encapsulation sdlc
 no keepalive
 clockrate 128000
 sdlc role prim-xid-poll
 sdlc vmac 4054.9470.0100
 sdlc address 0C
 sdlc xid 0C 0730000C
 sdlc partner 4200.800e.0000 0C
 sdlc dlsw C
!
interface Serial1/1
 description SDLC connection to IBM 5494 Controller 2
 no ip address
 no ip directed-broadcast
 encapsulation sdlc
 no keepalive
 clockrate 128000
 sdlc role prim-xid-poll
 sdlc vmac 4054.9470.0200
 sdlc address 0D
 sdlc xid 0D 0730000D
 sdlc partner 4200.800e.0000 0D
 sdlc dlsw D
!
interface Serial1/2
 description Disabled - Not In Use
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/3
 description Disabled - Not In Use
 no ip address
 no ip directed-broadcast
 shutdown
!
router eigrp 1
 network 192.168.8.0
 network 192.168.253.0
 network 192.168.254.0
 no auto-summary
!
ip classless
no ip http server
!
priority-list 1 protocol dlsw high
priority-list 1 default medium
!
ipx router eigrp 1
 network 25428
!
!
!
!

Hope that helps!

Ron Fuller, CCIE #5851, CCDP, CCNP-ATM, CCNP-Security, MCNE
3X Corporation
rfuller@3x.com

                    "Brian Jacklin"

                    <bmjackli@sprintpa To: <Ron.Fuller@3x.com>

                    ranet.com> cc: <ccielab@groupstudy.com>,
 <nobody@groupstudy.com>
                                              Subject: RE: DLSW versus STUN
 w/ Local Ack
                    09/06/00 12:22 PM

Ron,
 A sample config would be great!
 Thanks!
Brian Jacklin
Sprint ENS

-----Original Message-----
From: Ron.Fuller@3x.com [mailto:Ron.Fuller@3x.com]
Sent: Wednesday, September 06, 2000 6:08 AM
To: Brian Jacklin
Cc: ccielab@groupstudy.com; nobody@groupstudy.com
Subject: Re: DLSW versus STUN w/ Local Ack

I have configured this exact scenario for a number of my clients, and
here's my two bits. I have always leaned towards the DLSW solution.
First, as long as the AS/400 has a LAN card (ethernet or token ring) you
don't have to waste expensive serial ports on both the 400 and the router.
You also have more bandwidth to use as well. This can be an issue since we
have clients with 15 to 20 5x94 controllers remotely connected to the 400.
You use SDLC between the remote router and the controller, then encapsulate
it in IP using dlsw to transport it across the network. The only real
gotcha is to make sure that the controllers have the right PRPQ from IBM to
support PU 2.1 (I think...don't quote this as gospel). If your 400 is
running a newer version of OS/400, you'll be grooving. If you would like a
sample config, let me know.

STUN is cool and everything, but the real concern is the wasting of serial
ports. The DLSW solution will let you do the same thing with less
headaches. IMHO.

Ron Fuller, CCIE #5851, CCDP, CCNP-ATM, CCNP-Security, MCNE
3X Corporation
rfuller@3x.com

                    "Brian Jacklin"
                    <bmjackli@sprintpa To:
<ccielab@groupstudy.com>
                    ranet.com> cc:
                    Sent by: Subject: DLSW versus STUN
w/ Local Ack
                    nobody@groupstudy.
                    com

                    09/05/00 01:45 PM
                    Please respond to
                    "Brian Jacklin"

Can anyone give me a pro versus con analysis of DLSW versus STUN in the
following situation?

 AS/400 ----SDLC--- RTR-------Frame Relay WAN ----- RTR----SDLC---5394

 The AS 400 and 5394 controller are both connected to serial ports.

 Thanks!
 Brian Jacklin



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:53 GMT-3