Re: strange authentication problems on RIP, OSPF, BGP

From: aiqun hu (huaq@xxxxxxxxxxx)
Date: Wed Sep 06 2000 - 15:25:52 GMT-3


   
For example,

R3 S1 -----RIP V2------- R5 S1

Thanks,

r3#s
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r3
!
!
ip subnet-zero
no ip domain-lookup
!
key chain r5r3
key 0
  key-string ohio
key 1
  key-string indiana
key 2
  key-string kentucy
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
ip address 10.101.1.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain r5r3
!
interface TokenRing0
ip address 10.10.1.1 255.255.255.0
ring-speed 16
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip classless
!
alias exec s sho run
alias exec c conf t
alias exec i sho ip route
alias exec x sho ipx route
alias exec a sho apple route
alias exec xb sho ipx inter brief
alias exec ab sho apple inter brief
alias exec az sho apple zone
alias exec xs sho ipx servers
alias exec b sho ip bgp
alias exec bn sho ip bgp nei
alias exec inb sho ip inter brief
alias exec ss sho session
alias exec sio sh ip ospf nei
alias exec ci cle ip route *
alias exec cib cle ip bgp *
alias exec ibs sh ip bgp sum
alias exec sbn sh ip bgp nei
alias exec ib sh ip bgp
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end
r5#s
Building configuration...

Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r5
!
!
ip subnet-zero
no ip domain-lookup
!
key chain r5r3
key 0
  key-string ohio
key 1
  key-string indiana
key 2
  key-string kentucy
!
interface Loopback0
ip address 10.0.0.5 255.255.255.255
!
interface Ethernet0
ip address 10.20.1.2 255.255.255.0
!
interface Serial0
ip address 206.11.20.66 255.255.255.248
no fair-queue
!
interface Serial1
ip address 10.101.1.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain r5r3
clockrate 250000
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
router bgp 10060
bgp confederation identifier 200
bgp confederation peers 10600
neighbor 10.10.1.2 remote-as 10600
neighbor 10.20.1.1 remote-as 10060
neighbor 10.20.1.1 route-map setWei in
neighbor 10.20.1.1 password cisco
neighbor 206.11.20.65 remote-as 300
neighbor 206.11.20.65 route-map setWei in
neighbor 206.11.20.65 password cisco
no auto-summary
!
ip classless
ip as-path access-list 10 permit _500_
route-map setWei permit 10
match as-path 10
set weight 555
!
route-map setWei permit 999
!
!
alias exec s sho run
alias exec c conf t
alias exec i sho ip route
alias exec x sho ipx route
alias exec a sho apple route
alias exec xb sho ipx inter brief
alias exec ab sho apple inter brief
alias exec az sho apple zone
alias exec xs sho ipx servers
alias exec b sho ip bgp
alias exec bn sho ip bgp nei
alias exec inb sho ip inter brief
alias exec ss sho session
alias exec sio sh ip ospf nei
alias exec ci cle ip route *
alias exec cib cle ip bgp *
alias exec ibs sh ip bgp sum
alias exec sbn sh ip bgp nei
alias exec ib sh ip bgp
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

r5#

>From: Timur.Mirza@Notes.airtouch.com
>To: "aiqun hu" <huaq@hotmail.com>
>Subject: Re: strange authentication problems on RIP, OSPF, BGP
>Date: Wed, 6 Sep 2000 11:08:36 -0700
>
>
>
>
>can u post the cfgs? at least for rip & bgp?
>
>
>
>
>
>"aiqun hu" <huaq@hotmail.com> on 09/06/2000 10:52:02 AM
>
>Please respond to "aiqun hu" <huaq@hotmail.com>
>
>
>
>To: ccielab@groupstudy.com
>cc: (bcc: Timur Mirza/Corporate/AirTouch)
>Subject: strange authentication problems on RIP, OSPF, BGP
>
>
>
>I found that every time when I enable authentication on RIP, OSPF and BGP
>routing protocol, I had to reconfigure the PWD several times to make it
>work. I use notepad to copy and paste with the same authentication mode and
>same password on both sides, but always have some problems. Deleted the PWD
>on both sides, reconfigured the same PWD again and agin. It works!!!
>
>Anybody ran the same problems like that??? Is there any easiest way to get
>success on the first time when configuring the authentication on these
>routing protocols? I really want to get rid of these funny problems to save
>time.
>
>Thanks in advance for your reply
>
>Rena



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:53 GMT-3