RE: Dial backup for fram-relay point-to-multipoint interface

From: Aaron DuShey (aaron.dushey@xxxxxxxxxxxxxxxxxxxxx)
Date: Wed Sep 06 2000 - 11:22:24 GMT-3


   
you shouldn't need floating statics or point-to-point interface. OSPF demand
circuit should handle the situation for you-Notice below configuration-

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR, P - periodic downloaded static
route
       T - traffic engineered route

Gateway of last resort is not set

     170.100.0.0/16 is variably subnetted, 9 subnets, 4 masks
O E2 170.100.150.0/24 [110/30] via 170.100.20.2, Serial1/1
O E2 170.100.10.0/29 [110/30] via 170.100.11.1, FastEthernet0/0
C 170.100.11.0/24 is directly connected, FastEthernet0/0
O IA 170.100.30.1/32 [110/782] via 170.100.20.2, Serial1/1
C 170.100.25.0/28 is directly connected, BRI0/0
C 170.100.20.0/24 is directly connected, Serial1/1
O 170.100.53.2/32 [110/1562] via 170.100.53.1, Serial1/0
O 170.100.53.1/32 [110/781] via 170.100.53.1, Serial1/0
C 170.100.53.0/24 is directly connected, Serial1/0
grumpy#ip
Interface IP-Address OK? Method Status
Protocol

FastEthernet0/0 170.100.11.2 YES NVRAM up up

BRI0/0 170.100.25.1 YES NVRAM up up

BRI0/0:1 unassigned YES unset down down

BRI0/0:2 unassigned YES unset down down

FastEthernet0/1 unassigned YES NVRAM administratively down down

Serial1/0 170.100.53.3 YES NVRAM up up

Serial1/1 170.100.20.1 YES NVRAM up up

Serial1/2 unassigned YES NVRAM administratively down down

Serial1/3 unassigned YES NVRAM administratively down down

grumpy#c
Enter configuration commands, one per line. End with CNTL/Z.
grumpy(config)#int s1/0
grumpy(config-if)#shut
grumpy(config-if)#end
grumpy#
16:01:07: %SYS-5-CONFIG_I: Configured from console by console
16:01:30064771072: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
16:01:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed
stat
e to up
16:01:09: %LINK-5-CHANGED: Interface Serial1/0, changed state to
administrativel
y down
16:01:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed
sta
te to down
16:01:13: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 8358662 i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR, P - periodic downloaded static
route
       T - traffic engineered route

Gateway of last resort is not set

     170.100.0.0/16 is variably subnetted, 9 subnets, 4 masks
O E2 170.100.150.0/24 [110/30] via 170.100.20.2, Serial1/1
O E2 170.100.10.0/29 [110/30] via 170.100.11.1, FastEthernet0/0
C 170.100.11.0/24 is directly connected, FastEthernet0/0
O IA 170.100.30.1/32 [110/782] via 170.100.20.2, Serial1/1
C 170.100.25.2/32 is directly connected, BRI0/0
C 170.100.25.0/28 is directly connected, BRI0/0
C 170.100.20.0/24 is directly connected, Serial1/1
O 170.100.53.2/32 [110/2343] via 170.100.25.2, BRI0/0
O 170.100.53.1/32 [110/1562] via 170.100.25.2, BRI0/0
grumpy#r
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname grumpy
!
logging buffered 4096 debugging
enable secret 5 $1$nY34$qVfx1yJ0l9Oa9Kwhuek/i/
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
interface FastEthernet0/0
 ip address 170.100.11.2 255.255.255.0
 no ip directed-broadcast
!
interface BRI0/0
 ip address 170.100.25.1 255.255.255.240
 no ip directed-broadcast
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 20
 dialer map ip 170.100.25.2 broadcast 8358662
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/0
 ip address 170.100.53.3 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 shutdown
 frame-relay map ip 170.100.53.1 103 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 170.100.20.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial1/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1/3
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 1
 network 170.100.11.0 0.0.0.255 area 3
 network 170.100.20.0 0.0.0.255 area 2
 network 170.100.25.0 0.0.0.255 area 0
 network 170.100.53.0 0.0.0.255 area 0
 default-information originate always
 area 2 virtual-link 170.100.30.1
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!
alias exec i sh ip route
alias exec ip sh ip interface brief
alias exec b sh ip bgp
alias exec bn sh ip bgp neighbor
alias exec ipx sh ipx route
alias exec d sh dlsw pee
alias exec p sh protocols
alias exec r show run
alias exec c config t
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 password cisco
 logging synchronous
 login
line vty 0 4
 password cisco
 login
!
end

grumpy#
16:01:32: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from 8358662
, ca
ll lasted 24 seconds
16:01:141733920767: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to
down
16:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed
stat
e to down

Aaron DuShey

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
khalid siddiq
Sent: Wednesday, September 06, 2000 4:14 AM
To: ccielab@groupstudy.com
Subject: Dial backup for fram-relay point-to-multipoint interface

HI all,

I am facing a problem for configuring frame-relay point-to-multipoint
interface as a backup of isdn bri interface.
Ospf is running on both frame-raly and IP ospf on-demand circuit on
ISDN, the problem is that the PVC down but interface never , so
it cannot dial the isdn bri.

more the restriction are,
1- we have not to used frame-relay point-to-point interface.
2-no floating static route.

Is i can used dialer watch-list for OSPF ???
i read that watch-list is used only for EIGRP and IGRP.

Thanks in advance.
regards,
khalid



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:52 GMT-3