From: Ola Aiyegbusi (ola@xxxxxxxxxxx)
Date: Wed Sep 06 2000 - 11:29:05 GMT-3
Sorry about that. Here are the configs (somewhat truncated) ::
RTR A#sh run!
hostname RTR A
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
no fair-queue
!
interface Serial1
ip address 192.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 500000
!
router bgp 100
network 1.0.0.0
neighbor 192.1.1.2 remote-as 200
!
no ip classless
!
snmp-server community public RO
snmp-server community private RW
!
end
RTR B#sh run
version 12.0
!
hostname RTR B
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 193.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
ip address 192.1.1.2 255.255.255.0
no ip directed-broadcast
!
router ospf 64
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
no synchronization
neighbor 192.1.1.1 remote-as 100
neighbor 193.1.1.1 remote-as 200
!
ip classless
!
snmp-server community public RO
snmp-server community private RW
!
end
RTR C#sh run
!
version 11.1
hostname RTR C
!
partition flash 2 8 8
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Ethernet0
ip address 193.1.1.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
description !!!!!!THIS INTERFACE IS NOT WORKING!!!!!!!
no ip address
no ip directed-broadcast
no ip mroute-cache
no ip route-cache
shutdown
!
interface Serial1
ip address 194.1.1.1 255.255.255.0
no ip mroute-cache
no ip route-cache
!
router ospf 64
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
no synchronization
neighbor 193.1.1.2 remote-as 200
neighbor 193.1.1.2 route-reflector-client
neighbor 194.1.1.2 remote-as 200
neighbor 194.1.1.2 route-reflector-client
!
no ip classless
logging buffered
!
end
RTR D#sh run
version 12.0
!
hostname RTR D
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
no fair-queue
clockrate 2015232
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
clockrate 2015232
!
interface Serial0/2
ip address 194.1.1.2 255.255.255.0
no ip directed-broadcast
clockrate 503808
!
interface Serial0/3
no ip address
no ip directed-broadcast
shutdown
clockrate 2015232
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 64
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 200
no synchronization
neighbor 194.1.1.1 remote-as 200
!
ip nat translation timeout neverno ip classless
!
snmp-server community public RO
snmp-server community private RW
!
line con 0
!
end
----- Original Message -----
From: Sanjay Bhakta <sbhakta@charter.net>
To: <Lachlan_Kidd@data3.com.au>; Ola Aiyegbusi <ola@compath.com>
Cc: <ccielab@groupstudy.com>
Sent: Tuesday, September 05, 2000 9:50 PM
Subject: Re: IBGP, EBGP, AND ROUTE REFLECTORS
> Along with this, rtr A must know how to get back to the router sourcing
the
> pings. In your example, router b,c,d may know about network 1.1.1.0,
> however router a does not know about any of the interfaces on c & d. You
> can ping from rtr b, because rtr b is directly connected to rtr a, and so
> the ping source will be the interface between a & b on rtr b.
>
> In order to test this, you should also create another loopback and
advertize
> it from AS200. For example, create a loopback interface on rtr d, lo0
> 4.4.4.4 and advertize this. Now do an extended ping from rtr d using
> 4.4.4.4 as source.
>
> And remember what Lachlan said, if there is no IGP in the AS200, you
should
> use next-hop-self.
>
> ********
> Sanjay Bhakta (RTP 9/24)
>
>
> ----- Original Message -----
> From: <Lachlan_Kidd@data3.com.au>
> To: "Ola Aiyegbusi" <ola@compath.com>
> Cc: <ccielab@groupstudy.com>
> Sent: Wednesday, September 06, 2000 7:55 PM
> Subject: Re: IBGP, EBGP, AND ROUTE REFLECTORS
>
>
> >
> > Hi Ola,
> > I would suggest that you need a next-hop-self on rtB. This will
make
> > the source of the 1.1.1.0 update appear to be rtrB for C and D. I think
> the
> > problem lies in the reachability of the update coming from rtrA. Rember
> > that with IBGP, the source of the update does not change so C and D will
> be
> > seeing the update as coming from RtrA's serial port. C and D may not
have
> a
> > route to that network and hence the old rule of 'do not advertise what
you
> > do not know how to reach' applies. No synch only helps with IBGP. You
> could
> > try advertising the A-B network with an IGP and see if that fixes the
> > problem.
> > I may have this completely wrong so feel free to correct me <grin>.
> > Regards,
> > Lachlan.
> >
> >
> >
> > "Ola
> > Aiyegbusi" To:
<ccielab@groupstudy.com>
>
> > <ola@compath. cc:
> > com> Subject: IBGP, EBGP, AND
> ROUTE REFLECTORS
> > Sent by:
> > nobody@groups
> > tudy.com
> >
> >
> > 05/09/00
> > 05:06 PM
> > Please
> > respond to
> > "Ola
> > Aiyegbusi"
> >
> >
> >
> >
> >
> > I have a problem.
> >
> > I can't ping an external bgp router (AS100) from another AS (AS200) that
> > has a route reflector configured with no sync configured on all ibgp
> > speakers in the AS (AS200)
> >
> > a) rtr A (AS100) and rtr B (AS200) are external neighbors connected via
> > serial. They can ping each other.
> > b) rtr A is advertising it's loopback address via BGP (1.1.1.1/24)
> > c) rtr B can ping rtr A's loopback address
> > d) In AS200, rtr B is connected to rtr C. rtr C is connected to rtr D
e.g.
> > (rtrB)--------(rtrC)--------(rtrD)
> > e) All 3 routers above are in AS 200. rtr B is neighbored with rtrA
> > (external) and rtrC (internal). rtrC is neighbored with B and D (both
> > internal. rtr D is neighbored with C (internal)
> > f) In AS200, rtr C is configured as the route reflector with B and D as
> > clients
> > g) The IGP running in AS 200 is OSPF
> > h) Synchronization has been disabled in all AS 200 IBGP speakers
> > g) Network 1.0.0.0 (see bullet b above) shows up in the bgp table and
> > routing table of all IBGP speakers in AS 200
> >
> > Problem is: I can't ping 1.1.1.1 from rtr C or D, but I can ping it from
> > rtr B. HELP!!!!!!!
> >
> > Ola Aiyegbusi
> > ComPath Inc.
> > 10201 Lee Hwy Suite 140 Fairfax VA 22030
> > Phone: 703-383-9550 Ext. 122
> > Pager: 1-888-857-5620
> > Cell: 703-395-8808
> > Fax: 703-383-1369
> > Email: ola@compath.com
> > Web: http://www.compath.com
> >
> >
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:52 GMT-3