Re: Simple RIP -> OSPF redistribution?

From: Keith Kruepke (lister@xxxxxxxxxxx)
Date: Wed Aug 23 2000 - 12:28:11 GMT-3


   
Ryan,

Marco is right on the money here.

Your network architecture is valid for IP, but not for RIP. You cannot split s
ubnets of a major network by putting another major network between them. RIP i
s a classful protocol by definition. You will not be able to get this to work
with RIPv1 without readdressing. If you have to get this working with the addr
essing as is, use RIPv2.

Keith

----- Original Message -----
From: "Geatti" <geatti@home.com>
To: "Ryan Hoffman" <ryan.hoffman@telus.com>; <ccielab@groupstudy.com>
Sent: Wednesday, August 23, 2000 10:20 AM
Subject: RE: Simple RIP -> OSPF redistribution?

If you look at the routing and major nets for your interfaces you will
notice something.
On R9
You are using 2 different classful nets 192.168.1.0 and 192.168.0.0
You have used fixed length masks which is good, but as the route from R9
Loop0 (192.168.1.128) crosses the classful boundary at your E0 connection it
drops the subnet .128 and becomes a /24 (the classful boundary).
On R11
The route doesn't get put into the routing table as R11 has 192.168.1.0 /25
(loop0)so 192.168.1.0 /24 from R9 is going to overlap that address space.
Thats why when you take the loop 0 down on R11 it starts to work - no more
address overlap.

Possible solution:
Change R9's loop 0 to 192.168.3.128 / 25
You should see this appear as 192.168.3.0 /24 in R11 route table.

Marco

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Ryan Hoffman
Sent: Wednesday, August 23, 2000 7:26 AM
To: 'ccielab@groupstudy.com'
Subject: Simple RIP -> OSPF redistribution?

As anyone else seen the same thing I am? r9 sends 192.168.1.0 to r11. r11
won't put it in it's routing table. If I remove the lo0 on r11
(192.168.1.0/25), r11 then accepts this and puts it in it's routing table as
192.168.1.0/24 as expected. I can then readd the l0 on r11 and both routes
for 192.168.1.x stay in r11's routing table. However, when a clear ip route
is done on r11, the /24 disappears. I've added 'network 192.168.1.0' to
r11's 'router rip' but this didn't help. Is there a trick to fixing this,
or must I ensure that subnets of major networks aren't discontiguous with
RIP?

r9 e0---e1 r11

r9
==
interface Loopback0
 ip address 192.168.1.129 255.255.255.128
!
interface Loopback1
 ip address 192.168.0.129 255.255.255.128
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.128
!
router rip
 network 192.168.0.0
 network 192.168.1.0

r11
===
interface Loopback0
 ip address 192.168.1.1 255.255.255.128
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.128
 media-type 10BaseT
!
interface Ethernet1
 ip address 192.168.0.2 255.255.255.128
 media-type 10BaseT
!
router ospf 1
 redistribute rip subnets
 network 192.168.2.0 0.0.0.127 area 0
!
router rip
 network 192.168.0.0

r11#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     192.168.0.0/25 is subnetted, 2 subnets
C 192.168.0.0 is directly connected, Ethernet1
R 192.168.0.128 [120/1] via 192.168.0.1, 00:00:15, Ethernet1
     192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Loopback0
     192.168.2.0/25 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Ethernet0
r11#debug rip
*Mar 1 16:06:16: RIP: received v1 update from 192.168.0.1 on Ethernet1
*Mar 1 16:06:16: 192.168.0.128 in 1 hops
*Mar 1 16:06:16: 192.168.1.0 in 1 hops



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:29 GMT-3