RE: ipx bridging

From: Kenneth Kriel (kkriel@xxxxxxxxxxxx)
Date: Thu Aug 17 2000 - 07:19:42 GMT-3


   
Just a quick look at your configs, you are telling router 5 to route ipx, so
R1 is expecting to get routed ipx traffic. no ipx configured on R1, and no
ipx network configured on R5 serial interface - so it is not going to do
anything with the ipx traffic.

Else:
You want to bridge the traffic coming from R5 via R1 to R7 - I have not
tried that but cant think why it would not work - but r1 is only bridging
from one interface to where ? you need another bridge-group command on
another interface !

Let me know if I am missing the point but that is what I see.

Ken

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Tom Winters
Sent: Wednesday, August 16, 2000 5:47 PM
To: ccielab@groupstudy.com
Subject: ipx bridging

Having some problems with ipx bridging. The setup is;
R5----R1----R7
Currently doing irb on R5 and bridging on R1, R5 can ip ping
R7. R5 BVI is set to IPX network 2 R7 is also set to IPX
network 2. I have tried having no IPX routing and IPX
routing on R1 w/o success. Any suggestions?

R1 config;

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
no logging console
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host r2 2001 200.200.200.1
!
!
!
interface Loopback0
 ip address 200.200.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 24.131.152.176 255.255.255.0
 ip access-group 5 in
 no ip unreachables
 no ip directed-broadcast
 no ip proxy-arp
 no cdp enable
!
interface Serial0
 ip address 137.20.2.2 255.255.255.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 cisco
 no ip mroute-cache
 no fair-queue
 clockrate 1000000
 bridge-group 1
!
interface Serial1
 ip address 137.20.3.1 255.255.255.0
 no ip directed-broadcast
 bridge-group 1
!
router ospf 1
 area 2 authentication message-digest
 summary-address 160.0.0.0 224.0.0.0
 redistribute connected subnets tag 3 route-map ospf
 redistribute bgp 2 subnets tag 1 route-map redis
 network 137.20.2.0 0.0.0.255 area 2
 network 200.200.200.0 0.0.0.255 area 2
!
router bgp 2
 no synchronization
 network 137.20.2.0 mask 255.255.255.0
 network 200.200.200.0
 neighbor 137.20.1.2 remote-as 2
 neighbor 137.20.1.2 route-reflector-client
 neighbor 137.20.3.2 remote-as 3
 neighbor 137.20.3.2 update-source Loopback0
 neighbor 137.20.3.2 default-originate
 neighbor 137.20.17.2 remote-as 2
 neighbor 137.20.17.2 route-reflector-client
 no auto-summary
!
ip classless
ip route 24.0.0.0 255.0.0.0 24.131.152.1
ip route 137.20.40.0 255.255.255.0 Serial0
!
access-list 1 permit 137.20.3.0 0.0.0.255
access-list 1 permit 172.168.70.0 0.0.0.255
access-list 1 permit 160.0.0.0 31.255.255.255
access-list 2 permit 137.20.3.0 0.0.0.255
access-list 3 permit 137.20.17.0 0.0.0.255
access-list 4 permit 137.20.17.3
access-list 4 permit 137.20.40.17
access-list 5 permit 24.131.128.0 0.0.0.255
route-map ospf permit 10
 match ip address 2
!
route-map redis permit 10
 match ip address 1
 set metric-type type-1
!
!
snmp-server community secret RW 4
snmp-server community public RO 3
snmp-server trap-source Ethernet0
snmp-server enable traps config
snmp-server host 137.20.40.17 traps secret
bridge 1 protocol ieee
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 exec-timeout 0 0
 transport preferred telnet
 transport input telnet
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 no login
!
end

R5 config;

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
ip host r6 2001 137.20.9.1
ipx routing 0000.0000.0005
ipx internal-network F5
isdn switch-type basic-ni1
!
!
interface Loopback0
 ip address 137.20.9.1 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clockrate 1000000
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
 ip address 137.20.1.1 255.255.255.224
 ip ospf priority 100
 frame-relay map ip 137.20.1.2 502 broadcast
 frame-relay interface-dlci 502
!
interface Serial0.2 multipoint
 ip address 137.20.100.1 255.255.255.240
 frame-relay map ip 137.20.100.2 504 broadcast
 frame-relay interface-dlci 504
!
interface Serial1
 ip unnumbered BVI1
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 100
!
interface TokenRing0
 no ip address
 shutdown
!
interface BRI0
 ip address 137.20.17.1 255.255.240.0
 dialer map ip 137.20.17.2 name r6 broadcast 8358662
 dialer-group 1
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
!
interface BVI1
 ip address 137.20.2.1 255.255.255.0
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 100
 ipx network 2
!
router ospf 1
 summary-address 137.20.2.0 255.255.255.0
 redistribute igrp 1 metric 100 metric-type 1 subnets
 network 137.20.1.0 0.0.0.31 area 1
 network 137.20.2.0 0.0.0.255 area 2
 network 137.20.16.0 0.0.15.255 area 0
 neighbor 137.20.1.2 priority 1
 area 1 virtual-link 200.200.100.1
 area 2 authentication message-digest
 area 2 range 137.20.2.0 255.255.255.0
!
router igrp 1
 redistribute ospf 1 match internal external 1 external 2
nssa-external 1 nssa-external 2
 passive-interface BRI0
 network 137.20.0.0
 neighbor 137.20.100.2
 no default-information out
 default-metric 1544 0 255 1 1500
!
ip classless
!
no logging console
access-list 100 permit ospf any any
access-list 100 permit tcp any eq bgp any gt 1024
access-list 100 permit icmp any any
access-list 100 permit tcp host 137.20.3.2 gt 1024 host
137.20.10.1 eq telnet
access-list 100 permit tcp host 137.20.3.2 gt 1024 host
172.168.80.1 eq telnet
access-list 100 permit tcp host 137.20.2.2 eq telnet host
137.20.2.1 gt 1024
access-list 100 deny ip any any log
dialer-list 1 protocol ip permit
!
!
!
tftp-server flash /c2500-ds-l.113-11a.bin
bridge irb
bridge 1 protocol ieee
 bridge 1 route ipx
!
line con 0
 exec-timeout 0 0
line aux 0
 exec-timeout 0 0
 transport preferred telnet
 transport input telnet
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 no login
!
end

Thanks,

Tom Winters



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:27 GMT-3