basic BGP question

From: Harbir Kohli (harbirk@xxxxxxxxxxxx)
Date: Sat Aug 12 2000 - 21:35:39 GMT-3


   
I have 2 routers connected back-to-back and Router F is in AS 3 and the
other Router D is in AS 2. The router in AS 2 has a network command, but
on Router F I see nothing in the show ip bgp or in the ip route command.

What am I not understanding ?

***********RTF********************
version 11.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname RTF
!
!
ip subnet-zero
no ip domain-lookup
clock timezone est -5
clock summer-time edt recurring
!
interface Ethernet0
 ip address 172.16.65.1 255.255.255.192
 media-type 10BaseT
!
interface Serial0
 no ip address
 clockrate 2000000
!
interface Serial1
 no ip address
 clockrate 2000000
!
interface Serial2
 no ip address
 clockrate 2000000
!
interface Serial3
 ip address 172.16.1.1 255.255.255.0
 clockrate 2000000
!
interface Serial4
 ip address 172.16.30.2 255.255.255.0
 clockrate 2000000
!
interface Serial5
 ip address 172.16.10.1 255.255.255.0
 clockrate 2000000
!
interface Serial6
 no ip address
 clockrate 2000000
!
interface Serial7
 no ip address
 clockrate 2000000
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 3
 neighbor 172.16.1.2 remote-as 3
 neighbor 172.16.30.1 remote-as 2
!
ip classless
!
!
line con 0
 exec-timeout 0 0
line aux 0
 login
 modem InOut
line vty 0 4
 exec-timeout 60 0
 login
!
end

****************RTD********************
RTD#sh run
Building configuration...

Current configuration:
!
version 11.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname RTD
!
!
ip subnet-zero
no ip domain-lookup
clock timezone est -5
clock summer-time edt recurring
!
interface Serial0
 ip address 172.16.30.1 255.255.255.0
!
interface Serial1
 no ip address
 clockrate 2000000
!
interface TokenRing0
 ip address 192.68.10.1 255.255.255.0
 ring-speed 16
!
interface BRI0
 no ip address
 shutdown
!
router bgp 2
 network 192.168.10.0
 neighbor 172.16.30.2 remote-as 3
!
ip classless
!
!
line con 0
 exec-timeout 0 0
line aux 0
 login
 modem InOut
line vty 0 4
 exec-timeout 60 0
 login
!
end
***********************************
RTD#sh ip bgp ne
BGP neighbor is 172.16.30.2, remote AS 3, external link
 Index 1, Offset 0, Mask 0x2
  BGP version 4, remote router ID 172.16.65.1
  BGP state = Established, table version = 2, up for 00:08:03
  Last read 00:00:03, hold time is 180, keepalive interval is 60 seconds

  Minimum time between advertisement runs is 30 seconds
  Received 38 messages, 0 notifications, 0 in queue
  Sent 38 messages, 0 notifications, 0 in queue
  Connections established 2; dropped 1
  Last reset 00:08:31, due to : Peer closing down the session
  No. of prefix received 0
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 172.16.30.1, Local port: 179
Foreign host: 172.16.30.2, Foreign port: 11004

Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x383930):
Timer Starts Wakeups Next
Retrans 12 0 0x0
TimeWait 0 0 0x0
AckHold 11 1 0x0
SendWnd 0 0 0x0
KeepAlive 0 0 0x0
GiveUp 0 0 0x0
PmtuAger 0 0 0x0
DeadWait 0 0 0x0

iss: 1664764440 snduna: 1664764660 sndnxt: 1664764660 sndwnd:
16165
irs: 1612753053 rcvnxt: 1612753273 rcvwnd: 16165 delrcvwnd:
219

SRTT: 446 ms, RTTO: 2812 ms, RTV: 960 ms, KRTT: 0 ms
minRTT: 4 ms, maxRTT: 388 ms, ACK hold: 300 ms
Flags: passive open, nagle, gen tcbs

Datagrams (max data segment is 1460 bytes):
Rcvd: 21 (out of order: 0), with data: 11, total data bytes: 219
Sent: 13 (retransmit: 0), with data: 11, total data bytes: 219
RTD
******************



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:24 GMT-3