From: Keith Kruepke (lister@xxxxxxxxxxx)
Date: Thu Aug 10 2000 - 01:15:33 GMT-3
Scott,
I think this line from your routing table may be part of the problem:
B 4.4.4.0/24 [20/0] via 4.4.4.4, 00:00:36
The route to 4.4.4.0/24 goes through 4.4.4.4--that doesn't seem right to me.
I'm guessing that 4.4.4.0 is initially learned via RIP, so that you can get to
4.4.4.4 and start an EBGP session. Then the EBGP neighbor advertises 4.4.4.0 t
o router2, and that route would take precedence in the IP routing table (AD of
20 is much better than RIP). Then the RIP route is gone, so connectivity is lo
st, and the EBGP route disappears. Then the RIP route returns, and connectivit
y is reestablished, and the cycle continues.
Based on the description, this is my theory, but maybe someone has another idea
? I think this is part of the reason you would normally want to use the direct
ly connected interface IPs as the neighbor addresses for EBGP under most circum
stances. If you still want to use the loopbacks, I would put in static routes
to those networks, rather than using RIP.
Keith
----- Original Message -----
From: "Scott" <trig@usa.net>
To: <ccielab@groupstudy.com>
Sent: Wednesday, August 09, 2000 9:49 PM
Subject: BGP routing loop?
Hello
I was trying to connect two AS with a EBGP multihop command between two
loopbacks and it looks like I am getting a some type of routing loop. The BGP
routes are put in the routing table and removed every 60 seconds (see
attached). I have IP connectivity via RIP and the connection is showing as
established. Any suggestions? Thanks
Scotty
router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
138.6.0.0/24 is subnetted, 2 subnets
B 138.6.5.0 [200/0] via 172.16.35.5, 00:09:52
B 138.6.1.0 [200/0] via 172.16.35.5, 00:09:52
4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 4.4.4.0/24 [20/0] via 4.4.4.4, 00:00:36
R 4.0.0.0/8 [120/11] via 172.16.24.4, 00:00:27, Serial1
172.16.0.0/24 is subnetted, 5 subnets
O IA 172.16.35.0 [110/74] via 172.16.23.3, 00:10:44, Ethernet0
C 172.16.24.0 is directly connected, Serial1
C 172.16.23.0 is directly connected, Ethernet0
C 172.16.12.0 is directly connected, Serial0
C 172.16.2.0 is directly connected, Loopback0
router2#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
router2#
05:08:12: BGP: no valid path for 4.4.4.0/24
05:08:12: BGP: nettable_walker 4.4.4.0/24 no best path
05:08:12: BGP: 4.4.4.4 computing updates, neighbor version 15, table version
16,
starting at 0.0.0.0
05:08:12: BGP: 4.4.4.4 update run completed, ran for 0ms, neighbor version 15,
s
tart version 16, throttled to 16, check point net 0.0.0.0
05:08:12: BGP: 172.16.23.1 computing updates, neighbor version 15, table
version
16, starting at 0.0.0.0
05:08:12: BGP: 172.16.23.1 send UPDATE 4.4.4.0/24 -- unreachable
05:08:12: BGP: 172.16.23.1 1 updates enqueued (average=27, maximum=27)
05:08:12: BGP: 172.16.23.1 update run completed, ran for 8ms, neighbor version
1
5, start version 16, throttled to 16, check point net 0.0.0.0
05:08:12: BGP: 172.16.23.3 computing updates, neighbor version 15, table
version
!
interface Loopback0
ip address 172.16.2.2 255.255.255.0
no ip directed-broadcast
!
!
interface Serial1
ip address 172.16.24.2 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 3
network 172.16.23.0 0.0.0.255 area 3
!
router rip
version 2
network 172.16.0.0
default-information originate
!
router bgp 3
no synchronization
network 172.16.2.0 mask 255.255.255.0
neighbor 4.4.4.4 remote-as 4
neighbor 4.4.4.4 ebgp-multihop 5
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 distribute-list 2 out
neighbor 172.16.23.1 remote-as 3
neighbor 172.16.23.3 remote-as 3
!
Router 1
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
ip address 215.6.10.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback2
ip address 215.6.11.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback5
no ip address
no ip directed-broadcast
!
interface Ethernet0
no ip address
no ip directed-broadcast
appletalk cable-range 600-600 600.5
appletalk zone biteme
appletalk protocol eigrp
bridge-group 1
!
interface Serial0
ip address 172.16.24.4 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
ip address 172.16.10.10 255.255.255.252
no ip directed-broadcast
bridge-group 1
!
interface BRI0
no ip address
no ip directed-broadcast
shutdown
!
router rip
version 2
offset-list 1 out 10
network 4.0.0.0
network 172.16.0.0
!
router bgp 4
no synchronization
network 4.4.4.0 mask 255.255.255.0
neighbor 172.16.2.2 remote-as 3
neighbor 172.16.2.2 ebgp-multihop 5
neighbor 172.16.2.2 update-source Loopback0
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:23 GMT-3