OSPF virtual-link issue

From: Derek Buelna (dameon@xxxxxxxxxxx)
Date: Tue Aug 08 2000 - 01:34:03 GMT-3


   
Hi,

I was playing with cciebootcamp lab 1 and noticed that the OSPF area virtual-li
nk through area 3 provided router 4 with routes from area 0 but the routes in a
rea 44 didn't get back into the area 0 routers. It appeared as if r3 and r4 whe
re happy neighbors.

Your thoughts/feedback would be greatly appreciated.

Here are router 3 and router 4's configs ++.

Thanks,

-Derek

Derek Buelna, CCNP CCDP MCSE
Network Engineer
Firstworld Communications

r3#sh run
Building configuration...

Current configuration:
!
version 11.1
service slave-log
service timestamps debug datetime msec
service timestamps log datetime msec
service udp-small-servers
service tcp-small-servers
!
hostname r3
!
!
ip subnet-zero
!
interface Serial0
 ip address 10.10.1.3 255.255.0.0
 encapsulation frame-relay
 no fair-queue
 clockrate 2000000
 frame-relay map ip 10.10.1.1 301 broadcast
!
interface Serial1
 ip address 10.34.1.1 255.255.0.0
 clockrate 2000000
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 100
 network 10.10.1.0 0.0.0.255 area 0
 network 10.34.0.0 0.0.255.255 area 3
 neighbor 10.10.10.1 priority 200 poll-interval 180
 area 3 virtual-link 10.34.1.2
!
ip local policy route-map 10
ip classless
logging buffered
access-list 101 permit ip any 137.20.20.0 0.0.0.255
access-list 101 permit ip any host 10.10.1.2
access-list 101 permit ip any 11.0.0.0 0.255.255.255
access-list 101 permit ip any host 10.10.1.5
route-map 10 permit 10
 match ip address 101
 set ip next-hop 10.10.1.1
!
!
alias exec ipr show ip route
alias exec ipi show ip int brief
alias exec xpr show ipx route
alias exec apr show apple route
alias exec xpi show apple int brief
alias exec sd show dialer
alias exec s sho sess
alias exec ci clear ip route *
alias exec cb clear ip bgp *
alias exec sr show run
alias exec sbn show ip bgp nei
alias exec sb show ip bgp
alias exec son show ospf nei
alias exec cr copy run start
alias exec ct conf t
alias exec sio sh ip ospf nei
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

r3# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route

Gateway of last resort is not set

     10.0.0.0/8 is subnetted, 3 subnets
C 10.10.0.0 is directly connected, Serial0
O IA 10.1.0.0 [110/74] via 10.10.1.1, 00:19:05, Serial0
C 10.34.0.0 is directly connected, Serial1
     11.0.0.0/8 is subnetted, 1 subnets
O IA 11.1.0.0 [110/74] via 10.10.1.5, 00:19:05, Serial0
     137.20.0.0/16 is subnetted, 1 subnets
O IA 137.20.20.0 [110/74] via 10.10.1.2, 00:19:05, Serial0

r3# sh ip ospf int
Serial0 is up, line protocol is up
  Internet Address 10.10.1.3/16, Area 0
  Process ID 100, Router ID 10.34.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 10.10.1.1, Interface address 10.10.1.1
  Backup Designated router (ID) 10.34.1.1, Interface address 10.10.1.3
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:23
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.10.1.1 (Designated Router)
Serial1 is up, line protocol is up
  Internet Address 10.34.1.1/16, Area 3
  Process ID 100, Router ID 10.34.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.44.2.1
TokenRing0 is administratively down, line protocol is down
   OSPF not enabled on this interface
r4# sh run
Building configuration...

Current configuration:
!
version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r4
!
!
ip subnet-zero
!
interface Loopback0
 ip address 10.44.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.44.2.1 255.255.255.0
!
interface Ethernet0
 no ip address
 no keepalive
!
interface Serial0
 ip address 10.34.1.2 255.255.0.0
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 100
 network 10.34.0.0 0.0.255.255 area 3
 network 10.44.1.0 0.0.0.255 area 44
 network 10.44.2.0 0.0.0.255 area 44
 area 3 virtual-link 10.34.1.1
 area 44 range 10.44.0.0 255.255.0.0
!
ip classless
alias exec ipr show ip route
alias exec ipi show ip int brief
alias exec xpr show ipx route
alias exec apr show apple route
alias exec xpi show apple int brief
alias exec sd show dialer
alias exec s sho sess
alias exec ci clear ip route *
alias exec cb clear ip bgp *
alias exec sr show run
alias exec sbn show ip bgp nei
alias exec sb show ip bgp
alias exec son show ospf nei
alias exec cr copy run start
alias exec ct conf t
alias exec sio sh ip ospf nei
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

r4# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA 10.10.0.0/16 [110/128] via 10.34.1.1, 00:16:30, Serial0
O IA 10.1.0.0/16 [110/138] via 10.34.1.1, 00:16:30, Serial0
C 10.44.2.0/24 is directly connected, Loopback1
C 10.44.1.0/24 is directly connected, Loopback0
C 10.34.0.0/16 is directly connected, Serial0
     11.0.0.0/16 is subnetted, 1 subnets
O IA 11.1.0.0 [110/138] via 10.34.1.1, 00:16:20, Serial0
     137.20.0.0/24 is subnetted, 1 subnets
O IA 137.20.20.0 [110/138] via 10.34.1.1, 00:16:30, Serial0

r4# sh ip ospf int
Ethernet0 is up, line protocol is up
   OSPF not enabled on this interface
Loopback0 is up, line protocol is up
  Internet Address 10.44.1.1/24, Area 44
  Process ID 100, Router ID 10.44.2.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Loopback1 is up, line protocol is up
  Internet Address 10.44.2.1/24, Area 44
  Process ID 100, Router ID 10.44.2.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Serial0 is up, line protocol is up
  Internet Address 10.34.1.2/16, Area 3
  Process ID 100, Router ID 10.44.2.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.34.1.1
  Suppress hello for 0 neighbor(s)
Serial1 is administratively down, line protocol is down
   OSPF not enabled on this interface
Serial2 is administratively down, line protocol is down
   OSPF not enabled on this interface
Serial3 is administratively down, line protocol is down
   OSPF not enabled on this interface
TokenRing0 is administratively down, line protocol is down
   OSPF not enabled on this interface



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:24:22 GMT-3