Re: Eigrp split horizon

From: John Conzone (jkconzone@xxxxxxxx)
Date: Tue Jul 18 2000 - 15:18:09 GMT-3


   
Here all I've added was the "no ip split-horizon eigrp 1" command to S0 on
r1, and the routes of the respective spokes no appera on each other.

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password cisco
!
username all
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 10.1.1.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 no ip mroute-cache
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 network 1.0.0.0
 network 10.0.0.0
!
ip classless
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
end

r1#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 1.0.0.0/8 is a summary, 00:11:25, Null0
C 1.1.1.0/24 is directly connected, Loopback0
D 2.0.0.0/8 [90/2297856] via 10.1.1.2, 00:00:31, Serial0
D 3.0.0.0/8 [90/2297856] via 10.1.1.3, 00:00:31, Serial0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:11:25, Null0
C 10.1.1.0/24 is directly connected, Serial0
r1#sho ip eigrp ne
r1#sho ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
                                        (sec) (ms) Cnt Num
1 10.1.1.3 Se0 145 00:00:39 52 312 0 14
0 10.1.1.2 Se0 147 00:00:51 52 312 0 14
r1#sho ipeigrp to
r1#sho ip eigrp top
r1#sho ip eigrp topology
IP-EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 1.0.0.0/8, 1 successors, FD is 128256
         via Summary (128256/0), Null0
P 1.1.1.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 2.0.0.0/8, 1 successors, FD is 2297856
         via 10.1.1.2 (2297856/128256), Serial0
P 3.0.0.0/8, 1 successors, FD is 2297856
         via 10.1.1.3 (2297856/128256), Serial0
P 10.0.0.0/8, 1 successors, FD is 2169856
         via Summary (2169856/0), Null0
P 10.1.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
r1#
******************************************************

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 2.1.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 10.1.1.2 255.255.255.0
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay map ip 10.1.1.3 201 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 network 2.0.0.0
 network 10.0.0.0
!
ip classless
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
end

r2#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR

Gateway of last resort is not set

D 1.0.0.0/8 [90/2297856] via 10.1.1.1, 00:01:25, Serial0
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 2.0.0.0/8 is a summary, 00:01:25, Null0
C 2.1.1.0/24 is directly connected, Loopback0
D 3.0.0.0/8 [90/2809856] via 10.1.1.1, 00:01:25, Serial0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:24:50, Null0
C 10.1.1.0/24 is directly connected, Serial0
r2#sho ip eigrp ne
r2#sho ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
                                        (sec) (ms) Cnt Num
0 10.1.1.1 Se0 136 00:01:40 46 276 0 19
r2#sho ip eigrp to
r2#sho ip eigrp topology
IP-EIGRP Topology Table for process 1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 1.0.0.0/8, 1 successors, FD is 2297856
         via 10.1.1.1 (2297856/128256), Serial0
P 2.0.0.0/8, 1 successors, FD is 128256
         via Summary (128256/0), Null0
P 2.1.1.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 3.0.0.0/8, 1 successors, FD is 2809856
         via 10.1.1.1 (2809856/2297856), Serial0
P 10.0.0.0/8, 1 successors, FD is 2169856
         via Summary (2169856/0), Null0
P 10.1.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
r2#
******************************************************
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
enable password cisco
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
key chain ccie
 key 1
  key-string ccie
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 3.1.1.1 255.255.255.0
!
interface Ethernet0
 ip address 11.1.1.3 255.255.255.0
!
interface Serial0
 ip address 10.1.1.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.1.1.2 301 broadcast
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router eigrp 1
 network 3.0.0.0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
access-list 1 deny 4.0.0.0
access-list 1 permit any
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
end

r3#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D 1.0.0.0/8 [90/2297856] via 10.1.1.1, 00:02:23, Serial0
D 2.0.0.0/8 [90/2809856] via 10.1.1.1, 00:02:23, Serial0
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 3.0.0.0/8 is a summary, 00:02:23, Null0
C 3.1.1.0/24 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0
     11.0.0.0/24 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, Ethernet0
r3#sho ip eigrp nei
r3#sho ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
Type
                                        (sec) (ms) Cnt Num
0 10.1.1.1 Se0 141 00:02:33 49 294 0 19
r3#sho ip eigrp top
r3#sho ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(3.1.1.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - Reply status

P 1.0.0.0/8, 1 successors, FD is 2297856
         via 10.1.1.1 (2297856/128256), Serial0
P 2.0.0.0/8, 1 successors, FD is 2809856
         via 10.1.1.1 (2809856/2297856), Serial0
P 3.0.0.0/8, 1 successors, FD is 128256
         via Summary (128256/0), Null0
P 3.1.1.0/24, 1 successors, FD is 128256
         via Connected, Loopback0
P 10.1.1.0/24, 1 successors, FD is 2169856
         via Connected, Serial0
r3#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:54 GMT-3