From: Jason T. Rohm (jtrohm@xxxxxxxxxxx)
Date: Fri May 05 2000 - 02:32:07 GMT-3
I am having trouble getting an async dial-up working between routers in my
lab...
The symptoms:
The router will initiate the dial, connect, and pass through the
authentication. The debug shows that the LCP setup of IP completes.
However, I am unable to pass any data across the line and the line will
take itself down at what appears to be a random interval, usually less than
1 minute later.
I am tired and stumped... can anyone assist?
Config:
2511A has a Hayes Optima v.34 attached to line 8, the modem is manually
configured.
2511A is running IOS 12.0.7
2501A has a Hayes Optima v.34 attached to the AUX port, this modem is also
manually configured.
2501A is running IOS 11.0.22 IP Only
I am forcing the dial by pinging the 2501 from the 2511.
2511A Config:
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2511A
!
enable password ********* (Removed to protect the innocent)
!
username pppuser password 0 ppppassword
username 2501A password 0 ppppassword
username 2511A password 0 ppppassword
ip subnet-zero
no ip domain-lookup
ip host 3000A 2001 10.0.251.1
ip host 3000B 2002 10.0.251.1
ip host 2513A 2007 10.0.251.1
ip host 300C 2003 10.0.251.1
ip host 4000M 2004 10.0.251.1
chat-script Hayes-Optima ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30
CONNECT \c
chat-script Dial "" "ATZ" OK "ATDT \T" TIMEOUT 30 CONNECT \c
!
!
!
interface Loopback0
ip address 10.254.254.1 255.255.255.252
no ip directed-broadcast
!
interface Ethernet0
ip address 10.0.10.254 255.255.255.0 secondary
ip address 10.0.10.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Async8
ip address 10.1.40.6 255.255.255.252
ip directed-broadcast
encapsulation ppp
keepalive 10
dialer in-band
dialer map ip 10.1.40.5 modem-script Dial 5556962
dialer-group 1
async mode dedicated
peer default ip address 10.1.40.5
no cdp enable
ppp authentication chap
!
router eigrp 10
redistribute static
network 10.0.0.0
network 0.0.0.0
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.10.128
!
dialer-list 1 protocol ip permit
! line con 0
exec-timeout 0 0
transport input none
line 1 7
no exec
transport input all
line 8
no exec
modem InOut
transport preferred none
transport output none
stopbits 1
speed 38400
flowcontrol hardware
line 9 16
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
login
!
end
2501A Config:
Current configuration:
!
version 11.0
service udp-small-servers
service tcp-small-servers
!
hostname 2501A
!
enable secret **************
!
username pppuser password 7 08315C5E1918160405041E006A
username 2511A password 7 1407021B1C05393833272131
username 2501A password 7 105E1909151601181B0B382F
no ip domain-lookup
chat-script Dial "" "ATZ" "OK" "ATDT \T" TIMEOUT 30 "CONNECT" \c
!
interface Loopback0
ip address 10.254.254.13 255.255.255.252
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 10.1.40.5 255.255.255.252
encapsulation ppp
async mode dedicated
no peer default ip address pool
dialer in-band
dialer map ip 10.1.40.6 modem-script Dial 5550575
dialer-group 1
ppp authentication chap
!
router eigrp 10
network 10.0.0.0
!
ip route 0.0.0.0 0.0.0.0 10.1.40.6 250
logging buffered
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
no exec
modem InOut
transport preferred none
transport input none
transport output none
stopbits 1
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
password *****
login
!
end
2511A Debug: (debug ppp neg, debug ppp error)
6w2d: As8 IPCP: Install route to 10.1.40.5
6w2d: %LINK-3-UPDOWN: Interface Async8, changed state to up
6w2d: As8 PPP: Treating connection as a callout
6w2d: As8 PPP: Phase is ESTABLISHING, Active Open
6w2d: As8 LCP: O CONFREQ [Closed] id 233 len 25
6w2d: As8 LCP: ACCM 0x000A0000 (0x0206000A0000)
6w2d: As8 LCP: AuthProto CHAP (0x0305C22305)
6w2d: As8 LCP: MagicNumber 0x432EBB94 (0x0506432EBB94)
6w2d: As8 LCP: PFC (0x0702)
6w2d: As8 LCP: ACFC (0x0802)
6w2d: As8 LCP: TIMEout: State REQsent
6w2d: As8 LCP: O CONFREQ [REQsent] id 234 len 25
6w2d: As8 LCP: ACCM 0x000A0000 (0x0206000A0000)
6w2d: As8 LCP: AuthProto CHAP (0x0305C22305)
6w2d: As8 LCP: MagicNumber 0x432EBB94 (0x0506432EBB94)
6w2d: As8 LCP: PFC (0x0702)
6w2d: As8 LCP: ACFC (0x0802)
6w2d: As8 LCP: I CONFREQ [REQsent] id 103 len 25
6w2d: As8 LCP: ACCM 0x000A0000 (0x0206000A0000)
6w2d: As8 LCP: AuthProto CHAP (0x0305C22305)
6w2d: As8 LCP: MagicNumber 0x010E6CF2 (0x0506010E6CF2)
6w2d: As8 LCP: PFC (0x0702)
6w2d: As8 LCP: ACFC (0x0802)
6w2d: As8 LCP: O CONFACK [REQsent] id 103 len 25
6w2d: As8 LCP: ACCM 0x000A0000 (0x0206000A0000)
6w2d: As8 LCP: AuthProto CHAP (0x0305C22305)
6w2d: As8 LCP: MagicNumber 0x010E6CF2 (0x0506010E6CF2)
6w2d: As8 LCP: PFC (0x0702)
6w2d: As8 LCP: ACFC (0x0802)
6w2d: As8 LCP: I CONFACK [ACKsent] id 234 len 25
6w2d: As8 LCP: ACCM 0x000A0000 (0x0206000A0000)
6w2d: As8 LCP: AuthProto CHAP (0x0305C22305)
6w2d: As8 LCP: MagicNumber 0x432EBB94 (0x0506432EBB94)
6w2d: As8 LCP: PFC (0x0702)
6w2d: As8 LCP: ACFC (0x0802)
6w2d: As8 LCP: State is Open
6w2d: As8 PPP: Phase is AUTHENTICATING, by both
6w2d: As8 CHAP: O CHALLENGE id 23 len 26 from "2511A"
6w2d: As8 CHAP: I CHALLENGE id 1 len 26 from "2501A"
6w2d: As8 CHAP: O RESPONSE id 1 len 26 from "2511A"
6w2d: As8 CHAP: I SUCCESS id 1 len 4
6w2d: As8 CHAP: I RESPONSE id 23 len 26 from "2501A"
6w2d: As8 CHAP: O SUCCESS id 23 len 4
6w2d: As8 PPP: Phase is UP
6w2d: As8 IPCP: O CONFREQ [Closed] id 17 len 10
6w2d: As8 IPCP: Address 10.1.40.6 (0x03060A012806)
6w2d: As8 IPCP: I CONFREQ [REQsent] id 17 len 10
6w2d: As8 IPCP: Address 10.1.40.5 (0x03060A012805)
6w2d: As8 IPCP: O CONFACK [REQsent] id 17 len 10
6w2d: As8 IPCP: Address 10.1.40.5 (0x03060A012805)
6w2d: As8 IPCP: I CONFACK [ACKsent] id 17 len 10
6w2d: As8 IPCP: Address 10.1.40.6 (0x03060A012806)
6w2d: As8 IPCP: State is Open
6w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async8, changed state
to up
6w2d: %LINK-5-CHANGED: Interface Async8, changed state to reset
6w2d: As8 IPCP: State is Closed
6w2d: As8 PPP: Phase is TERMINATING
6w2d: As8 LCP: State is Closed
6w2d: As8 PPP: Phase is DOWN
6w2d: As8 IPCP: Remove route to 10.1.40.5
6w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async8, changed state
to down
6w2d: %LINK-3-UPDOWN: Interface Async8, changed state to down
6w2d: As8 LCP: State is Closed
6w2d: As8 PPP: Phase is DOWN
2501A Debug: (debug ppp neg, debug ppp error)
PPP Async1: dropping packet. Lower layer not up
%LINK-3-UPDOWN: Interface Async1, changed state to up
PPP Async1: treating connection as a callin
ppp: sending CONFREQ, type = 2 (CI_ASYNCMAP), value = 0xA0000
ppp: sending CONFREQ, type = 3 (CI_AUTHTYPE), value = 0xC223/5
ppp: sending CONFREQ, type = 5 (CI_MAGICNUMBER), value = 0x113A1DC
PPP Async1: received config for type = 2 (ASYNCMAP) value = 0xA0000 acked
PPP Async1: received config for type = 3 (AUTHTYPE) value = 0xC223 digest =
5 acked
PPP Async1: received config for type = 5 (MAGICNUMBER) value = 0x4333F002
acked
PPP Async1: received config for type = 7 (PCOMPRESSION) acked
PPP Async1: received config for type = 8 (ACCOMPRESSION) acked
PPP Async1: state = ACKsent fsm_rconfack(0xC021): rcvd id 104
ppp: config ACK received, type = 2 (CI_ASYNCMAP), value = 0xA0000
ppp: config ACK received, type = 3 (CI_AUTHTYPE), value = 0xC223
ppp: config ACK received, type = 5 (CI_MAGICNUMBER), value = 0x113A1DC
ppp: config ACK received, type = 7 (CI_PCOMPRESSION)
ppp: config ACK received, type = 8 (CI_ACCOMPRESSION)
ipcp: sending CONFREQ, type = 3 (CI_ADDRESS), Address = 10.1.40.5
ppp Async1: Negotiate IP address: her address 10.1.40.6 (ACK)
ppp: ipcp_reqci: returning CONFACK.
PPP Async1: state = ACKsent fsm_rconfack(0x8021): rcvd id 18
ipcp: config ACK received, type = 3 (CI_ADDRESS), Address = 10.1.40.5
Async1: install route to 10.1.40.6
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Async1, changed state to
down
%LINK-5-CHANGED: Interface Async1, changed state to reset
Async1: remove route to 10.1.40.6
%LINK-3-UPDOWN: Interface Async1, changed state to down
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:27 GMT-3