OSPF and wild card bits confusion

From: Kinton Connelly (kinton@xxxxxxxxxxxx)
Date: Sat Apr 29 2000 - 19:23:23 GMT-3


   
I've been going through the CCIE Boot Camp practice labs and just ran into
something that has me confused. On lab 8a, I don't understand where they're
getting the wild card bits for the OSPF areas. I've included a bit of
sample code from router 5 below.

Here's what I don't understand: normally, if you give me an interface like
Serial1 below and tell me to put it in OSPF Area 2, I'll take the interface
address:

137.20.25.2/24

and turn it into this OSPF statement:

network 137.20.25.0 0.0.0.255 area 2

But as you can see below, sometimes they do it this way and sometimes they
don't. Why? Why put it in there as "network 137.20.25.2 0.0.0.0 area 2" -
that would be the entry for a /32 network.

Thanks for any help,

Kinton

R5

--
interface Loopback0
  ip address 137.20.240.1 255.255.240.0
!
interface Ethernet0
  ip address 137.20.64.5 255.255.240.0
!
interface Serial0.1 multipoint
  ip address 137.20.100.34 255.255.255.224
!
interface Serial0.2 point-to-point
  ip address 137.20.200.17 255.255.255.240
!
interface Serial1
  ip address 137.20.25.2 255.255.255.0
!
interface BRI0
  ip address 137.20.224.5 255.255.240.0
!
router ospf 1
  network 137.20.25.2 0.0.0.0 area 2
  network 137.20.64.0 0.0.15.255 area 0
  network 137.20.100.32 0.0.0.31 area 1
  network 137.20.224.5 0.0.0.0 area 0
  network 137.20.240.1 0.0.0.0 area 0


This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:16 GMT-3