From: jbazar (jbazar@xxxxxxxx)
Date: Fri Mar 17 2000 - 18:25:18 GMT-3
Ronald
Do a debug ip packet. You will notice that your encapsulation will fai
l
for updates being sent out s0. That is because bridging is being done on
this interface for IP, and packets are going to your BVI to route packets.
When you use standard bridging without IRB, bridging is only done on
non-routable protocols. IRB will bridge all protocols as soon as you turn
it on (including IP).
If you want to continue to use the BVI, you must use that one address f
or
the whole bridge group. In your case, you have 3 IP addresses on the same
LAN. If you would rather use the IP addresses on the physical interfaces,
type "no bridge 1 bridge IP". This will disable the bridging of IP in
bridge group 1. You will not need the BVI in this case.
try it out
jeff
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Ronald Johnson
Sent: Friday, March 17, 2000 1:47 PM
To: 'jbazar'
Cc: ccielab@groupstudy.com
Subject: RE: IRB
Thanks for your responses guys but I'm not sure we have this one nailed yet.
I have heard a couple of different suggestions. One was to enable a BVI
interface (this was already in the config), the second suggestion was to
turn off bridging for IP (if only bridging is enabled, things work fine.. I
only run into problems when I create the BVI interface. Bridging works fine
by itself, so turning off bridging for IP does not make a difference).
Another suggestion was to create the BVI and add a network statement under
the IGRP routing process that included the ip address of the BVI. If you
reference the config you will see that this was already done as well...
So guys.. the jury is still out on this one. What I am not sure about is how
the IGRP updates are sourced once the BVI is created. If I debug the IGRP
updates it shows that updates are sourced not only by the BVI, but the
Serial 0 interface as well. As I mentioned in my previous e-mail.. I am
still receiving updates just fine on Router A. According to router A, I am
still sending them.. However, there is something weird about the creation of
the BVI on Router A that is keeping router B from receiving IGRP updates as
usual.
Router A: IGRP Debug Output
IGRP: received update from 192.168.3.65 on Serial0
subnet 192.168.3.104, metric 1002255 (neighbor 1000255)
subnet 192.168.3.64, metric 1002255 (neighbor 1000255)
subnet 192.168.3.0, metric 8506 (neighbor 6506)
network 1.0.0.0, metric 8506 (neighbor 6506)
network 33.0.0.0, metric 8506 (neighbor 6506)
network 172.16.0.0, metric 8506 (neighbor 6506)
network 22.0.0.0, metric 8506 (neighbor 6506)
network 192.168.5.0, metric 1002255 (neighbor 1000255)
*snip*
IGRP: sending update to 255.255.255.255 via BVI1 (99.99.99.99)
network 5.0.0.0, metric=1100
network 7.0.0.0, metric=6486
network 8.0.0.0, metric=6486
network 9.0.0.0, metric=6486
network 10.0.0.0, metric=2750
network 208.158.193.0, metric=8476
IGRP: Update contains 0 interior, 6 system, and 0 exterior routes.
IGRP: Total routes in update: 6
IGRP: sending update to 255.255.255.255 via Serial0 (192.168.3.66)
subnet 192.168.3.64, metric=8476
network 5.0.0.0, metric=1100
network 7.0.0.0, metric=6486
network 8.0.0.0, metric=6486
network 9.0.0.0, metric=6486
network 10.0.0.0, metric=2750
network 99.0.0.0, metric=1500
network 208.158.193.0, metric=8476
IGRP: Update contains 1 interior, 7 system, and 0 exterior routes.
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
jbazar
Sent: Friday, March 17, 2000 9:52 AM
To: 'Ronald Johnson'; cisco@groupstudy.com
Cc: ccielab@groupstudy.com
Subject: RE: IRB
Ronald
If you want these interfaces to participate in bridging but still allow
routing of IP without a BVI, type this command in global configuration on
both routers.
no bridge 1 bridge ip
You will start seeing routing updates again.
By default, IRB will bridge all protocols. The only way you can bridge and
route a certain protocol is by using a BVI.
Hope this helps
jeff
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Ronald Johnson
Sent: Thursday, March 16, 2000 10:37 PM
To: cisco@groupstudy.com
Cc: ccielab@groupstudy.com
Subject: IRB
Question.. I have two routers running IGRP over a frame link. When I turn on
IRB on router A (Bridging and Routing IPX, Decnet, Appletalk, IP), router B
stops receiving IGRP updates from router A. When I do a "debug ip igrp
events" on Router A it shows I am still receiving updates from router B and
sending updates out Serial 0. However, issuing the debug igrp command on
router B shows router B is sending updates, but is not receiving IGRP
updates from anyone. Even more strange is the fact that I cannot ping either
serial interface from either side when IRB is turned on!
RouterA-S0: <----IGRP----> :S0.1-RouterB
Seems like a simple scenario. However, as soon as I type "bridge irb" on
router A, router B no longer receives IGRP updates from
router A... Am I missing something obvious here? I am hoping for one of
those obvious gotcha answers since I am too tired to figure this out
tonight.. :D (config below)
Thanks.
-Ron
Router A:
!
interface Ethernet0
ip address 5.5.5.5 255.255.255.0
no keepalive
ipx network 4A
bridge-group 1
!
interface Serial0
ip address 192.168.3.66 255.255.255.248
encapsulation frame-relay
decnet cost 1
ipx network 40
cdp enable
frame-relay map ip 192.168.3.65 401 broadcast
no frame-relay inverse-arp
bridge-group 1
!
interface Serial1
ip address 208.158.193.129 255.255.255.248
clockrate 2000000
bridge-group 1
!
interface TokenRing0
ip address 10.1.1.1 255.255.255.0
decnet cost 5
ipx network 4B
ring-speed 4
!
interface BVI1
ip address 99.99.99.99 255.255.255.248
ipx network C30
!
router igrp 50
redistribute bgp 200 metric 1544 10 255 100 1400
passive-interface Ethernet0
passive-interface TokenRing0
network 10.0.0.0
network 192.168.3.0
network 5.0.0.0
network 208.158.193.0
network 99.0.0.0
distribute-list 1 out
!
router bgp 200
no synchronization
redistribute connected
neighbor 192.168.3.106 remote-as 200
neighbor 192.168.3.106 next-hop-self
neighbor 208.158.193.130 remote-as 100
!
ip classless
ip as-path access-list 10 deny _300
ip as-path access-list 10 permit .*
logging buffered 8000 debugging
access-list 1 permit 5.0.0.0
access-list 1 permit 7.0.0.0
access-list 1 permit 8.0.0.0
access-list 1 permit 9.0.0.0
access-list 1 permit 10.0.0.0
access-list 1 permit 192.168.3.20 0.0.0.3
access-list 1 permit 192.168.3.64 0.0.0.7
access-list 1 permit 192.1.24.0 0.0.0.7
access-list 1 permit 208.158.193.0 0.0.0.255
access-list 1 permit 99.0.0.0 0.255.255.255
access-list 2 deny 192.168.3.0 0.0.0.255
access-list 2 permit any
!
!
bridge irb
bridge 1 protocol ieee
bridge 1 route decnet
bridge 1 route ip
bridge 1 route ipx
=============================================
Router B:
interface Ethernet0
ip address 192.168.5.1 255.255.255.0
no ip directed-broadcast
ip ospf message-digest-key 1 md5 cisco
ip ospf interface-retry 0
ipx network 5
!
interface Serial0.1 point-to-point << to router A
ip address 192.168.3.65 255.255.255.248
no ip directed-broadcast
no ip split-horizon
ip ospf network point-to-multipoint
ip ospf interface-retry 0
ip ospf priority 100
decnet cost 1
ipx network 40
no arp frame-relay
frame-relay interface-dlci 104
bridge-group 1
!
interface Serial0.2 multipoint
ip address 192.168.3.105 255.255.255.248
no ip directed-broadcast
no ip split-horizon
ip ospf message-digest-key 1 md5 cisco
ip ospf network point-to-multipoint
ip ospf interface-retry 0
ip ospf priority 100
appletalk cable-range 500-500 500.1
appletalk zone WAN2
decnet cost 4
ipx network 20
frame-relay map bridge 102 broadcast
frame-relay map ipx 20.0000.0c47.5eb7 103 broadcast
frame-relay map decnet 2.3 102 broadcast
frame-relay map ip 192.168.3.106 102 broadcast
frame-relay map ip 192.168.3.107 103 broadcast
frame-relay map ipx 20.0000.0c47.b92b 102 broadcast
frame-relay map appletalk 500.2 102 broadcast
frame-relay map appletalk 500.3 103 broadcast
frame-relay interface-dlci 102
frame-relay interface-dlci 103
no frame-relay inverse-arp
bridge-group 1
router ospf 200
area 0 authentication message-digest
redistribute igrp 50 subnets
network 192.168.3.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
!
router igrp 50
redistribute connected metric 10 255 255 120 1400
redistribute ospf 200 metric 1544 30 255 20 1400
network 192.168.3.0
network 192.168.5.0
!
bridge 1 protocol ieee
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:23:05 GMT-3