From: LESH, MIKE (MIKLES@xxxxxxxxxx)
Date: Fri Feb 04 2000 - 10:46:24 GMT-3
Greetings to all,
Nobody said you would do this in the real world, anyway the lab test
does a lot of things you would not necessarily do in a production network.
My view is that this is just a way to practice some things that otherwise
would not be possible in a limited 'home' lab environment.
Basically the thrust of my previous E-mail was a modification of a
technique found in the book 'Cisco Routers for IP Routing / Little Black
Book', appendix B, by Innokenty Rudenko, CCIE. The author shows a way to
get around the problem of needing more then 2 Frame-Relay ports, but only
having routers with 2 synchronous serial ports. (i.e. the 2500 series.) His
basic method is to connect two apparently 2500 series routers together with
a cross-over cable on the Aux ports , then using that asynchronous
connection as a tunnel connection to carry two Frame-Relay DLCI's which
gives him three synchronous Frame-Relay ports, in a partial mesh
configuration. (By the way, I recommend the book as a good reference, I
learned of it via the ccielab@studygroup.com) The relevant parts of author's
configuration is as follows:
FR1(Aux0) --- X-over cable (Tunnel0) --- (Aux0)FR2
!
hostname FR1
!
frame-relay switching
!
interface Tunnel0
tunnel source 1.0.0.1
tunnel destination 1.0.0.2
!
interface Serial0
clockrate 64000
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Tunnel0 421
!
interface Serial1
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 302 interface Tunnel0 423
!
interface Ethernet0
ip address 169.124.84.34 255.255.255.0
!
interface Async1
ip address 1.0.0.1 255.255.255.0
encapsulation ppp
async default routing
async mode dedicated
ppp authentication chap
!
line aux 0
rxspeed 38400
txspeed 38400
!
and;
!
hostname FR2
!
frame-relay switching
!
interface Tunnel0
tunnel source 1.0.0.2
tunnel destination 1.0.0.1
!
interface Ethernet0
ip address 169.124.84.36 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
bandwidth 64000
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Tunnel0 421
!
interface Async1
ip address 1.0.0.2 255.255.255.0
encapsulation ppp
async default routing
async mode dedicated
ppp authentication chap
!
line aux 0
rxspeed 38400
txspeed 38400
!
My Modification is to use two access servers and using their higer async
port speeds gain some performance, as follows;
Frame01(Async16) --- X-over cable (Tunnel0) --- (Async16)Frame02
!
hostname Frame01
!
frame-relay switching
!
interface Tunnel0
no ip address
bandwidth 115200
tunnel source 181.21.15.1
tunnel destination 181.21.15.2
!
interface Serial0
no ip address
encapsulation frame-relay
bandwidth 57600
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 102 interface Tunnel0 402
frame-relay route 121 interface Serial1 123
!
interface Serial1
no ip address
encapsulation frame-relay
bandwidth 57600
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 120 interface Tunnel0 403
frame-relay route 123 interface Serial0 121
!
interface TokenRing0
ip address 181.21.1.1 255.255.255.0
ring-speed 16
!
interface Async16
ip address 181.21.15.1 255.255.255.0
encapsulation ppp
async default routing
async mode dedicated
ppp authentication chap
!
line 16
transport input all
stopbits 1
speed 115200
!
and;
!
hostname Frame02
!
frame-relay switching
!
interface Loopback0
ip address 181.21.16.1 255.255.255.0
no logging event subif-link-status
!
interface Tunnel0
no ip address
no logging event subif-link-status
bandwidth 115200
tunnel source 181.21.15.2
tunnel destination 181.21.15.1
!
interface Ethernet0
ip address 172.20.70.20 255.255.255.0
no logging event subif-link-status
!
interface Serial0
no ip address
encapsulation frame-relay
no logging event subif-link-status
bandwidth 57600
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 201 interface Tunnel0 402
frame-relay route 210 interface Tunnel0 403
!
interface Async16
ip address 181.21.15.2 255.255.255.0
encapsulation ppp
no logging event subif-link-status
async default routing
async mode dedicated
ppp authentication chap
!
line 16
transport input all
stopbits 1
speed 115200
!
In my case Frame01 is a 2512, and Frame02 is an AS2511-RJ, so I use
the octopus cable on the 2512 to connect async port 16 as in my previous
E-mail. I did not try the authors setup, however, my adaption to the
equipment at hand has proven to work quite well. (With the restrictions I
noted in the previous E-mail. (It took Cisco TAC a week to figure out the
IOS version differences I mentioned, but that's another story.)) My
configuration gives three synchronous serial ports in a full mesh
configuration. By changing the Frame-Relay Route statements on the serial
interface's and / or including other serial interfaces, it should be
possible to build as big a Frame-Relay network as desired. (Not that I would
recommend it for any kind of production environment.)
Also, using the tunneling via async technique, it should be possible
to add various simulated network connections of other types. I have not
tried this yet, but as the needs of my CCIE studies grow, it shows promise
of allowing for various scenerio's that would not otherwise be possible.
Whatever helps can't be all bad,
Mike
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:22:52 GMT-3