From: Manjeet Chawla (mchawla@xxxxxxxxxx)
Date: Tue Jan 04 2000 - 20:27:59 GMT-3
The point in having middle router as RR is to eliminate the prerequisite of
having full mesh between the IBGPs. If RR was not configured then R3 will not
propagate the routes it learnt from R2 to R4. Correct me if I am wrong, BGP ha
s
a rule: "When a BGP speaker receives an update from the BGP speaker in it's ow
n
AS (IBGP), the receiving BGP speaker will not redistribute that information to
other BGP (IBGP or EBGP) speakers in its own AS".
Also, as Murali mentioned below, RR can use Next-hop-self only for the EBGP
learned routes only because the next-hop of the reflected routes should not be
changed.
Hope this helps.
Manjeet
Muralidhar Devarasetty wrote:
> About U'r 40.x.x.x I didn't understand the question properly.B'se I feel it
> is correct.
> U used nexthop self in R2 so U see that address as next Hop in R3 and R4.
> Reg 30.x.x.x
> U can't use next hop self command on Routereflector .It won't work for U.I
> don't remember whether it is documented in Halabi or in BGP case studies
> from cisco site but I am sure U can't use on RR.
> Good luck
> Murali
>
> ----Original Message Follows----
> From: "Naushad Prasla" <naushad.prasla@sabre.com>
> Reply-To: "Naushad Prasla" <naushad.prasla@sabre.com>
> To: "Brad Hedlund" <BHedlund@LifeTimeFitness.com>, <ccielab@groupstudy.com>
> Subject: RE: BGP Route Reflectors and Next-hop-self
> Date: Tue, 4 Jan 2000 14:51:06 -0600
>
> Brad,
>
> Please correct me if I am wrong. Would'nt both R3 and R4 need to be clients
> in order for these two Routers to exchange routes among them selves? Both R3
> and R4 are originating certain routes.
>
> Dennis,
>
> here is pertinent configs from all Routers.
>
> Notice how R4 is showing next hop address for network 40.0.0.0 (orginated on
> R1) as 192.168.23.2. Also, notice how R2 is showing next hop address for
> network 30.0.0.0 (originated on R4) as 192.168.13.2. Neither of these next
> hops addresses shows to directly connected despite of the Next-hop-self
> command.
>
> Here is the topology map just to make it bit easier.
>
> R1-.1-----192.168.12.0-----.2-R2-.2-----192.168.23.0-----.3-R3-.1-----.2-R4
>
> *******************************************************
> R1#
>
> interface Serial0
> ip address 192.168.12.1 255.255.255.0
>
> router ospf 1
> network 192.168.0.0 0.0.255.255 area 0
>
> router bgp 1
> network 40.0.0.0
> neighbor 192.168.12.2 remote-as 2
>
> ip classless
> ip route 40.0.0.0 255.0.0.0 Null0
> !
> R1# sh ip bgp
> BGP table version is 5, local router ID is 192.168.12.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 10.0.0.0 192.168.12.2 0 2 i
> *> 20.0.0.0 192.168.12.2 0 0 2 i
> *> 30.0.0.0 192.168.12.2 0 2 i
> *> 40.0.0.0 0.0.0.0 0 32768 i
>
> *******************************************************************
> R2#
>
> interface Serial0
> ip address 192.168.23.2 255.255.255.0
>
> interface Serial1
> ip address 192.168.12.2 255.255.255.0
>
> router ospf 1
> network 192.168.12.0 0.0.0.255 area 0
> network 192.168.23.0 0.0.0.255 area 0
> !
> router bgp 2
> no synchronization
> network 20.0.0.0
> neighbor 192.168.12.1 remote-as 1
> neighbor 192.168.23.3 remote-as 2
> neighbor 192.168.23.3 next-hop-self
> !
> ip classless
> ip route 20.0.0.0 255.0.0.0 Null0
> !
> R2#
> R2# sh ip bgp
> BGP table version is 18, local router ID is 192.168.23.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *>i10.0.0.0 192.168.23.3 0 100 0 i
> *> 20.0.0.0 0.0.0.0 0 32768 i
> *>i30.0.0.0 192.168.13.2 0 100 0 i
> *> 40.0.0.0 192.168.12.1 0 0 1 i
> R2#
> *******************************************************
> R3#
> !
> interface Serial0
> ip address 192.168.23.3 255.255.255.0
>
> interface Serial1
> ip address 192.168.13.1 255.255.255.0
>
> router ospf 1
> network 192.168.3.0 0.0.0.255 area 0
> network 192.168.13.0 0.0.0.255 area 0
> network 192.168.23.0 0.0.0.255 area 0
> !
> router bgp 2
> no synchronization
> network 10.0.0.0
> neighbor 192.168.13.2 remote-as 2
> neighbor 192.168.13.2 route-reflector-client
> neighbor 192.168.13.2 next-hop-self
> neighbor 192.168.23.2 remote-as 2
> neighbor 192.168.23.2 route-reflector-client
> neighbor 192.168.23.2 next-hop-self
> !
> ip classless
> ip route 10.0.0.0 255.0.0.0 Null0
> !
> R3#
> R3#sh ip bgp
> BGP table version is 7, local router ID is 192.168.23.3
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 10.0.0.0 0.0.0.0 0 32768 i
> *>i20.0.0.0 192.168.23.2 0 100 0 i
> *>i30.0.0.0 192.168.13.2 0 100 0 i
> *>i40.0.0.0 192.168.23.2 0 100 0 1 i
> R3#
> *******************************************************
> R4#
> interface Serial0
> ip address 192.168.13.2 255.255.255.0
>
> router ospf 1
> network 192.168.0.0 0.0.255.255 area 0
>
> router bgp 2
> no synchronization
> network 30.0.0.0
> neighbor 192.168.13.1 remote-as 2
> !
> ip classless
> ip route 30.0.0.0 255.0.0.0 Null0
> !
> R4#
> R4#sh ip bgp
> BGP table version is 20, local router ID is 192.168.13.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *>i10.0.0.0 192.168.13.1 0 100 0 i
> *>i20.0.0.0 192.168.23.2 0 100 0 i
> *> 30.0.0.0 0.0.0.0 0 32768 i
> *>i40.0.0.0 192.168.23.2 0 100 0 1 i
> R4#
> R4#
>
> -----Original Message-----
> From: Brad Hedlund [mailto:BHedlund@LifeTimeFitness.com]
> Sent: Tuesday, January 04, 2000 10:48 AM
> To: 'Naushad Prasla'; ccielab@groupstudy.com
> Subject: RE: BGP Route Reflectors and Next-hop-self
>
> Why is R2 a route relfector client of R3?
> The only route-reflection needed in this scenario is from R3 to R4.
>
> R2 and R3 should have an IBGP session.
> R3 and R4 should have an IBGP session.
> R3 reflects prefixes to R4.
>
> Then, configure next-hop-self on R3 pointing to R2 and R4.
>
> Try that.
>
> -Brad
>
> >
> > R1 --- R2 --- R3 ---- R4
> >
> > R1 and R2 running EBGP
> > R2, R3, and R4 running IBGP
> >
> > R2 and R4 are the clients of R3 which is a route reflector. I have two
> > next-hop-self commands in R3 for each of R2 and R4.
> >
> > Routes in R4 which are originated by R2 and "reflected" by R3
> > still shows R2
> > as the next hop address. Similarly, routes in R2 which are
> > originated by R4
> > show R4 as the next hop address. My goal is to show R3 as the
> > next hop for
> > routes going between R2 and R4.
> >
> >
> > I do have a config if anyone is interest..I have already rebooted,
> > reconfigured and used Route-map to set IP next hop..Nothing worked...
> >
> >
> > Any ideas...
> >
> > Naushad Prasla
> >
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:22:43 GMT-3