Re: BGP and OSPF redistribution

From: Joe Soricelli (jsoricelli@xxxxxxxx)
Date: Wed Apr 28 1999 - 16:07:47 GMT-3


   
Mark and all,

Just got a chance to try this in my lab. First, did a redistribute
connected ito OSPF on router 1. This worked as expected and routers 2 and 3
saw the EBGP subnet.

The attached configs show the setup NOT using a redistribute connected. It
has the 172.17.0.0/16 route summary being advertised from router 4. This
gets to routers 2 and 3 and they are able to ping the EBGP subnet
interfaces.

-joe

P.S. I used Ethernet between 1 & 4 and 2 & 3, but the theory/layout is
still the same.

-----Original Message-----
From: Mark Mirrotto <mmirrott@stratos.net>
To: 'Joe Soricelli' <jsoricelli@fridge.ccci.com>; ccielab@groupstudy.com
<ccielab@groupstudy.com>
Date: Wednesday, April 28, 1999 2:02 PM
Subject: RE: BGP and OSPF redistribution

>The area 0 network is 172.17.59.16 / 28 with the 3 interfaces in question
>being .17 .18 & .19.
>The E0 network on R4 is 172.17.59.160 / 30 Ethernet 0 on R4 is set to
>172.17.59.161
>The token ring network that R2 & R3 share is 172.17.59.128 / 28 with the 2
>interfaces set to .129 & .130 and is in OSPF area 1
>I have the ip classless statements around the house, I have 'no summary'
>statements in the BGP processes, and I am using the appropriate masks in
>the BGP network statements.
>My OSPF redistribute command includes the subnets parameter.
>R2 & R3 can see the 160 network from R4, and R4 can see the 128 and 16
>network. R2 & R3 cannot see the .0 network. Since I am subnetting down a
>class B, I don't need to worry about the IP subnet zero, but the commands
>are there anyway.
>I did try a few things last night, including redistributing connected on R1
>and the route to the 0 subnet still didn't show up on R2 & R3.
>I think that's everything.
>Thanks!
>
>
>-----Original Message-----
>From: Joe Soricelli [SMTP:jsoricelli@ccci.com]
>Sent: Wednesday, April 28, 1999 12:34 PM
>To: ccielab@groupstudy.com
>Subject: Re: BGP and OSPF redistribution
>
>Can you supply some IP addressing information on the links? Specifically,
>the E0 on router 4, the EBGP link, and the 2 area 0 links on router 1?
>-----Original Message-----
>From: Mark Mirrotto <mmirrott@stratos.net>
>To: 'Joe Soricelli' <jsoricelli@fridge.ccci.com>; ccielab@groupstudy.com
><ccielab@groupstudy.com>
>Date: Wednesday, April 28, 1999 1:29 PM
>Subject: RE: BGP and OSPF redistribution
>
>
>>Router 1 has the network statement. Sorry, I should have given more
>details.
>>
>>-----Original Message-----
>>From: Joe Soricelli [SMTP:jsoricelli@ccci.com]
>>Sent: Wednesday, April 28, 1999 8:56 AM
>>To: ccielab@groupstudy.com
>>Subject: Re: BGP and OSPF redistribution
>>
>>Does router 1 or 4 have the network between them listed as a network
>>statement under BGP?
>>
>>-joe
>>-----Original Message-----
>>From: Mark Mirrotto <mmirrott@stratos.net>
>>To: 'ccielab@groupstudy.com' <ccielab@groupstudy.com>
>>Date: Wednesday, April 28, 1999 8:42 AM
>>Subject: BGP and OSPF redistribution
>>
>>
>>>I am having problems in my test lab getting BGP routes to redistribute
>into
>>>my routing tables. Here is the scenario:
>>>
>>>R1 is running OSPF over a multipoint frame relay connection to R2 and R3.
>>>This is OSPF area 0
>>>R2 and R3 are also connected via their token ring interfaces in OSPF area
>>>1.
>>>R1 also has an EBGP connection to R4 over a point-to-point frame relay
>>>connection. R4 is advertising the network connected to its ethernet.
>>>R1 is mutually redistributing OSPF and BGP. The rest of the OSPF routers
>>>see the BGP route from R4, and R4 sees the rest of the OSPF network. The
>>>problem is R1 is not propagating the network connecting R1 and R4 (the
>EBGP
>>>network) even though there is a network statement under the BGP routing
>>>process.
>>>If I extend the OSPF area 0 to include the network connecting to R4,
>>>everything works fine. I guess the bottom line is I need to get this
>route
>>>into the routing tables somehow without using static routes, and without
>>>using OSPF. Any ideas?
>>>Thanks
>>>
>>
>>
>
>
version 11.3
no service password-encryption
!
hostname router1
!
!
!
interface Ethernet0
 ip address 172.17.59.1 255.255.255.240
 no lat enabled
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 encapsulation frame-relay
!
interface Serial2.1 multipoint
 ip address 172.17.59.17 255.255.255.240
 ip ospf network point-to-multipoint
 frame-relay map ip 172.17.59.18 312 broadcast
 frame-relay map ip 172.17.59.19 313 broadcast
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 redistribute bgp 1 metric 1000 subnets
 network 172.17.59.17 0.0.0.0 area 0
!
router bgp 1
 redistribute ospf 1
 neighbor 172.17.59.2 remote-as 2
 no auto-summary
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

version 11.3
no service password-encryption
!
hostname router2
!
!
!
interface Ethernet0
 ip address 172.17.59.129 255.255.255.240
 no lat enabled
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 encapsulation frame-relay
!
interface Serial2.1 point-to-point
 ip address 172.17.59.18 255.255.255.240
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 321
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 network 172.17.59.18 0.0.0.0 area 0
 network 172.17.59.129 0.0.0.0 area 1
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

version 11.3
no service password-encryption
!
hostname router3
!
!
!
interface Ethernet0
 ip address 172.17.59.130 255.255.255.240
 no lat enabled
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 encapsulation frame-relay
!
interface Serial2.1 point-to-point
 ip address 172.17.59.19 255.255.255.240
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 331
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 network 172.17.59.19 0.0.0.0 area 0
 network 172.17.59.130 0.0.0.0 area 1
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

version 11.3
no service password-encryption
!
hostname router4
!
!
!
interface Loopback0
 ip address 172.17.59.161 255.255.255.252
!
interface Ethernet0
 ip address 172.17.59.2 255.255.255.240
 no lat enabled
!
interface Serial0
 no ip address
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router bgp 2
 network 172.17.0.0
 neighbor 172.17.59.1 remote-as 1
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:36 GMT-3