RE: BGP AS-PATH PREPEND

From: Jeff Lodwick <jeff_at_tydesystems.com>
Date: Fri, 10 Jan 2014 13:41:07 -0700

Your understanding of the traffic being re-routed over the Layer 2 link is
correct. If you are referring to controlling traffic after it is re-routed
over to the Layer 2 link than Marc is correct that you will need to
configure QOS to accomplish this. In your scenario you would configure a
priority queue and match an extended ACL with the source subnet of
10.80.10.0/24 and specify the amount of bandwidth reserved. Just be careful
of the amount of bandwidth you reserve for this because when you configure
priority with MQOS using the "priority" keyword you're also policing the
traffic at times of congestion to the amount you specify (non-congestion the
priority queue can exceed the bandwidth reserved). Please note you can only
configure 1 priority queue (technically 2 priority classes but they are part
of the same queue that's serviced FIFO) and the priority queue is generally
reserved for voice traffic in the real world. After you configure the
priority queue you can then put everything else in the default queue (class
class-default) or create other queues and assign bandwidth reservations as
needed. I've provided an example of this below. In the configuration below
all remaining traffic will fall in the default class. Please let me know if
you have any further questions.

 

access-list 101 permit ip 10.80.10.0 0.255.255.255 any

 

class-map match-any SOURCE

match access-group 101

!

policy-map QOS

class SOURCE

  priority percent 30

!

interface gig 0/1

service-policy output QOS

 

Tyde Systems is a company that provides mainly Cisco network consulting
services (but can also help with other vender equipment) and customized
software solutions such as our Inventory Management System that periodically
checks EOL status of your devices. Give us a try and mention that you heard
about us from the CCIE groupstudy and receive 20% off our standard rate. We
are also currently offering a free network assessment of up to 10 network
devices where you can try our services for free.

 

Jeffrey Lodwick - CCIE 15671 R&S
Senior Data Engineer / Owner
Jeff_at_tydesystems.com
Office: 303-346-9988
Mobile: 303-919-1366
Tyde Systems

www.tydesystems.com <http://www.tydesystems.com/>

 

From: marc abel [mailto:marcabel_at_gmail.com]
Sent: Friday, January 10, 2014 12:45 PM
To: Cisco Fanatic
Cc: Jeff Lodwick; Sam Bibby; Tony Singh; ccielab_at_groupstudy.com
Subject: Re: BGP AS-PATH PREPEND

 

You can do that with QOS but not directly through BGP.

 

On Fri, Jan 10, 2014 at 1:40 PM, Cisco Fanatic <ebay_products_at_hotmail.com>
wrote:

Ok. I will try this.
 
What if one of my link goes down. For example - MPLS link between R1 and R3
goes down. My understanding is that all the traffic will re-route to Layer
2.
 
Is there a way to make sure that we can set priority so that traffic
originating from 10.80.10.0/24 takes priority over 10.80.20.0/24 (say).
 

  _____

From: jeff_at_tydesystems.com
To: ebay_products_at_hotmail.com; marcabel_at_gmail.com

CC: sammybibs_at_gmail.com; mothafungla_at_gmail.com; ccielab_at_groupstudy.com
Subject: RE: BGP AS-PATH PREPEND

Date: Wed, 8 Jan 2014 11:46:11 -0700

 

Now I see where your confusion is. You can't do AS path prepend for a
"path" like it looks like you're thinking. AS path prepend is used for
manipulating routes (as Marc mentioned) generally to a provider to affect
the "cloud" whether it be MPLS or internet. Also since you need to affect
traffic in both directions generally you would need to use something like
Weight or Local Preference as well as AS path prepend to manipulate traffic
coming out of R1 and R2 as well as traffic coming back from R3. In your
specific scenario you can set Weight on both R1 and R2 (granted they are in
different BGP AS's) for all traffic from R3 and not worry about AS path
prepend. This way all the routes from R3 will have a higher weight (on both
R1 and R2) and therefore be preferred over routes from R1 and R2.

 

Also good work with all caps on your route-map statements! This is what I
recommend as it helps with typos using a combination of upper and lower
case.

 

Please note I'm making some assumptions here with the BGP AS's you are
using. Please let me know if you have any questions.

 

--------------------

 

R1:

router bgp 65500

neighbor 10.255.255.1 route-map WEIGHT_CHANGE in

!

route-map WEIGHT_CHANGE permit 10

set weight 100

 

R2:

router bgp 65501

neighbor 10.255.255.21 route-map WEIGHT_CHANGE in

!

route-map WEIGHT_CHANGE permit 10

set weight 100

 

---------------------

 

Jeffrey Lodwick - CCIE 15671 R&S
Senior Data Engineer / Owner
Jeff_at_tydesystems.com
Office: 303-346-9988
Mobile: 303-919-1366
Tyde Systems

www.tydesystems.com <http://www.tydesystems.com/>

 

From: Cisco Fanatic [mailto:ebay_products_at_hotmail.com]
Sent: Wednesday, January 08, 2014 11:12 AM
To: Jeff Lodwick; 'marc abel'
Cc: 'Sam Bibby'; 'Tony Singh'; ccielab_at_groupstudy.com
Subject: RE: BGP AS-PATH PREPEND

 

Let me try to put this is perspective so that I help myself understand BGP
effectively. This is how I have setup in my lab.
 
Topology
++++++++
 
R1 (10.255.0.25) ------------------ (10.255.0.26) R2
|
|

(10.3.0.1) (10.13.0.1)
                        | |
                        | |
 (10.255.255.1) (10.255.255.21)
                             R3
 
R1 & R2 is directly connected. Think of it as P-2-P link, I call it Layer 2
connection.
R3 is a router in simulated MPLS cloud.
R1 second interface 10.3.0.1 is connected to R3 10.255.255.1
R2 second interface 10.13.0.1 is connected to R3 10.255.255.21
 
Objective
++++++++
 
1) All traffic originated by users and systems in R2 that is accessing R1
will utilize the MPLS cloud as the primary path with the Layer 2 as their
secondary path.
2) Data replication traffic will only utilize Layer 2 as the primary path.
3) In the event connectivity between R1 & R3 is lost, all traffic should
traverse Layer 2.
 
-Yuri
 
 

> From: jeff_at_tydesystems.com
> To: marcabel_at_gmail.com; ebay_products_at_hotmail.com
> CC: sammybibs_at_gmail.com; mothafungla_at_gmail.com; ccielab_at_groupstudy.com
> Subject: RE: BGP AS-PATH PREPEND
> Date: Wed, 8 Jan 2014 10:45:09 -0700
>
> Marc,
> You are correct here. That's why I was asking where this host route was
> because I didn't see it in the BGP table and I didn't see a network
> statement advertising it (if it's in the IGP table already).
>
> Jeffrey Lodwick - CCIE 15671 R&S
> Senior Data Engineer / Owner
> Jeff_at_tydesystems.com
> Office: 303-346-9988
> Mobile: 303-919-1366
>
> www.tydesystems.com
>
>
> -----Original Message-----
> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
marc
> abel
> Sent: Wednesday, January 08, 2014 10:20 AM
> To: Cisco Fanatic
> Cc: Sam Bibby; Tony Singh; ccielab_at_groupstudy.com
> Subject: Re: BGP AS-PATH PREPEND
>
> That access-list isn't going to match any routes. Remember you are
matching
> routes not flows so you can't specify a source and destination.
>
>
> On Wed, Jan 8, 2014 at 10:53 AM, Cisco Fanatic
> <ebay_products_at_hotmail.com>wrote:
>
> > Because I only want 10.100.60.11 (source) to go over Layer 2 (a name)
> > 10.20.80.11 (destination). The rest should all be prepended.
> >
> > ip access-list extended OVER_L2
> > permit ip host 10.100.60.11 host 10.20.80.11
> >
> > With your suggestion all the traffic will be prepended (longer AS
> > path) and it will not be the best route.
> >
> >
> > Date: Wed, 8 Jan 2014 16:36:40 +0000
> > Subject: Re: BGP AS-PATH PREPEND
> > From: sammybibs_at_gmail.com
> > To: ebay_products_at_hotmail.com
> > CC: mothafungla_at_gmail.com; ccielab_at_groupstudy.com
> >
> > I'm pretty sure the route map is wrong here,
> >
> > !!!Yours
> >
> > !
> > !You match the ACL but don't do anything with it.
> > !
> >
> > route-map AS_CHANGE permit 10
> >
> > match ip address OVER_L2
> >
> > !
> > ! You then pre-pend everything via the match all in the next statement
> > !
> >
> > route-map AS_CHANGE permit 20
> >
> > set as-path prepend 65500 65500 65500
> >
> > !
> >
> >
> > !!!Suggestion
> >
> > !
> > !You match the ACL but don't do anything with it.
> > !
> >
> > route-map AS_CHANGE permit 10
> >
> > match ip address OVER_L2
> > set as-path prepend 65500 65500 65500 !
> >
> > \Sam
> >
> >
> > On Wed, Jan 8, 2014 at 4:31 PM, Cisco Fanatic
> > <ebay_products_at_hotmail.com>
> > wrote:
> >
> > Sorry, cut-paste issue, too many notepad open.
> >
> >
> > R1
> >
> > ++
> >
> >
> > !
> >
> > router bgp 65500
> >
> > neighbor 10.255.0.26 route-map AS_CHANGE out
> >
> > !
> >
> > route-map AS_CHANGE permit 10
> >
> > match ip address OVER_L2
> >
> > !
> >
> > route-map AS_CHANGE permit 20
> >
> > set as-path prepend 65500 65500 65500
> >
> > !
> >
> > ip access-list extended OVER_L2
> >
> > permit ip host 10.100.60.11 host 10.20.80.11
> >
> > !
> >
> >
> > It is still going over the other connection...
> >
> >
> > R1#traceroute 10.20.80.11
> >
> > Type escape sequence to abort.
> >
> > Tracing the route to 10.20.80.11
> >
> > VRF info: (vrf in name/id, vrf out name/id)
> >
> > 1 10.255.255.1 4 msec 0 msec 4 msec
> >
> > 2 10.255.255.22 [AS 1] 4 msec 0 msec 4 msec
> >
> > 3 10.13.0.253 [AS 65501] 4 msec 4 msec 0 msec
> >
> >
> >
> >
> >
> >
> >
> > > Subject: Re: BGP AS-PATH PREPEND
> >
> > > From: mothafungla_at_gmail.com
> >
> > > Date: Wed, 8 Jan 2014 15:59:21 +0000
> >
> > > CC: ccielab_at_groupstudy.com
> >
> > > To: ebay_products_at_hotmail.com
> >
> > >
> >
> > > Where's your match extended ACL in route-map condition ?
> >
> > >
> >
> > > --
> >
> > > BR
> >
> > >
> >
> > > Tony
> >
> > >
> >
> > > > On 8 Jan 2014, at 15:47, Cisco Fanatic <ebay_products_at_hotmail.com>
> > wrote:
> >
> > > >
> >
> > > > I understand how AS-PATH PREPEND works, but I am not able to make
> > > > it
> > work
> >
> > if I
> >
> > > > need to manipulate traffic paths only from a specific source to a
> >
> > specific
> >
> > > > destination.
> >
> > > >
> >
> > > > R1
> >
> > > > ++
> >
> > > >
> >
> > > > !
> >
> > > > router bgp 65500
> >
> > > >
> >
> > > > neighbor 10.255.0.26 route-map AS_CHANGE out
> >
> > > >
> >
> > > > !
> >
> > > > route-map AS_CHANGE permit 10
> >
> > > >
> >
> > > > set as-path prepend 65500 65500 65500
> >
> > > >
> >
> > > > !
> >
> > > >
> >
> > > > R2
> >
> > > > ++
> >
> > > >
> >
> > > > !
> >
> > > > router bgp 65501
> >
> > > >
> >
> > > > neighbor 10.255.0.25 route-map AS_CHANGE out
> >
> > > >
> >
> > > > !
> >
> > > > route-map AS_CHANGE permit 10
> >
> > > >
> >
> > > > set as-path prepend 65501 65501 65501
> >
> > > >
> >
> > > > !
> >
> > > >
> >
> > > > R1#sh ip bgp
> >
> > > > BGP table version is 196, local router ID is 10.255.255.2
> >
> > > > Status codes: s suppressed, d damped, h history, * valid, > best,
> > > > i -
> >
> > > > internal,
> >
> > > > r RIB-failure, S Stale, m multipath, b backup-path, x
> >
> > > > best-external, f RT-Filter
> >
> > > > Origin codes: i - IGP, e - EGP, ? - incomplete
> >
> > > > Network Next Hop Metric LocPrf Weight Path
> >
> > > > *> 10.3.0.0/16 0.0.0.0 0 32768 ?
> >
> > > > *> 10.7.0.0/24 0.0.0.0 0 32768 ?
> >
> > > > *> 10.11.0.0/24 0.0.0.0 0 32768 ?
> >
> > > > *> 10.13.0.0/16 10.255.255.1 0 1 65501 ?
> >
> > > > * 10.255.0.26 0 0 65501
> > 65501
> >
> > 65501
> >
> > > > 65501 ?
> >
> > > > *> 10.16.0.0/24 0.0.0.0 0 32768 ?
> >
> > > > *> 10.20.0.0/24 10.255.255.1 0 1 65501 ?
> >
> > > > * 10.255.0.26 28416 0 65501
> > 65501
> >
> > 65501
> >
> > > > 65501 ?
> >
> > > >
> >
> > > > I need specific traffic from 10.100.60.11 (Source) to specific
> >
> > 10.20.80.11
> >
> > > > (Destination) over the 10.255.0.26 connection.
> >
> > > >
> >
> > > >
> >
> > > > 10.100.60.11
> >
> > > > _` 10.20.80.11
> >
> > > >
> >
> > > >
> >
> > > > Any thoughts?
> >
> > > >
> >
> > > >
> >
> > > > Blogs and organic groups at http://www.ccie.net
> >
> > > >
> >
> > > > __________________________________________________________________
> > > > _____
> >
> > > > Subscription information may be found at:
> >
> > > > http://www.groupstudy.com/list/CCIELab.html
> >
> > >
> >
> > >
> >
> > > Blogs and organic groups at http://www.ccie.net
> >
> > >
> >
> > > ____________________________________________________________________
> > > ___
> >
> > > Subscription information may be found at:
> >
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> >
> > ______________________________________________________________________
> > _
> >
> > Subscription information may be found at:
> >
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > ______________________________________________________________________
> > _ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> >
> >
> >
> >
> >
>
>
> --
> Marc Abel
> CCIE #35470
> (Routing and Switching)
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>

 

-- 
Marc Abel
CCIE #35470
(Routing and Switching)
Blogs and organic groups at http://www.ccie.net
Received on Fri Jan 10 2014 - 13:41:07 ART

This archive was generated by hypermail 2.2.0 : Sat Feb 01 2014 - 10:24:52 ART