Re: cisco access point vlan issue

From: Hasan AKSOY <hasan_at_agirol.com>
Date: Thu, 13 Dec 2012 00:41:33 +0200

here is my sw1 all config ;

  SW1 working correctly but sw2 working only vlan1 cannot work on vlan19

*********SW1 CONFIG*******

Current configuration : 19601 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXX
!
boot-start-marker
boot-end-marker
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
no ip dhcp use vrf connected
ip dhcp pool CONNECT
    network 172.20.68.0 255.255.255.0
    domain-name XXX
    netbios-name-server 172.16.68.5 172.16.10.81
    netbios-node-type h-node
    default-router 172.20.68.1
    dns-server 172.16.68.5 172.16.10.81
    lease 0 3
!
ip dhcp pool XXX
    network 172.26.68.0 255.255.255.0
    domain-name XXX
    netbios-name-server 172.16.68.5 172.16.10.81
    netbios-node-type h-node
    default-router 172.26.68.1
    dns-server 172.16.68.5 172.16.10.81
    lease 0 3
!
ip dhcp pool Guest-WLAN
    network 172.27.68.0 255.255.255.0
    domain-name XXX
    netbios-node-type h-node
    default-router 172.27.68.1
    dns-server 200.59.96.90 200.54.144.227
    lease 0 3
!
!
!
mls qos map policed-dscp 24 26 46 to 0
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22
23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39
48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55
56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30
31
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46
47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46
47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30
31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54
55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62
63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22
23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38
39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint TP-self-signed-XXXX
  enrollment selfsigned
  subject-name cn=IOS-Self-Signed-Certificate-XXX
  revocation-check none
  rsakeypair TP-self-signed-XXX
!
!
crypto pki certificate chain TP-self-signed-XXX
  certificate self-signed 01
   XXXXXXXXXXXXXXXX
   quit
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
class-map match-all AutoQoS-VoIP-RTP-Trust
  match ip dscp ef
class-map match-all AutoQoS-VoIP-Control-Trust
  match ip dscp cs3 af31
!
!
policy-map AutoQoS-Police-CiscoPhone
  class AutoQoS-VoIP-RTP-Trust
   set dscp ef
   police 1000000 8000 exceed-action policed-dscp-transmit
  class AutoQoS-VoIP-Control-Trust
   set dscp cs3
   police 1000000 8000 exceed-action policed-dscp-transmit
!
!
!
interface FastEthernet0/1
  switchport access vlan 999
  switchport mode access
!
interface FastEthernet0/2
  switchport access vlan 999
  switchport mode access
interface FastEthernet0/3
  switchport access vlan 999
  switchport mode access
!
interface FastEthernet0/4
  switchport access vlan 999
  switchport mode access
!
interface FastEthernet0/5
  description Inside Interface XXX (172.19.68.5)
  switchport mode trunk
  spanning-tree portfast
!
interface FastEthernet0/6
  description Interface XXX 172.16.68.1 (temp. because of VLAN issues)
  switchport trunk allowed vlan 1,18-20,26,27
  switchport mode trunk
!
interface FastEthernet0/7
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/8
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/9
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/10
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/11
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
  interface FastEthernet0/12
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/13
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/14
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/15
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/16
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/17
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/18
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
interface FastEthernet0/19
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/20
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/21
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/22
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/23
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/24
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/25
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/26
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/27
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/28
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/29
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/30
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/31
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/32
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
interface FastEthernet0/33
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/34
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/35
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/36
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/37
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/38
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/39
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/40
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/41
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/42
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/43
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/44
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/45
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/46
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!
interface FastEthernet0/46
  switchport voice vlan 19
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  spanning-tree portfast
  service-policy input AutoQoS-Police-CiscoPhone
!

!
interface FastEthernet0/48
  description Wireless Accesspoint XXX02 (172.16.68.8)
  switchport trunk allowed vlan 1-19
  switchport mode trunk
  srr-queue bandwidth share 10 10 60 20
  priority-queue out
  mls qos trust device cisco-phone
  mls qos trust cos
  auto qos voip cisco-phone
  service-policy input AutoQoS-Police-CiscoPhone
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
  switchport mode access
  spanning-tree portfast
!
interface GigabitEthernet0/4
  switchport mode trunk
!
interface Vlan1
  ip address 172.16.68.4 255.255.255.0
  no ip route-cache
!
interface Vlan13
  description test
  no ip address
  no ip route-cache
!
interface Vlan18
  description XXX Vlan for Climate control access
  ip dhcp relay information trusted
  ip address 172.18.68.3 255.255.255.0
  no ip route-cache
  no logging event link-status
!
interface Vlan19
  ip address 172.19.68.3 255.255.255.0
  no ip route-cache
!
interface Vlan20
  description XXX Vlan for Wireless Connect access
  ip dhcp relay information trusted
  ip address 172.20.68.3 255.255.255.0
  no ip route-cache
  no logging event link-status
!
interface Vlan26
  description XXX Vlan for Wireless access
  ip dhcp relay information trusted
  ip address 172.26.68.3 255.255.255.0
  no ip route-cache
  no logging event link-status
!
interface Vlan27
  description XXX Vlan for Wireless Guest access
  ip dhcp relay information trusted
  ip address 172.27.68.3 255.255.255.0
no ip route-cache
  no logging event link-status
!
interface Vlan31
  description XXX Vlan for Management access
  ip address 172.31.68.3 255.255.255.0
  no ip route-cache
  no logging event link-status
!
interface Vlan999
  no ip address
  no ip route-cache
!
ip default-gateway 172.16.68.1
ip http server
ip http secure-server
!
ip access-list extended Guest-WLAN-IN
  permit udp any any eq bootps
!
control-plane
!
!
line con 0
  exec-timeout 0 0
line vty 0 4
  password 7 XXX
  login
  length 0
  transport input telnet
  transport output telnet
line vty 5 15
  password 7 XXX
  login
  transport input none
!
ntp authenticate
ntp trusted-key 1
ntp clock-period 36028876
ntp server 172.16.8.203
end

Yeah maybe I am missing something because on switch 1 I see your IP address
as .4 not .1 so again what is doing the routing between vlan 19 and 1?

interface Vlan1
  ip address 172.16.68.4 255.255.255.0

> Yeah maybe I am missing something because on switch 1 I see your IP
> address
> as .4 not .1 so again what is doing the routing between vlan 19 and 1?
>
>
> interface Vlan1
> ip address 172.16.68.4 255.255.255.0
>
>

-- 
Using Opera's revolutionary email client: http://www.opera.com/mail/
Blogs and organic groups at http://www.ccie.net
Received on Thu Dec 13 2012 - 00:41:33 ART

This archive was generated by hypermail 2.2.0 : Tue Jan 01 2013 - 09:36:53 ART